FUDiabetes

New to dexcom and xdrip

Hi all I’m new to Dexcom and xdrip. I recently got approved to use dexcom g6 for cgm. My endo told me I wouldn’t need a receiver, that I would be able to use the dexcom app on my phone. Apparently dexcom hasn’t updated their software to Android 9.0. After a lot of searching I found Xdrip and was pretty excited to try it. At first it worked pretty good. I got about 6 readings (30mins) and the it wouldnt read anymore, that went all night. I Uninstalled and reinstalled 3 times with same results. What if anything can I do? I’m using a Samsung galaxy note 10 plus with android 9.0. Any and all help will be greatly appreciated. If it comes down to it I will be doing something different because I won’t carry an additional item along with my insulin pump and cell phone.

Hi @rscott1972 Welcome to FUD!

First, the obvious. In settings>g5/g6 debug did you check “I am using G6”? If not, then check it.
Next, with the G6 you can successfully use Native mode. Check “native algorithm”.

Next, check " allow OB1 initiate bonding", scan for G5 constantly", “authenticate G5 before each reading”. For now, also check “unbond G5 before each reading”. When it starts working this is the first thing to uncheck.

Next, in settings>less common settings>other misc options, check “run collector in foreground”, “Samsung Workaround”, and “proper ongoing”.

From your log it looks like your having intermittent GATT problems. This is where the BLE doesn’t allow more than one connection at a time, and your last connection is preventing a new one. These settings should fix that.

Good luck! Let us know how it goes.

Thank you so much for the quick reply. I’ve corrected all of the settings you suggested to me. I’m posting another screen shot of my logs and a screen shot of my home screen.

@rscott1972 Quick question–did you initially run the Setup Wizard? That’s the first step to getting started on the right foot.

Yes I ran the wizard. Made sure that transmitter and sensor were correct. I’ve Uninstalled 3 times now and pretty much get the same result. I even wasted a sensor thinking maybe I did something wrong. I really do appreciate your help. I’m not sure who I’m more disappointed with, my endo for telling me this is a great system, or Dexcom for their lack of ability to update their software.

Doc is the expert here, but I’ve been using xdrip for several months (with a much older phone) so I’ll just add what I check to help diagnose a problem. First I’d look at your bluetooth connection from your phone settings to make sure you are paired with the transmitter. Then check status page in xdrip: “System Status” tab on left side hamburger, showing connection status (and ability to “Restart Collector” which is the same thing that is being done when the log prints “Aggressively restarting collector”) and by swiping left will see G5/G6 Status which shows up to date info on bluetooth connection. Save and print these here if not straightforward.

Finally, I find my (old) phone occasionally gets stuck, and turning off/on bluetooth or even more directly forcing a phone restart (by power down/up) resets state and reestablishes the bluetooth connection and will often make things right again (assuming all your settings are correct).

I restarted my phone and made sure Bluetooth was connected only to the Dexcom. Here is a scree shot of my home screen now.

If not updated at the next five minute reading, check out the status pages I mentioned and show those here.

BTW, I wouldn’t be disappointed with either your endo or Dexcom (which is a great system in my experience). Your endo was just trying to save you some money, and Dexcom is trying to do the same by supplying an app to run on phones. If I were you I would be disappointed in google, who has decided to send out new android releases without supporting backwards compatibility for existing apps.

p.s. Did you install the Dexcom app on your phone before you installed xdrip? If you did that causes known problems and the Dexcom app must be completely removed and not just disabled - google it to find information.

Your earlier screenshot msgs indicate sensor start failed. Then start ok. Then other errors.

What is your transmitter ID first 2 digits ?

The latest versions are 8G, and they have additional checks during startup to prevent restart.

Another option is to check this. It is original dexcom app that by passes the check of phone version. I used this before trying xDrip on non-supported phone.

I’ve Uninstalled and reinstalled 3 more times. I officially believe I’m done with dexcom, I’ve spent the better part of a full day jacking around with this app and dexcom junk. I appreciate all of the help and info in trying to get me started with this but it all just goes back to not working.

Did you ever get this sorted out? I have the Note 10+ and the 8G transmitter. I have been using xdrip for 2 years. I can’t get it to stay connected either

No I never did get it figured out. I really wish someone would figure out a fix for this. I think I’d really like Xdrip over using dexcom.

you need to allow permissions in the apps setting of the phone. Settings- Apps- Xdrip-Change System settings- Allow and also allow install unknown apps. Also make sure permission is set on Location and Storage. Then on the Xdrip settings set in the debug settings make sure Use the OB1 Collector is unchecked. I have the note 10 plus and ran into your problem with the Dexcom app. I installed Xdrip and was having the same issues it would read and then stop. I did that and I have been getting steady readings since the 23rd. You might need after changing the xdrip settings and permissions on samsung app settings restart in the Xdrip app- system status and then click restart collector. I even have been able to use the same sensor for the last 14 days without it expiring. Enjoy!

What are the first two digits of your transmitter serial number?

The first 2 is 81

8G are the first digits of the transmitter I’m using. Ive tried all of the suggestions posed from here and still unable to get xDrip to work. I also have a Samsung Note 10 plus.

8G is the latest transmitter version, so not as many folks using yet. Your prior posts show you did get it working, but then errors.

Check this to see if it may be cause.