Dexcom G4 share not pairing with Xdrip on new phone (but worked fine on old one)

I’m a long-time Xdrip user who just upgraded his old phone (LG G3) to a nice shiny new one (LG G6). I don’t remember having any serious trouble setting up Xdrip on the old phone, but this new one absolutely will not pair with my receiver. I’ve disconnected, forgotten devices, restarted and pretty much everything I can think of multiple times but Xdrip will just not find the receiver. Correct receiver serial number and all of the settings (as far as I can see) are identical to what was working on the old phone. Is there some incompatibility with Android 7.0? Some buried system setting that I’m missing? Someone please help, this is driving me nuts!



@docslotnick, @Aaron, what do you think?

@bwschulz, welcome to the forum!

@bwschulz First, welcome!
I think your problem is the basic variability of Bluetooth implementations with Android phones. But a couple things you might try.

First, make certain under G5 debug settings you check “authenticate G5 before each read”.

Also, be sure to upgrade to the 20Sept Nightly. Jamaorham has included a rewrite of the G5 connectivity issues by introducing the OB1 G5 Collector. You have to enable Engineering Mode in Less Common Settings in order to see the OB1 Collector option.
You can enable Engineering Mode by long pressing the eyedroper icon on the home screen and saying “enable Engineering Mode” when Google voice pops up. Jamorham rewrote the G5 collector script to solve the variability of Bluetooth implementations among Android phones.

I tried the OB1 G5 collector and it did not work for my Samsung Note 4, and Jamorham said he was going to work on it some more, but hopefully it will work for your phone.

The last resort option, which is what I did from the start, is to get a Sony Smartwatch 3 and use that as the collector. I get 95-98% collection with it and it is way more convenient than pulling out my phone.

Let me know how it goes or if you need further info.

EDIT: Sorry, just noticed that you are talking about the G4 share, so you must be using a wixel. I’m not real familiar with the G4 wixel. The wixel developer, John, always seems to be around on the Jamorham xDrip+ Gitter group and a lot of the discussion is about the wixel.

EDIT2: Ignore the wixel thing I just wrote. Share does not use it, it connects via the receiver, duh.
But you may want to review the setup instructions:


Could it be a receiver issue that is blocking the new connection? Did you try a reset on the receiver? Use a paperclip on the little hole in the back of the receiver and hold the paperclip in for about 15 seconds until the receiver buzzes/vibrates then let go of the paperclip and let the receiver restart?

Kind of like turning the computer off and on and sometimes you get lucky and everything works after that?


Thanks for the suggestion- I forgot about that little reset hole. I assume that this restarts everything, including the sensor, so I’ll give that a shot tonight when I’m back home.

1 Like

The G5 transmitter would not reset based on a reset of the receiver.
It has been awhile since we have used the G4 so I don’t recall on the G4.

1 Like

The paperclip at work wouldn’t get to the restart button, but a needle at home did. But it didn’t help.

A few other questions/ideas:

  • Do I need to have the receiver connected to the phone via Bluetooth before I try pairing in Xdrip, do I need to keep it unpaired with the phone before doing it in Xdrip, or should this not matter?
  • The app info screen says that I’m using version “beta/2.0.5_2-7a93a06-experimental-xDrip2-beta-205-2-2016.02.20”, which looks like Beta5. There seems to be a Beta6 version available- would installing that be a good next step? Is there a different version elsewhere that would be better?
  • I transferred this app from my old phone (along with all of the others) via an app called “LG Mobile Switch”. This worked well for other apps and actually brought over my registration code from a paid app (which was a pain to transfer the time before that), but could something be sticking to this install from the other phone that is causing problems here?

I hope I can get this working again- I don’t want to have to wait for the (Dexcom) G6 before I can get my blood sugars on my (LG) G6 again. Any ideas or suggestions are very welcome!


@bwschulz 2016.2.20 was a long time ago in terms of xDrip and also Android phones. You should definitely upgrade to a newer version of xDrip or better yet xDrip+. Communities developing these Android apps to work with Dexcom are acutely aware of changing BLE implementations and try very hard to keep up on all of them while developing.

You can easily connect your LG G6 phone to Dexcom G5 currently. You can even get it on your watch, or even use a watch as the collector. You can do this via xDrip+.

I’m fairly certain that it would not matter. But make certain when you are trying to pair xDrip to your receiver that you enable location on your phone.

1 Like

@bwschulz, I know very little about Xdrip – but, as an engineer who often deals with complex systems, I have two suggestions:

  • A fresh install is definitely the way to go if you don’t get the transferred application to work right away. In fact, I would not make any more than a token attempt at it before doing a fresh install: too many things are likely to go wrong that nobody will be able to figure out.

  • I am not sure how to do that for Xdrip, but having a good understanding of the different branches of the code available, and how mature or experimental they are, that’s really valuable. I am pretty sure that someone here can point you in the right direction as to which version of the app is better for you to try – @docslotnick actually started going that way.

1 Like

xDrip or Drip+? Which version should I go for first? I’m just trying to get what I had working again.
I’ve got a Huawei watch that worked perfectly with my old setup and I’m trying to get it running again.

@bwschulz I don’t really have experience with xDrip, but I’ve been using xDrip+ for about eight months.

The reason I went with xDrip+ was the extended functions it provides, such as forward prediction. Also it seems to be the xDrip fork that is undergoing the most active development.

In sure you’ll be able to get the Huawei watch to display with xDrip+ although I don’t think it will work well as the collector (receiver).

If you have any problems getting xDrip+ to work for you I’ll be happy to help you get it going.


Reinstalling did it. Mostly works now. Only one minor missing feature from the last version (can’t use different sounds for rapid rise and rapid fall) and the low prediction looks like it could be useful. The only remaining major issue I have is that the graph displays on my watch initially (set watchface in Wear and resend glucose to watch in Xdrip) but after a while the screen goes black and when it comes back only the time (digital) is displayed (large white text on black background). I have to switch back to the Xdrip watchface in Wear to get the graph back, but it always disappears in 5 minutes or so. Any idea where this setting could be? Or should I uninstall and try the newer version of Xdrip (without the plus)?


@bwschulz You should probably use the latest version of whichever app you are comfortable using.

The Android Wear integration has been a focus of the most recent developments in xDrip and xDrip+.

Also, if you are using xDrip+ make sure under settings>smartwatch features you only have the slider set to “on” to send data to your watch. Make sure you uncheck all the options to have the watch act as collector. Also you may need to keep “location” enabled in your phone settings.


@bwschulz, just to confirm, are you using Xdrip or Xdrip+ right now?

I was using an older version of Xdrip, which I just uninstalled to install the latest version of Xdrip.
The watch screen issue seems more likely to be related to Wear, not Xdrip. I’ve figured out that within five minutes it switches the Xdrip face for one called “Simple” that doesn’t seem to exist on the phone. I can delete this face off the watch and it still adds it and switches it out for the Xdrip one. I despise Android 2.0 (I allowed it to upgrade by mistake when factory resetting to use with new phone) and was giving it a brief chance while looking for an excuse to factory reset it again to downgrade back to 1.5 or so. This is that excuse. I’ll try downgrading the watch, then switching back to Xrip (without the plus) if I keep having issues.


@bwschulz I have heard that Android Wear 2.0 and xDrip do not play together very well, including on the Huawei watch. I don’t recall seeing complaints about that watch before 2.0.

1 Like

@jroth, I know you are an xdrop+ user also – any thoughts?

Then I may very well be screwed. Apparently my mistaken upgrade didn’t just upgrade my watch’s OS, but also the factory reset files. Now my “factory reset” just resets everything in 2.0 and doesn’t downgrade me to 1.6 like it did last time.
I had previously tried to forcibly downgrade (, but I got stuck on step 13 (Win7 computer didn’t recognize watch) and I got around this usin factory reset, which did let me revert to 1.6 that time. I’ll guess I’ll just have to keep trying different computers (with Win10) and make it work somehow if Xdrip won’t work again.

I did uninstall Xdrip+ and install Xdrip and got it working this time after manually enabling location in the apps settings (I thought this had been enabled before but didn’t work for some reason). But now my problem is that all of my watch faces are gone. I reinstalled Xdrip and then installed Nightwatch too but still nothing. Anybody know where the watch faces are or how to get them back on my devices? They don’t show up on the phone or the watch now.

1 Like

Glad you got xDrip working on your new phone!
That is strange that the watch faces didn’t get installed with the app on your phone.

You can download the Nightscout watch faces here:

Or I believe if you reinstall xDrip the watch faces should automatically appear in Android Wear.

1 Like

That’s what I was afraid of- I’ve done both (reinstalled Xdrip and installed Nightwatch twice) and no watch faces yet. But I don’t even see the rest of my apps either, so I think my watch itself may be screwed up. It just doesn’t seem to be syncing any of my old apps since the “factory” reset to 2.0. I don’t even see another watchface I paid for and is still on my phone appear on my watch, so I think I need to contact Huawei customer support now.

1 Like