FUDiabetes

How do I start xdrip+ with a Dexcom?

Okay, so I rushed home, joined the Facebook group and have downloaded xDrip on my wife’s Samsung Galaxy S7. Now the problem I’m having is…I went through steps 1 - 17 in the xDrip guide and, since we have already had Liam’s sensor in since the 14th, I selected April 14th as the “sensor date”.

I then left the phone near him for 30 minutes (almost an hour actually) and it’s doing nothing. It’s stuck on a message “Please wait, need 2 readings from transmitter first.”

Am I supposed to do something manually here??? The guide doesn’t mention anything needed here. What am I missing?

1 Like

@ClaudnDaye Harold, a couple of questions:

  1. G4 or G5
  2. If G5, what date is the transmitter manufacture. If its recent, within the last six months, so the following: go into settings>G5 Debug> Check mark next to Authenticate before each reading. If this was not checked, and you check it now you’ll get a reading within 14 mins.
  3. I’m sure it is, but check to make sure Bluetooth is on on your phone
  4. recheck the the transmitter serial number in the settings.

Let me know what happens, I’ll be here.

Oh, and while you’re in G5 Debug settings, check scan for G5 constantly. Some phones work better with this setting checked.

1 Like

Just curious if there is an xDrip post somewhere. If not, maybe someone could spawn the details from this thread into one? I don’t know much about.

I’m currently putting an illustrated guide together. Should be up in about a week.

2 Likes

@TiaG Yes, the phone needs to be in Bluetooth proximity of the watch to function as the uploader. If it’s out of range of the phone then it picks up all the readings since it was disconnected from the watch.

The watch also can be as annoying as you want with alerts, visual and vibrating. High, low, ratell of rise, rate of fall, programmable alerts, you name it.

  1. G5 Mobile Transmitter
  2. 2017-05-19, so checked the box and will now wait 15 min. Should I “restart sensor”?
  3. Yes
  4. Number is correct, and listed as “Dexcom Transmitter ID” in the app.

Will do.

Update: Actually, there are two dates on the transmitter box…one reads “SB” and that date is the 2017-05-19 date. The other one doesn’t say anything…it’s just a squiggly lined image and reads 2016-09-19.

@ClaudnDaye no need to restart sensor. Just wait for the magic to happen :grinning:

Not sure exactly when Dexcom updated the transmitter software, but the last two transmitters I used required to authenticate before each reading setting

1 Like

It’s on now, so will update in 30 minutes or so. Right now it’s still reading the same thing…“Please wait, need 2 readings from transmitter first.”

@ClaudnDaye. Should have started up. Go into system status and press " restart collector"

and you did xdrip+, not xdrip, right? I actually don’t know if this is a dumb question but I sort of vaguely remember that xdrip needs other equipment but xdrip+ doesn’t?

@TiaG Xdrip now reads the G5 directly without the wixel needed for the G4

I’m using “XDrip G5” (I guess it’s xDrip specifically made for G5?)

This is the package name of the one I just downloaded: xDrip-plus-20170425-b79a73d.apk
"Nightly build 25th Apr 2017"

@ClaudnDaye Yes, that’s the most recent nighty build from the xDrip+ Github repository

@ClaudnDaye I’m off to bed now. Got an early meeting before office hours tomorrow morning. I’ll check back tomorrow morning. Hope xDrip+ starts working for you before then.

Will it have basic background info? What is xDrip, why do people use it, what advantages does it give, etc?

A quick update: No magic happened. :frowning: I left it all night. I’m on the road in a few minutes for work and will be back this evening. I plan to troubleshoot this tonight and into this weekend if necessary to try and get this working.

Thanks for the help thus far.

I’m surprised. We’ll get it working this weekend. Sorry.

No luck. I uninstalled the app and re-installed it. Multiple phone shutoffs as indicated in the troubleshooting section for xDrip. We also just today started up a new transmitter session on our son so I thought this would be a perfect time to begin anew with xDrip. Followed instructions…received “warm up” count down. The “2 calibrations” option never appeared. Now it’s stuck on the same message indicated above (2 readings from transmitter message.)

At one point (last night, before I started anew), I did receive the blue arrow and the 2 calibration option. I entered those 2 calibrations, but nothing happened. My xDrip install seems to only like the ‘2 readings from transmitter’ message…

Also, it DID show the device authenticated in the status.

I’ve tried restarting sensor, tried checking and unchecking the two optional settings listed ( “Scan For
G5 Constantly” and then try “Force G5 to UI Thread” - both together and separately), tried restarting collector. Tried forgetting device…tried everything listed in the troubleshooting section as well as anything I can find on the interwebs for troubleshooting. So far no luck. Not sure how to get the message to disappear (‘Please wait, need 2 readings from transmitter first.’) The phone is sitting right beside him and has been all night / morning.

Will keep trying other things, but so far, not looking good. It looks like a great app if I can just get it to start working…

@ClaudnDaye Harold, I tried to recreate your problems on my tablet. The way way I finally got it to start was to turn off my watch (what would be your iPhone, the receiver). I mean power down off.

This might be a bit scary for you because you’ll be without readings for about half an hour to forty five minutes. But for startup, the two receivers are bumping into one another too badly to get good connection on xDrip+.

After I powered down my watch, xDrip+ on my tablet took about 3
0 minutes to ask for the double calibration. Based on the Bluetooth stack on your Android you may not be able to use the iPhone for the receiver anymore.

Oh, and make sure location is enabled on the Android phone