FUDiabetes

G6 signal erratic losses with xDrip+

xdrip

#1

Hi all,

I just moved today from FSL and miaomiao to G6 for my 10 yo daughter.
I have the latest xdrip release and the warm up went well…

However, since that, I keep on having signal losses erratically… Sometimes it works perfectly for 4 or 5 consecutive readings and suddenly, I have signal missed for 15 min… 20 min…

G6 options on the phone:
Use the OB1 Collector is ticked
Native Algorithm is ticked

Any idea ?

Any options to tick ?


#2

@Kywalh Hi! And Welcome to FUD!

If you’re using a Samsung phone go into settings>> less common settings>>other misc options and check “buggy Samsung Workaround”.

Did you start the G6 with the startup wizard? That will make sure the optimum settings are enabled.


#3

@docslotnick thank you for your reply !
She has a Wiko phone and I went through the startup wizard, latest nightly built from the 10th of Jan…

Should I try to activate the Samsung option anyway ?

Thanks


#4

@Kywalh It wouldn’t hurt to run it.

Also, in G5/G6 Debug settings, tick “fallback to xDrip” and swe if that helps.


#5

@docslotnick I will try !!!
See the picture of the settings… If you see something…

Why can’t I put more than 1 picture ?


#6


#7


#8


#9


#10

@Kywalh Uncheck “allow OB1 unbonding”, “force G5 to ui thread”, “authenticate G5 before each reading”, G5 Bluetooth Watchdog"

Tick “Bluetooth Wakelocks”.

If this works you can try rechecking/unchecking items to find out what is breaking the system.

Also, on the three dot menu on the upper right xDrip+ home screen you can click “view events log” and see where it’s hanging up.


#11

@Kywalh Also you should know that Wiko has not been tested with xDrip+ so it is not on the recommended phone list.

This is, however, not a hard and fast list of phones that work. Just ones that have been tested.

https://github.com/NightscoutFoundation/xDrip/blob/master/Documentation/Phones_For_G5.md


#12

I made the changes you proposed…
Let see…

I know for the compatible phone and I don’t have any issue to buy a new one but I also need to ensure it works with AndroidAPS too…

@docslotnick

Enclosed a part of the log…


#13

@Kywalh Ok. It looks like GATT is not properly disengaging to allow a new session. This was a common problem on some older phones.

Go to "less common settings>>Bluetooth settings and tick “close GATT on BLE disconnect” and “Always Discover Services”.

I think that will get rid of that error.


#14

@docslotnick
Change done… Always discover services is ticked but greyed… So I cannot changed it…


#15

@Kywalh Oops, sorry. Engineering Mode must be enabled.

On the xDrip+ home screen, tap the eye dropper icon. In the treatment applet that pops up, click the microphone and say “Enable Engineering Mode”. There will be a confirmation toast that it was turned on. Go back and make sure discover services is ticked and not grayed out.


#16

@docslotnick
Even if already ticked ?


#17

@Kywalh Yes. It won’t be applied until engineering mode is enabled


#18

@docslotnick
Engineering mode enabled !

What shall I look at ? Log again ?


#19

@Kywalh Yes, look at the log again to see if you’re getting GATT related errors. If you are still consistently getting them, you may need to try another phone.


#20

@docslotnick
Ok… It seems that I still have those errors…
I need to change phones but I have no clue how to proceed since the sensor is started and the transmitter is paired…