FUDiabetes

xDrip+ Integration with Tidepool

Great News! Jamorham has just added Tidepool integration to xDrip+! He just announced that the code commit has been approved and added to the master program.

We should be seeing it in a day or two when the latest nightly update is released.

This is significant for a couple of reasons. First, Tidepool is an excellent platform, easier than Nightscout, to upload and share your data with followers and doctors. Second, Tidepool can push data to Dexcom Clarity.

Edit: I misspoke. Tidepool cannot currently push data to Clarity. But you can add a provider to Tidepool so that they can easily see your data there. It has much the same information as Clarity.

4 Likes

Hopefully it can post to both; I need the NS for OpenAPS but finally getting data into Clarity would avoid some of the eye rolling I get every time I go see the endo for sure!

1 Like

xDrip+ has for a long time been able to upload to NightScout, Just go to settings>Cloud Upload>Nightcout Sync.

Hi Doc, I finally found time to connect my dexcom/xDrip+ to a data collector, and picked Tidepool since that was free and easy to set up, (which I believe limited me to either Tidepool or Dexcom Clarity). Clarity would have made more sense since my endo supports that but not Tidepool, but xDrip doesn’t seem to support Clarity yet so Tidepool it was.

Are you using Tidepool? So far Tidepool only supports Google Chrome browser to view data; I avoid google whenever possible but relented and installed Chrome for this single use. Since connecting everything it has been uploading my data; I had more than a month’s worth so it is taking its time but getting there.

I was glad to see that it has kept the data going back to when I first started using xdrip (more than a month’s worth).

4 Likes

@jag1 That’s great! I’ve been uploading to Tidepool since JamOrHam released that xDrip+ capability.

It’s a neat service, but more geared to pump use. I’ve been going back and forth with Sugar Mate and Center Health for an alternate data service.

Sugar Mate looks really good. You just add them as a follower, and your data uploads from xDrip+. The data displayed is excellent, and it’s free.

The one thing xDrip+ needs to accomplish is to upload to Clarity. Hopefully that will be sooner than later, but it’s up to Dexcom at this point.

4 Likes

I’m using Tidepool and xDrip, too. I also upload omnipod to it. And use Nightscout Uploader to upload pump data to Nightscout. Hassle to physically upload pump data, but nice to see all data in one place!

1 Like

Hi@docslotnick. Any thoughts on an issue that I’m having with xdrip and tidepool. My xdrip data uploaded to Tidepool and then on Dec 26 stopped. It hasn’t uploaded since.

When I look at xdrip - System Status I see:

Tidepool Synced to: 5 weeks ago
Tidepool Status: Data Upload was not Sucessful: 400 Bad Request.

When I look at xdrip Settings - Cloud Upload- Tidepool and do aTest Tidepool login I get;

“Connecting to Tidepool” and then “Found Existing Remote Dataset”

I have updated to the most current nightly build and still no success.

Any thoughts on how I can get my data to continue uploading?

1 Like

@jim26 In system status where you can see the time since the last upload, just tap on “last poll” and see if it works.

1 Like

Do you have the latest xDrip+ build? xDrip+ now only works w/ the production site, https://app.tidepool.org. The test site is no longer supported.

If you haven’t already, create an account at that link, and update your credentials in xDrip+ Settings - Cloud - Tidepool.

1 Like

There is a checkbox in settings>cloud upload>tidepool that you can check if you still want to use the test site (int-app.tidepool.org) instead of the main site (app.tidepool.org).

Make sure it’s set to your preference.

2 Likes

@docslotnick Is that still working?

@Trying Seems to work for me, and I just updated yesterday.

1 Like

Ok, when I do that the below messages appear

  1. Connecting to tidepool
  2. Found Existing Remote Data Set

Tidepool Status says:

  1. Uploading data
  2. Data Upload was not sucessful: 400 bad request. (this message also appears in the View Event logs)

I don’t know maybe I’ll just create a new tidepool account.

@Trying - yes, I’m on the most current build. No, I’m not using the test server settings. I’m using the production settings.

@jim26 The is weird. Check your password and username settings once again. Maybe a small error. Mine uploads without missing a beat.

1 Like

@jim26 I would bet it’s something like mixing up credentials for the int.app.tidepool.org and app.tidepool.org. If you have the credentials set for the app.tidepool.org, then you must have the checkbox in cloud upload>tidepool NOT TICKED.

If you have the int.app.tidepool.org credentials, then the box should be CHECKED.

Having those reversed is the only way I could see your scenario doing what it’s doing.

1 Like

Thank you for your thoughts!! I will check my settings again.

@jim26 Did you solved the problem? I have the same one. I have the latest Nightly build 13th Apr 2019, I checked all options many times. I see this in “View Events Log”:

Data Upload was not successful: 400 Bad Request

In “System Status” there is no Uploader tab. Any idea how to solve this problem?

1 Like

No, I never got past the error. I didn’t have the motivation to figure it out, since I already had nightscout reports.

1 Like

Hi @elion If there is not some securry measure on your phone preventing upload, the routine in xDrip+ is pretty straight forward.

In Cloud upload>tidepool upload, do the following:
–Make sure the tidepool slider is enabled
–make sure you have an account set up at tidepool.com
–put in your app.tidepool.com (not the intapp.tidepool.com) username. Check spaces and capitalization. It will probably be your email address, but it still needs to be proper case with no leading or trailing spaces.
–enter your app.tidepool.com (not intapp.tidepool.com) password. Again, check case and leading and trailing spaces.
–Now, test the tidepool login. It should work.
–set the data age for a relatively short interval, like 30 minutes.
–DO NOT CHECK anything else!

Again, if your phone security is not preventing file upload, this should work. It will take some time for all the data to be uploaded, but you should see “tidepool chunk upload” in the events log after 30 minutes.

2 Likes

Hi @jim and @docslotnick. Thank you for the quick response. I checked everything again. I copied username and password, so it cannot be the cause of this problem. I have opened just app.tidepool com account with my email and password with some special characters. “Data Age Mins” was previously 15 but I changed it to be 30 as you suggested. “Only on Wifi” is checked but nothing else. “Sync to Tidepool” is ON.

About my phone security I am not sure what to check or what else to check about phone security? Bitdefender Security is there and Android version is 8.0.0.

But still in “System Status” there is no “Uploader” tab, where TidepoolUpload can be forced.