FUDiabetes

Xdrip+ and g6

dexcom
#1

How do I correct the issue of my xdrip not showing readings for hours? I’m using my galaxy s9+ phone as the receiver. Moat of the settings I see are for the g5.

#2

You may find answers here.

Or here

2 Likes
#3

Sorry to sound like Microsoft tech support here, but have you tried restarting the phone? I use Xdrip+ on my (LG) G6 with my (Dexcom) G6 and the phone will occasionally stop receiving readings, often for hours. I need to restart to get everything working again anywhere from once every few days to a few times in one day.

1 Like
#4

Settings, scroll down to just above “XDRIP+ EXTRA SETTINGS”, choose “Less common settings”, scroll down to the bottom, three lines up choose “Other misc options”. Examine the third option down, “Samsung Workarounds”. It will probably be checked; xDrip+ detects Samsungs, but if not try checking it.

Other than that there are a variety of different options to avoid dropped readings, I think I posted an algorithm that works most of the time for me. The problem is that xDrip+ goes into an aggressive but very slow “scan always” mode if it misses a reading and this is so slow that it locks up in a noisy bluetooth environment. Apart from the various recommendations, some or none of which may work with an S9+, do this:

  1. Set the missed reading alert to 6 minutes.
  2. When it goes off go to the notification area and just turn bluetooth off. The default xDrip+ settings will turn it back on in a minute or so and xDrip+ should manage to find the transmitter then. (The “restart bluetooth” options don’t fix the problem for me.) If xDrip+ doesn’t turn BT on you can do it yourself after 8 minutes or less.
  3. If you don’t get a reading within a few minutes go outside as far away from other blueteeth as possible (e.g. the middle of the Sahara, or Iowa) and reboot the phone.

John Bowler