Latest Android update causes major xDrip+ issues here with G6 and I sadly can't use it...any suggestions?

For some reason my Samsung S10e decided to update on its own without asking me like it usually does – I usually never update until I know it works with xDrip+ first. I’m using it with a Dexcom G6, and xDrip+ has been working relatively well for the past 8 months on it.

Now xDrip+ is stuck on “G6 State isn’t currently known. Next connection will update this”, then sometimes will connect for a bit and I’ll see all the readings that it missed (on the error list page it says, repeatedly: Aggressively restarting collector service due to lack of reception)…then it will lose connection again. When warming up it will finish the 2 hours then stay on the “Sensor is still Warming up” for about 30 min, at which point it will, again, show all of the readings that it missed, then stops working on and off with the same message as above. It’s like it falls down for long periods but remembers all of the data from the period that it had fallen down.

I’ve completely re-installed xDrip+ and did Matt’s extensive checklist with Samsung phones/installation, including all Bluetooth settings – no dice. I tried re-starting the sensor. I made sure there are no battery-saving issues happening with xDrip+, etc.

The Dexcom app (which is simply a very poor app) works fine with the same transmitter and sensor, so it’s definitely an xDrip+ issue. Unfortunately I need to use the Dexcom app because xDrip+ simply doesn’t work now. :frowning:

Any ideas/suggestions, or is there an xDrip+ update coming soon to work with the newest Android OS update with Samsung phones?

1 Like

I usually have separate device(s) for xdrip+. A lot of older Androids can be found pretty cheaply on Amazon.

Interesting! I hear you. For me that would defeat the purpose of xDrip+, as it would be like carrying around the Dexcom Receiver in addition to my S10e.

Just to clarify; on exactly the same phone? I.e. you uninstalled xDrip+ and installed the Dexcom app and it started working?

Yes, exactly. For the hell of it I tried uninstalling Dexcom app again and re-installing xDrip+, and still have the same issue unfortunately.

1 Like

Thanks, that helps me, though it probably doesn’t help anyone else.

I installed the Dexcom app on my wife’s (supported, not supported) 7Edge and it was dropping out too. So I figured all supported Samsungs are equal, but some are not so equal as others. On the other hand it might have been because I had three devices connected directly to the sensor (the Dexcom receiver, my xDrip+ and my wife’s Dexcom app.) Apparently the latter.

Well, it seems like Android 10 is causing problems for a few people here on xDrip+…I hope it gets cleared up soon so I can trash the comically bad G6 app, which does work fine on the new OS. xDrip+ was working great before Android 10 got installed without me knowing.

I wonder if any of the xDrip+ crew is checking it out?

@TiaG pointed out elsewhere running the “source setup wizard” apparently completely resets xDrip+'s internal state and allows it to reconnect.

It might be worth trying that. I does seem to put xDrip+ back into some kind of initial state; it seems just to scan for the transmitter, not connect directly. It doesn’t work for me; the only way I know to fix it is to turn bluetooth off, or reboot the whole phone.

Thanks for the suggestion – the issue still happened when I re-installed xDrip+ from scratch, and also when I tried Source Setup Wizard. Also rebooting the phone doesn’t work for me. The Dexcom App is working fine until then…it just is written for kindergartners, hahaha.

Since you have the Dexcom app working fine another approach (which I have never tried, since I can’t even get to 1st) is to have both installed on the 'phone but set xDrip+ to use Dexcom share as the data source. (I understand this works, but I don’t know how to do it.)

So far as I can see the only downside to this is that xDrip+ loses its connection when our prima-donna-phones lose their internet connection, but that would be fine for me I think because I look to xDrip+ for more long term analysis and better display. I can go back to the pre-school implementation when I’m out of contact with the internet.

Hey, and happy holidays!

It sounds like the same old samsung issue… I’m using the same setup you are, but mine’s running fine, so it seems like it’s something in Samsung or XDrip+ that’s having the issue.

I know it sounds dumb, but make sure when you uninstall, you uninstall EVERYTHING (all past apk’s that might be hiding in a downloads folder), download a clean version, and then use the source setup wizard from scratch. Also be sure you don’t have the dexcom app installed! You just get crazy interference, XDrip+ hates the dual instance.

I know my ‘how-to’ was crazy long and complicated, but I know it worked for me, and apparently a bunch of other people (it’s insane how these things catch on, right?! You know my name!!!), so I’d just double check to be sure you’re going through all the steps in order.

Hopefully you can get it squared away - it’s definitely possible to run it with the combination you’ve got going, but it sounds like you’re having a bit of bad luck! I’ve got fingers crossed it’ll work itself out for you!


P.S. - Did you guys know that you can get Alexa to speak your readings?! Not to hijack the thread, but damn, sugarmate is awesome!

It does make sense. In software QA that is the environment; you start from a clean system (out of manufacturing, no boot, nothing) install whatever is required and see if it works. Most of the time it does, curious.

So I’m sitting on 267 minutes of xDrip+ dropped signal @192 with a Dexcom receiver @158 and wondering to myself if I can continue this charade. My intuitions say to me that there is bad state within xDrip+; conditions that are set that should not be set, that are causing the failure to connect.

At the end of the day I come back to something that a QA person (Andrew Cummins, one of my very curious set of heros) said to me many years ago which, summarized, is, “It isn’t the job of QA to fix your software, it is so say whether or not it works.”

I would have to side with you; the reason being that the Dexcom G6 app is working great as far as connection goes, with no special adjustments to the OS needing to be made aside from a battery and automatic system setup options – it never drops signal. xDrip+ is not paid so I can’t really complain…I just hope that they get it to work reliably for people like us because it’s incomparably better than the prehistoric Dexcom app is in every other way. But reliable connection is possibly the most important thing. :slight_smile:

1 Like

The 19-12-22 nightly update is supposed to be an attempt to fix the dreaded Android 10 connection problem. You would be wise to give that release a try, and also let JamOrHam know if it works or not. This problem is a work in progress.

Thanks for letting me know!

I never really understood how to get updates immediately installed on xDrip. When I hit the “Check for updated version” under the three dot menu, nothing happens except for “Checking for update…”, but then I still have the old version. I always have had Automatic Update Check on, and the channel is set for Alpha.

How do I immediately download/install the update you’re talking about? I’m on 19-12-05.

Indeed. I’m not going to say the xDrip+ UI is perfect but it is broadly consistent with other Android apps and with modern UI design rules. Both the Dexcom receiver (I don’t have much experience with the app) and the Insulet Omnipod receiver have UIs that suggest the designers really don’t have any experience whatsoever with UI design.

I admit UI design wasn’t taught when I studied computer science, but that was 40 years ago. I hope it is now, at least at the more technically oriented colleges.

@Headlands You can either choose “nightly” on the updates menu, or go to
and get the latest updates.

Thanks! I don’t see “nightly” anywhere in the Updates settings window, though – is there another updates menu hidden somewhere?

@Headlands Sorry for the late reply.

To get nightly updates to show you need to enable engineering mode. Just tap the treatment icon, then press and hold the microphone icon, then type “engineering mode” into the text box.

Go back to the updates setting and you should see nightly.

1 Like

You can also speak “engineering mode” to the phone, à la Star Trek, however it doesn’t enable extra update modes in the version I have (set to Beta). I suspect they, quite correctly, don’t want people switching to nightly updates without fully understanding what they are getting. Back when I was working in the industry we used to call it dogfooding.

Update: in fact I think it is a progression, nothing to do with engineering mode, which seems to be a temporary setting. If you run alpha releases then you get the option to do nightly releases. This makes 100% sense to me; you don’t go into the deep, deep, deep end of the pool until you have at least tried the 3m bit.