Upgraded samsung and having xdrip+ issues? *fixed*

Alright guys, I know a LOT of people have been having problems on Samsung devices since the latest Android update - I know I was - and I think I finally patchworked a solution that has worked consistently for me for the last 6 hours. Granted, that’s not a great sample set, but it’s a lot better than what I have been getting, so I’ve decided to jot down what all I had to do. I know it sounds cheesy, but let’s start with what the issue was:

If you Samsung device (Galaxy S9, S9+, S10, etc) just went through a forced Android update, then your xDrip+ started having connection issues with you Dexcom (as soon as the screen went dark, overnight, etc), then this solution is for you.

STEP 1: Delete xDrip+. I know this sounds simple, but it’s not. Go in to Settings -> Apps -> xDrip+. Then click “Force stop.” Then tap “Storage.” While in storage, hit clear cache, and clear data. You need to clear BOTH. Then go back to “xDrip+”, and hit “Uninstall.” Then navigate to Samsung -> My Files -> Downloads, scroll down, and delete EVERY “xDrip-plus-blahblahblahblah.apk” file. In my case there were about 6, you might have more or less.

STEP 2: Delete EVERY instance of a Dexcom transmitter on your bluetooth list. Go in to Settings -> Connections -> Bluetooth. Then click the gear icon next to anything that starts with “DexcomXX” (where XX are the last 2 digits of your transmitter), and click “Unpair”. You need to do this for EVERY Dexcom device. (And to be honest it might say “forget”, or “delete” - I don’t remember the exact wording on some of mine.)

STEP 3: Turn your phone off. I don’t know if a restart will fix it, I’m only listing what I did, so I’d recommend turning your phone all the way OFF. Once it’s off, power it back on.

STEP 4: Download the latest xDrip+ from: https://github.com/NightscoutFoundation/xDrip/releases?fbclid=IwAR0gpgst9R4mpXpqjdbr5zybZdKCmngLcdCjtt94IQIbuVI90tjCSSTUaG8


STEP 5: Fix your phone settings. Go straight to Settings-> Device Care -> Battery-> Power mode and choose “High performance”. Then go back to Settings -> Apps -> xDrip+ and click “Mobile data.” Once there, make sure that “Allow background data usage” is turned ON. Currently I don’t have “Allow app while Data saver on” enabled.

Then go back to Settings -> Apps -> xDrip+, click “Battery,” and make sure “Optimize battery usage” says “Not optimized”. You might need to navigate through some of the menus to make sure it isn’t being optimized (I think you click the top drop-down and change it from “Apps not optimized” to “All”, scroll all the way down to "xDrip+, and make sure that it is turned OFF). Once you’ve done this, back on the “Battery” section, the “Allow background activity” should be greyed out, and you shouldn’t be able to do anything with it.

Then go back to Settings -> Apps -> xDrip+ and go to “Permissions.” I had success turning on permissions for Camera, Contacts, Location, Phone, SMS, and Storage. I have no idea which of these it actually needs, but again, I’m relating what worked for me.

Then go back to Settings -> Apps -> xDrip+ and scroll down to “Advanced.” On “Change system settings,” make sure it is allowed, and on “Install unknown apps” make sure it is allowed.

Step 6: Configure xDrip+. You can finally open xDrip+, and you should be greeted with the standard “Terms and Conditions” pages. When you get to settings, choose your receiver type, and you’ll get to a branch where you choose “CONFIGURE SETTINGS” instead of “Start Sensor.” Again, this is what worked for me, but I configured settings BEFORE I started the sensor.

In xDrip+, in the Settings menu, go to “G5/G6 Debug Settings.” Make sure that all of the following options ARE CHECKED: “Use the OB1 Collector”, “Native Algorithm”, “Restart Sensor”, “Preemptive restarts”, “Go on without calibrations”, “G6 Support”, “Allow OB1 unbonding”, “Allow OB1 initiate bonding”, “Authenticate G5 before each read”. For me, all of the rest are unchecked, and again, it’s working as-is, so I’d highly suggest these options.

Go back to “Settings”, then scroll down to “Less common settings”. In this menu, make sure “Aggressive service restarts” and “Display Bridge Battery” are enabled. Again, this is what’s worked for me.

Then go to “Bluetooth Settings”, and make sure that all of the followed are enabled: “Turn Bluetooth on”, “Bluetooth Watchdog”, “G5 Bluetooth Watchdog”, “Trust Auto-Connect”, and “Allow blucon unbonding”. The rest should be unchecked.

Go back to “Less common settings”, and scroll down to “Other misc options”. One last time, make sure all of the following options are enabled: “Run Collector in foreground”, “Battery Optimization prompt”, and “Samsung workarounds”.

From here you can go back to the xDrip+ homescreen and start your sensor. I still had a sensor session running (I think I started it about 13 days ago), and xDrip+ picked it up as soon as I input my transmitter ID.

Now I hate to say this, but: I’m not tech support. I don’t work on xDrip+. I’m not a programmer, and I don’t know what the hell I’m doing. But I do know that, like many of you, I was getting frustrated at this Samsung/xDrip+ issue, and these were the steps that helped me. There’s no guarantee that they’ll help you - it’s just what worked for me, SO FAR. Again, it’s been running smoothly for about 6 hours now, which is better than it has been for the last 2 weeks, so I figured I would share. If you come up with a better/faster/different way of making this work, that’s awesome - but in my searches I didn’t find a comprehensive guide on how to make it work again, so I figured I would put one together - hence this post. I really hope it’ll help you guys, as I know it can be super frustrating, but fingers crossed that we’ve now got a step by step solution for how to get this problem licked!

Your Friendly Neighborhood Type 1 Diabetic


I also use samsung, but not xdrip. Have had all kinds of issues with phone since the upgrade, Wi-Fi turns off if phone is off (but power on), Bluetooth turns off also and web sites I go to allot that used to sign in automatically don’t anymore. Am about to get new phone.

OMG I was getting so annoyed by this. Didn’t think to go into the Samsung settings and make sure everything was allowed and prioritized. I haven’t gone through to find out where the “magic” was in the list of changes, but this worked for me! I was getting maybe 20 minutes of connection and now I am at 48 hrs with no interruptions!
Dexcom G6, Samsung S10e, xdrip+ build from 17-MAY-2019

Thanks for the detail in outlining your method!



Hey Matt,

I’ve been having trouble with xDrip+ also and trying the process that you have stated definitely helped me. Before trying the steps here, the new updated app just wouldn’t work, now at least the app is trying to link with my Dexcom G5. Only thing is I keep getting a sensor error at the bottom of the screen. In my System Status screen, I get a “Sensor Status - Sensor Failed” and in “Brain State - Deep Sleeping”. Not sure what to do now but I’ll keep searching. Just want to say, Thanks for the help sir! It looks like I’m a step closer to fixing this. I’m using the Samsung Note 5, xdrip+ build from 18-MAY-2019.


1 Like

Question I downloaded this on ab s10+ but I’d said currently unknown, will update this next connection what does this mean

1 Like

Actually, it has happened 5 times with my android phone.- suddenly signal lost. Initially, i was doing restart sensor but had to then calibrate. Last time, i just tried System status=>restart collector and that fixed the issue. This is a quick temporary solution if anyone wants to try

1 Like

Yeah, the restart collector option can temporarily trigger a reconnect… but it doesn’t really seem to be a long-term fix. If anybody is in a pinch and needs a quick solution, definitely try Palani’s suggestion!

And just to expand on the topic, it does seem like the latest update causes more problems that (thankfully) aren’t too bad - by downloading the latest nightly direct from github and upgrading, it’ll trigger two new notifications: Xdrip now requires access to call logs (dunno why), and wants to run location services in the background. Funny thing is, Samsung tries to tell you to DISABLE the second option, but definitely LEAVE IT ENABLED OR ENABLE IT! Once the installation is complete, as far as I can tell, there’s no way to retrigger that notification, or to turn it on through options… weirdly XDrip doesn’t even show up as an app anymore. But for people who are having the latest update issues, it might be worth trying, reinstalling, and making sure those options are activated!

1 Like

@ [Pastadude]

Literally just created an account to THANK YOU so much for creating this post! I followed your directions step by step and finally got my Dexcom working seamlessly. I appreciate you so much. Have a wonderful day!

((I had tried the restart collector, among many other things, and they just didn’t do the trick!))


Shoot! I may have spoke too soon - worked for 15 minutes and then back to square one. Sad day.


Hey! Thanks for signing up to say thanks, but I’m sorry the solution doesn’t seem to have worked! I’ve updated both my phone’s operating system to the latest android, as well as XDrip+ to the latest, and mine’s still running… which I know doesn’t solve your problem, but can be used as a case-study to compare. It seems like you’re still experiencing the same issue, so my suggestion would be to go through everything slowly, one step at a time, and try a fresh install. Be sure to delete everything from your phone first though - delete the apk installation file(s) for the old versions of xdrip, delete the bluetooth connections, and then be sure you have the most recent nightly build when you download the new apk… I know that ONE notification can literally mess the entire thing up, so be sure to allow location when it pops up! I’m sorry you’re still in the thick of it, but it gets better, I promise!


1 Like

Thank you so much for this post. I discovered this forum thanks to upgrading from a Note 8 to an S20. The dexcom app is as barebones as it gets but it did its job for me until i upgraded. I freaked out when I saw it was not compatible with the S20. I never got a receiver because of the app and I was dreading going back to sticking myself several times a day. Xdrip initially did not work but following your steps it got up and running with no trouble. Again I can not thank you enough.


So I got a new Samsung galaxy note 20 for christmas. I was “hoping” it would work with xdrip, even though it had taken weeks of tinkering to get my old moto z force to work. I ended up carrying around my old phone just as an xdrip receiver. I tried a variety of things that I remembered doing to get my old motorola to work, to no avail. Finally I got tired of my kids teasing me about walking around with 2 phones, so I came here and eventually found this thread. Bingo! I followed your instructions, hoping the fix for older samsung phones would work for my new one, and it did!
Thanks Pastadude!


I have Samsung s10 with Android 9. I tried your suggestions and it worked for me like a charm.

Thank you so much ! ! !


No problem! I think the newer versions of xdrip help streamline the process, but Samsung can be really problematic on the backend, so I’m glad people are still finding this tutorial helpful! Be sure to share xdrip with any T1’s you might come across - I was introduced to it a few years back by a work acquaintance randomly, and it literally changed my life, so you never know who you might impact by spreading the word!


1 Like

Hello all, I am new to this forum and need to know has this brrn fixed? I have an S10 running Andrpid 10, still on and off with working. The othet issue is the sound for alarms are not working, which is important since I am hearing impaired and the Dexcom receiver is not audible for me.
Please HELP!

1 Like