Xdrip+ signal missed

Hello everyone!
Yesterday I put a new sensor (FSL2) and started up by librelink. I dont rely on Librelink as I’m using patched version. Xdrip has been my go to, however I havent used it since Nov 2022. I constantly encounter “signal missed” errors, like every 10 mins. When I scan from Librelink, it gets data back and worls for next 10 mins only.
My phone is Samsung galaxy s21. I even reinstalled xdrip several times and still get the same error. Does anyone have solution for this? I’ll greatly appreciate your help!

To check, it’s the most recent version of Xdrip right? When I used Samsung, it seemed as though having the most recent version was quite helpful. I forget all the settings recommendations but I think I remember threads of people dealing with similar types of issues, although don’t remember if it was that exact phone. Since then I’ve moved to Google Pixel and have had things go smoothly.

1 Like

Hey Mark. Thanks for answering. Funny thing: i configured phone settings once again to granted all permissions both to librelink and xdrip and restarted phone twice. It worked. Not quite sure why. But Probably root cause was in Librelink app. after 2nd restart it finally synced with phone configurations and then Xdrip was able to capture data without issues.