FUDiabetes

Xdrip+ Changing the G5 Transmimtter

HELP @docslotnick and others.

I use xdrip+ with a sony smartwatch 3 as the collector and a Samsung Galaxy S5.

Every time I change the G5 transmitter with xdrip it never “just works” if I just change the transmitter number in the settings. So I randomly change settings and reboot my phone watch several times and it eventually works. Then I never know what I did to make it work.

This morning we are at 4.5 hours and multiple reboots and I am stuck.

Can someone write down a step-by-step telling me how to change from an old dead G5 transmitter to a new G5 transmitter so it will just work the first time?

Thanks muchly in advance.

1 Like

@Aaron Sounds pretty weird. But you may want to check “scan for G5 Constantly”, “Authenticate G5 Before Each Reading”.

Try that. If it doesn’t work go back and check “Unbond G5 Before Each Reading”. These settings are all in settings>>G5/G6 Debug.

If it works when you check “Unbond…” make sure you uncheck it once you’ve got it going, and just use that as transmitter start-up workaround.

Good luck!

Edit: Also install the latest nightly. Jamorham snuck in a Buggy Samsung fix a couple months ago.

2 Likes

Thanks @docslotnick

So here is what I did to make it work:

  1. Check “Unbond G5 before each reading” on the Sony Watch Xdrip Settings
  2. Change Transmitter ID on phone to new ID (Settings -> Dexcom Transmitter ID)
  3. Wait for Watch to request new bluetooth pairing - then click “YES”
  4. Once it has paired, uncheck “Unbond G5 before each reading”

For some reason, my phone/watch have weird security settings (I have a BYOD phone and the office IT guys have security software on my phone that can do interesting things.) For some reason it blocks unbonding in the bluetooth so once I bond I need to turn off the unbond setting.

Now in 6 months I will know what to do :slight_smile:

@Aaron. Great! Glad you got it working. Weirdities abound!