FUDiabetes

8T Dexcom G6 transmitter refuses to connect to Android phone

I just had to switch Dexcom G6 transmitters and my new one (series 8T) is refusing to connect to my phone, so I can’t start the sensor. It searches for ~minutes then goes into “Deep Sleeping” mode and doesn’t do anything. I restarted my phone and updated my Xdrip+ install to the latest nightly release (9/2/21) and still nothing. My phone can’t even find it as a Bluetooth device anymore. It showed up for a while at first and I kept manually trying to connect it (which has worked in the past) until it just stopped letting me try and disappeared the next time I toggled BT on and off. Anyone else have any problems getting this series of transmitter to connect to Xdrip+, and more importantly have you figured out how to make it work?

1 Like

I figured out the problem and boy is it dumb! Every transmitter I can remember used the following numbering convention, where @ are letters and # are numbers:
8@##@@
This transmitter code ended in a 0 (zero). Not an O (capital o) like I had been using because it fit the format. I entered a zero as the last letter of the transmitter just to reset things so I could try what I thought was the correct one again and the stupid thing connected immediately. Keep this in mind if you get a transmitter with a code you think ends in O!

4 Likes

Nevermind, that only got it to seem like it connected and start the sensor. Almost 3.5h after the 2h warmup period I still haven’t seen a single reading. There are odd and conflicting errors in the system status window:

Classic Status Page
Bluetooth Device: None Set
Connection Status: Not Connected
But the sensor is running and has been for 3.5 hours.

G6/G6 Status Page
Bluetooth Link: Disconnected, Connecting, or Connected
Last Connected: Up to several minutes ago (it is connecting to something)
Brain State: Scanning Errors: 217 (when not connected) or Bonding Errors: 218 (when connected)

How can it think it’s connected when it doesn’t think there’s a bluetooth device or connection?

2 Likes

There used to be a very detailed log available somewhere off a button at the top right - I haven’t used xDrip+ for several years so I can’t remember exactly what it was called, I think the word “debug” was used.

The transmitter itself only transmits once ever 5 minutes, when it has something new to add, and the protocol for listening is, I suspect, just as etiolated. So most of the time it is “disconnected”.

The fact that you have “bonding errors” suggests that xDrip+ isn’t managing to complete the protocol for linking to the transmitter; the log will reveal more. Since you have an 8T it may be that Dexcom have altered the protocol in some way that reveals xDrip+ incompatibility but more likely it is something like this:

So you need to look at “Error or Event List” :wink:

2 Likes

I’ve had non-readings for sensors that had blood…other than that, haven’t encountered that

1 Like

I managed to get the Dexcom Receiver working, so I dealt with that POS until it was time to start a new sensor just in case there was some strangeness from restarting an old sensor.
Nope. Same error on the phone (started with Xdrip+ first)- the sensor starts but will not provide any data after the warmup period. The main screen just says “G6 State isn’t currently known. Next connection will update this”
Again, I started the sensor with the Dexcom Receiver (UGH!) and it works fine. I tried a few of the things on that page you linked to but they haven’t worked.
I found my event log and here are some of the errors in case anyone can help diagnose/troubleshoot:

DexTimeKeeper
[timestamp] No valid timestamp stored for transmitter: 8TXX@0

Ob1G5StateMachine
[timestamp] Unhandled packet type in reply: InvalidRxMessage
FF0601

Ob1G5Collection Service
[timestamp] Error count reached: [increasing four digits]

Ob1G5StateMachine
[timestamp] authentication notification throwable: (CONNECT_NOW)
com.polidea.rxandroidable2.exceptions.BleDisconnectedException:
Disconnected from MAC=‘XX:XX:XX:XX:XX:XX’ with status 0 (GATT_SUCCESS)
[date & time]

1 Like

It’s an 8T; I’ve not got beyond 8L so I don’t have any experience of those and I use the Dexcom app (because I use an iPhone and xDrip is provided by Spike, which I would have to build myself.) Sounds like they changed the protocol. The messages you posted will only help if someone knows exactly what the issue is. It may be the 8T but it could also be a config issue on your xDrip+.

There was an option in the past and maybe there still is to send the complete log to JamOrHam. I did so several times but got nothing back, however it might help him - no harm trying.

Your best bet, unless someone here pipes up with more information, is NightScout (I think they have fora) or, if you know how to do it, an issue on GitHub for JamOrHam. My checks indicate that JamOrHam has disabled issues, but that may be because I haven’t pulled from him; the status of “Issues” on GitHub seems to be slightly weird at this moment.

Thanks- I just sent him the log file. I’ll google some of the specific error messages and maybe I’ll be able to find something. At least I still have CGM data, but it’s in pretty much the worst format possible.

2 Likes

I just switched to the new Samsung 21 Ultra, and decided to switch totally to xdrip rather than rely on dex g6 app and follow. It ched up a lot of battery on my old phone. I ran into the same problem you did, even with the dex receiver. Sometimes the receiver just doesn’t capture the signal from the transmitter, and it needs 30-40 minutes more to acquire the signal.

In the end I found that some settings in xdrip was the issue. BTW, I have the 8K transmitter. In the debug menu check restart sensor, but uncheck preemptive restarts Check Go on without Calibration. Check Minimize Scanning and Avoid Scanning. I think this is what messed up the phones BT linking.Check G6 support, uncheck Allow OB1 unbonding, Check Allow OB1 initiate bonding. The rest only pertains to the G5 system.

One more thing, in the Menu stop the sensor (even if you didn’t have one running), and then do the sensor restart as you would normally.

Hope this helps.

Take care,

Mike

2 Likes

I actually got it working with the help of the Xdrip+ discussion board over on Github. I don’t know what finally did it (if anything), but I cleared the queue (which I didn’t know was a thing you could do), fixed a few settings and permissions in Android, and restarted. When it still didn’t work (and because someone else asked about it) I tried (again) to change the transmitter name, forget it and restart the collector, changed the name back, forgot it and restart the collector (probably toggling BT on and off at some point as well) and then BOOM! Transmitter suddenly connected like it was business as usual.

3 Likes

That stuff all mirrors my experience when I was using xDrip+. Do lots of things and eventually it starts working. I couldn’t find any settings that actually consistently worked, but I did find lots of people saying “you must set this on, this off and remember to dance round the maypole in the correction direction”, etc. None of those things (including the maypole) worked consistently.

Meanwhile the G6 app on the same 'phone (some people said the problem was in the 'phone) worked just fine, most of the time. I eventually reached the conclusion that the G6 app aggressively tries to re-sync to the transmitter when it loses the signal.

For example (with an 8L transmitter) I just “forgot” the transmitter in my iPhone settings; I removed the transmitter from my known devices. This didn’t faze the Dexcom app; a couple of minutes passed and I got a notification that it wanted to pair with the transmitter, the app screen said “transmitter not found” (or something like that) and iOS popped up a pairing request, which I OKed, and I got the next reading.

1 Like

Yup. If it’s not working just keep trying things- even some things you’ve already tried. Just because it didn’t work the last time you tried it doesn’t mean it won’t work this time.

1 Like

I was having the same issues. I had deep sleep as the error message. I cleared cache in Bluetooth and forgot the device. Next (and what I think did the trick) I deleted the transmitter number to leave it blank. Then went back in and added it, and it’s worked :muscle:

2 Likes