FUDiabetes

G6 with xDrip+ on Android

I’m running a G6 straight to a Pixel and then to a Garmin Forerunner (no receiver or Dexcom app).

This has been running great for months, but then today when I tried to start a new sensor I’m having connection issues; after the 2-hour warm-up I get this error:

“G6 State isn’t currently known. Next connection will update this”

I’ve tried going into System Status and doing the Restart Collector and restarting the phone, but that hasn’t worked.

I thought I should try doing Stop Sensor, but the warning on that page tells me not to do so unless I’m actually taking out the sensor.

Any suggestions on what to do?

1 Like

Hi @ponjovi and welcome to FUD!

First, are you using the OB1 collector or the native Dexcom collector? For connection issues I would recommend OB1.

Next, download the latest nightly. There’s a lot going on behind the scenes.
https://github.com/NightscoutFoundation/xDrip/releases

It won’t make any difference if you restart the sensor. It seems the problem is BLE connection with the transmitter.

Let me know how it goes.

Yep using OB1. Just tried installing the latest nightly, and tried stopping sensor and starting again. Still getting same error - “G6 state isn’t currently known.…”

@ponjovi You might try running the Data Source Wizard again. Maybe something got screwed up. We just need to get your phone communicating with your transmitter.

Just long press the xDrip+ icon at the top of the home screen and you’ll get the option to display it.

Okay, tried stopping sensor and starting again with the Data Source Wizard, still same error.

Should I fully uninstall xDrip and re-install?

Another question:

I could uninstall xDrip and re-install the Dexcom app to see if that works, and isolate xDrip as the issue? If I do this, and then try to go back to xDrip would there be issues trying to re-start it on xDrip?

Or, should I first try forgetting the Dexcom transmitter in the Bluetooth settings?

@ponjovi No problem with going back and forth with the Dexcom app.

But one more thing. Could you double check that the transmitter id was entered correctly? Longshot, but you never know.

Yep double-checked the transmitter code, it’s fine.

I tried forgetting the transmitter in my Bluetooth settings, now having trouble reconnecting to the transmitter.

I see a list of new available devices in this format:

N0XXX

For example,

N07BQ
N00KC
N00ND
etc.

This list continues to dynamically update itself… really weird. Any chance this is the transmitter going haywire?

It’s seeming more and more like this. I liked your idea of reconnecting to the Dexcom app. Do you have a receiver? If you do just connect the transmitter to the receiver and you won’t have to uninstall xDrip+.

Does the lack of connectivity coincide with a phone update. Many people had a connection problem on the Samsung S9/S9+ after the latest phone update. Maybe you have something similar?

I do this all the time :slight_smile:

1 Like

So I re-installed the Dexcom app and was able to successfully pair, so not sure what the issue was with xDrip. Will try swapping again and will report back.

But importantly I’m now back up and running which is great since I’m traveling for a week with only a few fingerstick strips with me so really needed the CGM back online.

Thanks @docslotnick for all the help!

1 Like

Not sure if anyone is still following this thread, but I was having similar issues with xdrip+ and the G6 with my first attempt at bring a previously fine sensor and transmitter combo from the Dexcom app to xdrip. What finally worked was doing a hard reset on the transmitter, then uninstalling and reinstalling the latest nightly (currently from 5/25/19). I then started everything from scratch, and so far I’m up and running. For hard transmitter reset, I found instructions here in the AndroidAPS wiki, under the “extend transmitter life” section:

https://androidaps.readthedocs.io/en/latest/EN/Configuration/xdrip.html#xdrip-dexcom-g6

Also imporant:
Go to System Status after stopping a sensor (either a new one or trying again with one already inserted) and make sure that before you try again, the queue where it says “(1) Stop Sensor” has disappeared.

1 Like