FUDiabetes

Problems starting Dexcom G6 with XDrip+

I’m having a lot of problems with my first Dexcom G6 sensor, linked with XDrip+ on my LG Phone (running Android 6.0.1)
I entered the transmitter ID, inserted the sensor, connected the transmitter & entered the sensor code & then started to wait for 2 hours…
The log shows many error messages including
Sensor started at …2018-10-31 17:49…
Started G6 sensor using calibration code 9159
No valid timestamp stored for transmitter: 80FBH6
Session start failed: clock not synchronized or other error
Invalid dex timestamp in updateAge: 0
Transmitter sent raw sensor value of 0!! This isn’t good
Session start time reports: no session in progress

After 2 hours I was prompted to enter 2 calibrations (even though I had entered the sensor calibration code earlier)
Even though I entered to calibrations, the system constantly prompts again for calibrations & the error log shows
Did not find 3 readings for initial calibration - aborting

I’ve tried “Restart collector” & “Forget device” with no improvements.

Apart from this it’s working fine :slight_smile:

Would be very grateful if someone could help.

@Paul Did you run the Data Source Wizard? It automatically checks all the right settings for a G6. You can find it as an option by long pressing the xDrip icon on the home screen.

Also make sure " I am Using the G6" is checked in settings>>G5/G6 Debug.

Thanks for your reply.

Yes – I’ve already run the Data Source Wizard. At the end of this it prompts to enter the transmitter ID.

Also the " I am Using the G6" is already checked

@Paul Are you using the OB1 collector? If not I would certainly suggest checking that option in G5/G6 Debug Settings. There are still some problems with G6 and native collector.

Hi

I checked – yes I’m already using the OB1 collector.

Earlier today I tried loading Xdrip+ on another (older) phone – it didn’t work there either but had less error messages than on my “normal” phone.

I then switched back to my “normal” phone & it started working.

This is good (obviously!) but, because I don’t know what I really did to fix it, leaves me with a potential problem when I start my next sensor…

Anyway, thanks for your help