FUDiabetes

Xdrip and glimp give readings readings from -7 to over 1000

Both xdrip and glimp don’t work with my new blucon. Linkblucon and librelink work fine. The images are quite funny; glimp gave me a warning that i was 350, which I wasn’t, but then i looked back and saw that i was recently over 1000. Xdrip dipped into the negative, interspersed with random readings around 400 and around 38. My blood sugar has been pretty steady while working on this issue, between 70 and 140 over the 36 hr period where i tried again and again with different apps to see if i could get them to work.

Does anyone know the best support community or group to find info on stuff like this? Anyone ever heard of this craziness? Thanks for any help.

1 Like

Welcome to our little corner of the web. Thanks for posting. I don’t have any experience with blucon, but surely someone here does.

Is it possible you need newer update to xDrip?

Unfortunately, the newer version of blucon which should but does not have a newer differentiating name, will not work with xdrip. They have failed with xdrip for over a year now, and are extremely vague on their website. I have the 2018 blucon, which does not work with 14 day libre sensors, however, it does seem like the apple way to go, I’m not sure if the apple has watchfaces, but I do know that you are not able to program different ringtones for high, low, predicted low, so their app is very outdated compared to xdrip… still stuck with the miaomiao2 for now

1 Like

I would try to email ambrosia’s customer service department. I personally prefer xdrip, and even used it when I tried the eversense, so i bought the miaomiao2 (i also prefer android). On Ambrosia’s website, it says it will only work with linkblucon, but their apple watch support is supposed to work well…are you an apple and Apple watch user?

1 Like