FUDiabetes

Unable to get MM2/Xdrip data to display on Note9

My home screen remains blank except for the manual entries. It does display the battery level of the MM2. The log seems to indicate that it’s collecting data, but the home screen remains empty.

Using a Note9, and I’m sorry if this has been asked before. I did research the topic but failed to find the answer posted previously.

Any help will be appreciated. I’m about trash the whole thing…

1 Like

Are you trying to use xDrip with Medtronic pump (MM2?) If so, this post may help.

Otherwise please provide more details on what you are trying to do.

No, I’m simply trying to use the MiaoMiao2 device to see my BG levels continuously, not just when I scan them.

It reads the data as in the first screenshot but won’t display them, as in the 2nd screenshot, that will follow (due to the restriction against new users posting more than one picture)

1 Like

Have you set your data source to Libre 2 ( or are you using the MM2 with the Libre 10 day?), and have you set display preferences? Have you gotten readings with this setup before, or is this the initial result from this setup?

1 Like

I am using the MM2 and US 14day sensors, which to my understanding is NOT the Libre2 sensors.

I have tried the Libre2 Patched setting but that makes everything go haywire

I responded earlier but the forum didn’t let me post it because I had more than one pic.

Data source is not set to Libre2. I am using the US 14day sensors, which are not the same thing as the L2 from what I understand.

From what I can tell, there are no display choices that would prevent the data from being show.

1 Like

As you hang around here and read and post, your user level will increase automatically. I wasn’t aware of limitations on the number of pictures, but I guess that makes some sense.

@DavidL Sorry for not getting back to you sooner. Been a busy couple of days.

I did some research and dis find a similar problem with the Pixel 3 running Android 10, but nothing running Android 9. The fix for that problem was Bluetooth Settings like this

Might give that a try.

OK, I had to recharge the MM2, so I didn’t reapply it yet. Your screenshot had a setting that was not set on mine. So hopefully when I get home later it will fix it. If not I’ll keep trying. Thanks!

Tried the one setting that you showed that I had not previously had checked and still nothing.

The app is reading data according to the activity log, but nothing displays.

I think I am going to try one more time at deleting this mess and re-downloading and reinstalling it.

If that doesn’t work then, I give up and will send it back.

@DavidL Sorry I couldn’t help you more. I’m really not familiar with the Libre or the MM2, and was just relying on my research.

@DavidL There is a new issue that was opened on github that pretty much describes your problem. No solution is yet given, but maybe someone will chime in there.

2 Likes

@DavidL You might try to update xDrip+ to the latest nightly build. A new commit was just merged to allow the US 14 day Libre work with the MM2 with tomato.

This was merged just 16 hours ago.

2 Likes

OK. Thanks, I will try it!

Hey thanks! I downloaded it and it didn’t seem to help, BUT, I went into the settings, AGAIN, and clicked ‘backfill’ or something and SUCCESS.

I’m not sure if that is what did it or if the updated app just needed the time to set itself.

But it WORKS! finally!

1 Like

@DavidL That’s great! Glad you had the patience to persist!

It was definitely the update. When you saw the graph " magically" appear, that was just the backfill from the transmitter being read. Good to keep that setting checked with systems that support backfill.

I find that xDrip+ is definitely a work in progress. I would highly recommend that you set your update track to nightly. Sometimes the smallest change can make all the difference.