Using Libre2 sensors on xDrip+ in the UK

Hello all,
@Trying and @RogerType1 were very kindly helping me out on another thread which had digressed somewhat, so i thought i’d start a new one here. I am looking to minimize the amount of equipement i use to make life simpler, and therefore would like to switch to Libre2 sensors and ditch the miaomiao reader. I believe this needs a patched app, and 1-2 spare days to faff around (the antithesis of making life easier…but anyway).
So my Libre1 sensor is up in 2hrs, and i foolishly thought that would be enough time to set up the new arrangement… and of course i have fallen at the first hurdle.
A github how-to guide suggests to "Load the Version 2.3.0 of the freestyle Libre App DE, for example from here or here "…
which i duly do, but once i run the apk on my android phone it says i need to download it from the Play store…which it switches to, and then written in red is “not available in this country” (the UK)… trying to install anyway it just hangs.
Am i doing something wrong already…?(!)

And if so (and this doesn’t work in the UK) now i have the Libre2 sensor (and no more Libre1 sensors), is the easiest way of getting CGM from it simply to use the (non-patched) Libre app ?

I must say, i’m really not looking forward to a night without readings… so thank you all vm indeed in advance!



I use the Dexcom CGM so I am not familiar with Libre. However, you note that you are following a Github guide. Could you post the link to the guide so that we can follow along with what you are doing? Perhaps someone here will be able to help.

Just from your post though, it seems that the Libre App DE is specifically built for the German market. Also the first link seems to be host Version 2.5.3 for Android, not Version 2.3.0.

Googling “Version 2.3.0 of the freestyle Libre App apk” list downloads for the APK Version 2.3.0. You may want to download it here and do the install:

1 Like

Thanks @Trying. I found a v1 sensor in the bottom of my drawer, so i have 9d to go to try to get this working.

i tried your link but it seemed to be the AT version… so i managed to find a UK version, and got as far as the 7th step in the ‘Get the APK and Tools’ section of the GitHub article. i.e. i have downloaded the APK and the APKtool, run the tool, and now have a new librelink with all the extracted files of the application.

but i don’t follow the 7th step: " Copy the patch Files from this repository to the same location as the librelink folder (you should now have a directory with at least the following files/folders: librelink , xdrip2.git.patch , sources and xdrip2.patch )

what are these patch files, and from where should i have got them ? Point 7 suggests they are in the ‘librelink’ folder, but i don’t see them, and searching for xdrip2.patch on my drive/computer comes up with nothing.

So i feel i’ve (again) fallen at the first (or at least very early) hurdle. Perhaps you could point out what i’m missing here?

As an aside, I find it rather strange that this is so incredibly complex… and given i am struggling with it, i can’t imagine anyone without a very good understanding of IT can get anywhere with this. Why don’t Abbott let xDrip use it’s (v2) sensor, like miaomiao/Tomato do with the v1 ? Doesn’t seem much to ask…?!

Thank you again for the assistance here.

1 Like

Could you post the link to this GitHub article? Maybe someone will be familiar with it and help you more effectively.

So we need the GitHub site for “Step 7”. This statement implies that these patch files are on this GitHub site, see “Copy the patch Files from this repository”. You may need to download them, or perhaps download the source from this GitHub site, and then build the patches.

Good question!! I don’t use Libre myself so I’m not sure why but perhaps it is economics!

1 Like

Here: GitHub - TinoKossmann/LibreLink-xDrip-Patch: Patch für LibreLink, um per vom Libre 2 empfangene Bluetooth-Daten an xDrip weitergeben zu können.

you might be right… but it isn’t in any way obvious to me where they are stored.

Thank you, as always.

1 Like

Thanks for the link. So the English does not seem to correspond to the German! In any case, the German does instruct you to clone the github repo:

“git clone

This will download those missing patch files. You’ll want to download them to your librelink folder, “7. Copy the patch Files from this repository to the same location as the librelink folder”.

1 Like

Thanks @Trying, you’re spot on. I downloaded that batch of files and put in the ‘librelink’ folder. So now i need to run the patch… i downloaded an ancient piece of software called Patch 2.5.9 (it says GNU GENERAL PUBLIC LICENSE Version 2, June 1991 in the set-up wizard…!), as instructed, and installed the ‘patch editor’ to program files.

i then tried step 3 (using a command prompt and not a PowerShell) but get an error:

C:\Users\user\Downloads\librelink>patch -p1 --binary --merge < …/xdrip2.patch
The system cannot find the file specified.

I tried setting up the patch inside the librelink folder… not sure what a " < operation" is, as it isn’t mentioned in the command syntax.
I looked at the ‘git apply’ method, but that seems even more impenetrable.
I feel way out of my depth here… but i’d really like to press ahead.
any idea where i’m going wrong here…?

1 Like

So the instructions say, “patch -p1 --binary --merge < …/xdrip2.patch”

You have an extra “.” in your command, as in “< …/xdrip2.patch”

Note, “< " means that the patch command takes xdrip2.patch as input. The “…/” means that the file is located in the folder ABOVE your current folder. “./” means the file would be located in your current folder. What is your current folder? The guide instructs you to change your directory to the librelink folder. Is this your current folder? Is the patch command located in librelink? Is librelink where your xdrip2.patch is located? Depending on where you xdrip2.patch file is located, use the appropriate “< ./” or < …/” arguments.

If “xdrip2.patch” is located in the lbrelink folder, then the command probably should be:

patch -p1 --binary --merge < ./xdrip2.patch

UPDATE: Sorry, it looks like this forum editor adds an extra “.” to the text! You probably did not have 3 dots in your command! I see mine also show 3 dots!! The 3 dots should be 3 dots!! See my next response though, as I think you need to use BACKSLASHES rather than the FORWARD SLASH.

1 Like

Ah, I noticed that you are using Windows, right? If so, then the forward slash should be a BACKSLASH. Eg:
for Windows patch -p1 --binary --merge < ..\xdrip2.patch

depending on location of your xdrip2.patch file. Also, you could use the full path of your xdrip2.patch rather than the “.\” shorthand.

Yes, using windows, so backslash used. i am using “two dots”, (and have tried one and three also!) - no luck. i am in a command prompt and have changed the directory to “librelink”, which is precisely where the xdrip2.patch file is located.
so i’m not sure what’s going on.

1 Like

Where is your patch executable located? The first command in your screenshot implies it cannot file the patch executable.

i guess it’s this file?

in which case, it’s inside a few folders inside the librelink folder.

the instructions don’t ask for it to be run though… do they?

1 Like

Yep, that’s it. It sounds like you didn’t do the full gnu installation setup? Typically, GnuWin32 is a full set of “Unix” like commands installed on Windows. These gnu commands allow one to execute the basic Unix command set, like “ls” to list files in a directory, etc. If you follow the instructions to install GnuWin32 then you would have access to all GnuWin32 commands under the GnuWin32\bin folder. I’m not sure if patch has any other dependencies on other “Unix” libs that typically get installed with GnuWin32. If it doesn’t, then you should be able to execute patch located in librelink\GnuWin32\bin. Something like:
C:\Users\user\Downloads\librelink\GnuWin32\bin>patch -p1 --binary --merge < .\xdrip2.patch

1 Like

Here is where i downloaded GnuWin32: Find out more about GnuWin |

I ran it, and it looks like the “full gnu installation” to me…?


Funnily enough, there is a comment at the bottom that says:
“Probably good code, great functionality, but won’t run on your Win10 PC until you manually configure a path properly. Try finding wget.exe in \Program Files (x86)\GnuWIn32\bin and add that directory to your path. Really sloppy installation and configuration, guys.”
…which sounds relevant, but i feel so far out of my depth i really have no clue…

1 Like

Hmm, that image just shows that it is installing the sed Unix command, nothing more, but probably the image is not displaying the full log.

Yes, you should add the location of your GnuWin32 path to your Windows system path. Then open a new command window to run any of the GnuWin32 commands. I’m on a Mac, not Windows, but from my recollection, you can add the path by opening Control Panel. Follow the instructions in this link for Windows 10. Ignore any reference to ‘java’.

By adding the path of your GnuWin32\bin directory to your system path environment, you’ll have access to all commands in your cmd window.

1 Like

Hello there @Trying. I hope all is well with you! As you can tell, I had a few days off from this as it was giving me a bit of a headache… but feel i really need to get it done, as i want to start using these Libre2 sensors and stop relying on this extra bit of hardware on my arm (the miaomiao, which needs charging with a unique cable every 7d, making it very easy to get caught out when travelling etc…)

I think i got as far as downloading everything, but switching the cmd window to the GnuWin32\bin directory and then attempting to run it (which i think was your suggestion?) doesn’t seem to yield any results.

I think you also also mentioned i might not have installed gnu fully/correctly…but i’m not sure how we check this?

I’m sorry for being a pain on this, but i’m really struggling with these GitHub instructions, and really don’t know where else to turn. Thank you so much for your patience!

1 Like

No, you probably should follow the github instructions which says to cd to your librelink directory to run the patch command. However, follow my previous post to add the GnuWin32\bin directory to your PATH environment variable:

After you update your PATH environment variable following the above link, open a new CMD window, then cd to your librelink directory and run the patch command.

The “< ..\xdrip2.patch” argument on the patch command indicates that the xdrip2.patch file is in the directory one up from your current directory (librelink\GnuWin32\bin). In your image above, this would mean that it is located in your GnuWin32 directory, which it is not. Isn’t it located in your librelink folder? If it is, after setting your PATH environment variable, change your patch command in your above image to specify the input at “< .\xdrip2.patch”. This would indicate the the patch command will read the xdrip2.patch file from your current directory (C:\Users\user\Documents\libre patch\librelink), ie., your librelink directory. Alternatively, use the full path of the location of your xdrip2.patch on your patch command, for example, < “C:\Users\user\Documents\libre patch\librelink”. I believe you will need the quotes around the full path since there is a space in the full path “libre patch”.

1 Like