not displaying all BGs

I’ve started using on my Mac in the menubar, at the recommendation of so many here on FUD, @ClaudnDaye at Sugarmate thread.

I use it similarly to @docslotnick, in conjunction w/ xDrip+, Nightscout and Dexcom G5.

I notice I frequently have gaps in the graph despite xDrip+ having a 100% capture rate. Does anyone else experience this?


1 Like

@Trying I notice that too. I think it’s from Dexcom Follow not getting a reading, as it has no backfill function. This will occur especially if you are using your watch.

The watch will backfill the phone when it comes back in proximity, so you get 100% collection. But Follow only reports from the phone in real time, so it misses the readings while the watch is out of contact with the phone.

That and Dexcom Follow general bugginess are the only reasons I can think of.


I see this from time to time and I believe it’s just a glitch because when I slide the scrollbar right to left and go back to that spot the dots are there.


Ah, okay, that is what is going on then! I do mostly use the watch as the collector. I didn’t realize that Dexcom Follow did not support the backfill functionality. Is this a Dexcom issue, or an xDrip+ issue? I’m assuming Dexcom? Since I’m away from my phone for hours on end sometimes, it is really annoying! Maybe there is some workaround…? I only just started using Sugarmate after @ClaudnDaye mentioned it. Its UI on the Mac is really handy in the menubar, but it would be even better if they could get the data directly from Nightscout!! :wink:

1 Like

They can!
Settings → Data Source

Edit: Okay just kidding. That’s how you change it on the iPhone app, I have no idea how to change it on their other apps, can’t figure it out. But it can read from a Nightscout URL, mine does.

Yes, but I am not using the Dexcom App. I using xDrip+ on Android which supports a Dexcom Follower (ie., sugarmate). I will check to see if it is possible to send the backfill data to the Dexcom Servers, or perhaps xDrip+ does send the data, but Dexcom/Sugarmate ignores it. Not sure!

Sugarmate isn’t tied to Dexcom.
I originally set up Sugarmate to pull data from Nightscout when I was using Libre+MiaoMiao+Spike, no Dexcom involved at all.

1 Like

Oh, how do you configure it to use Nightscout? Or maybe that feature is only available on iPhone? I’m using Android. Maybe I could install it on an old iPhone 5 that I have and am not using. Just to configure it to use my NS URL…

@Trying I just submitted Follow backfill on github as a feature request.
Let’s see what happens. I’m not optomistic.

1 Like

Unfortunately I can only seem to find the option via the iPhone app, it doesn’t seem to be present on the Mac app or the web app. On the iPhone app you can go to Settings -> Data Sources and choose to input a Nightscout url.

Might be worthwhile to email them about doing this on their other apps? Not sure


Great, thank you! I’ll take a look at xDrip+:smile: Seems like if this is solely an xDrip+ issue then it can be resolved upon watch / phone reconnecting. Let’s see :slight_smile:

Good idea, I’ll do so in the Feedback!

1 Like

@Trying This was just started as a commit to fix the problem by @kskandispersonal at github. My guess it will be added in a few weeks.

Yes, I see! :slight_smile: Thank you!

@docslotnick There is also another issue w/ but I don’t think it is an xDrip+ issue. does not display BGs < 40!! You probably never experience this (I hope!), but I happened to have lows today, once in the morning and again in the afternoon. Bad day for me! All BGs display in except those < 40. Probably Dexcom Share or expected behavior? These lows display in xDrip+, Nightscout and Tidepool for me, just not I sent a feedback email to Josh / so hopefully will get a response from him.

This is a SugarMate screenshot. You set your graph range.

1 Like

I think that’s an issue with the Dexcom sensors rather than sugarmate, I don’t believe the sensors themselves read lower than 40 - they just switch to saying LOW


@Trying. You are correct! I had a low <40 the other day and it’s not at all displayed in sugar Mate. Hadn’t noticed.

1 Like

It’s just a setting folks.

1 Like

I think you might be right. xDrip+, Nightscout and Tidepool do display it as 39, but of course, it could actually be lower, it’s just that xDrip+ sets the value to 39 for anything < 40 coming from the transmitter.

Thanks, good point! I do have the lower range set to 30.

I think it isn’t a big issue since we can assume it is a LOW, and we really don’t know what the actual value is anyway, just that it’s < 40! I only noticed it because I was testing the github fix (in your link) and saw that sugarmate was still showing gaps in the graph, but only for < 40 BGs!

@docslotnick By the way, do you ever have gaps in your Tidepool graph? I noticed today that I had about an hour+ gap in BGs. Other apps (xDrip+, Nightscout, and do show these BGs, and phone and watch were both in-range during this time.