Sony SW3 Suddenly not connecting to G6 transmitter

My daughter’s Sony SW3 has been running with xdrip+ with no problems, but today it stopped connecting. I verified that Bluetooth is on and looked over all the settings on the watch and the phone. I don’t see any obvious issues. The watch says “Dexcom KM Disconnected.” When I click on it to connect, it tries but doesn’t connect. Any suggestions?

1 Like

@sahmcolorado Haven’t seen that one before. But you should try to reboot the watch, that solves most watch problems. If it still doesn’t work, reboot the phone.

I know it can be frustrating at times, but it’s usually something simple.

@sahmcolorado Also, “Dexcom KM” is probably the Bluetooth connection to your transmitter. Be sure you have " constantly scan for Bluetooth" and " Reauth on every connection" checked in G5 settings on the phone.

Thank you @docslotnick :slight_smile:

I did already try rebooting the watch, but not the phone. I’ll try rebooting the phone.

Do you mean on the phone or on the watch? I have those set on the phone already.

@sahmcolorado. Yes. I meant on the phone.

1 Like

OK. Hmmmm… checked those settings and rebooted watch and phone and still the watch simply mocks me.

@sahmcolorado I don’t think your G6 transmitter is out of juice yet.

Try going into “system status” and hit “restart collector” ( the big button at the bottom of the Classic Status Page.).

Also, I know you probably don’t want to, but disconnect the Dexcom receiver from the transmitter. It may be competition for the BLE signal.

The fact that it’s been running just fine means it shouldn’t just stop.

Thanks. I’ll give those a try.

Shortly after my last reply here, the watch started continually rebooting. A factory reset didn’t help. @ErikKnowles looked it up and found that it is a known problem. He ended up installing the latest software and it now works. We don’t really know if the software update is relevant, so it may happen again. Also noticing that the battery is either not charging correctly or just losing it’s charge very quickly. I’m beginning to think that this $60 watch wasn’t a bargain after all.

1 Like

sahmcolorado’s husband here: the SW3’s now stopped communicating with the transmitter. It’ll pull data from a phone, but it will not serve as collector. Scanning for Bluetooth devices with the watch does not show the transmitter.

Not sure how to proceed…

Hi @ErikKnowles Assuming you have all the settings correct, which I assume you do, this is something that should be solved by a reboot of the phone and watch. If that doesn’t work I would be suspect of the watch’s Bluetooth hardware.

Just make sure all the Android Wear settings in xdrip+ are letting only the watch be the colleactor.

Thanks. I’ve rebooted both, did a factory reset on the watch, switched phones, made sure the watch was the collector.

I’ve read in various forums that newer versions of Wear caused problems with BT. I’m considering installing an older version to see if that makes any difference.

@ErikKnowles Thanks for the heads up on Wear. I keep it up to date and have not had any problems, but this sounds like a possibility.

Good luck!

Late follow up – it wasn’t a Wear problem after all. Not sure what did it (low battery or one of the kinda-confusing “force wear” options), but the watch’s been working brilliantly for weeks.

THANK YOU for all your help. As a coder (back in the day I built a combo clock/BG tablet app. for the original Dex) I should look into how I can support this project!


@ErikKnowles Glad you got it going!

There are so many directions that coders want to take xDrip+ that I’m sure someone with your skills could find a good place.

I’m an old hacker from way back. The last project I completed was a Bg tracking app for the Palm. Never got in to Android or iOS development though.