Samsung s9 update 12/6/2020 - Bluetooth request issues with xDrip

Just updated my Galaxy s9, and wouldn’t you know it? - there’s an issue.

For some reason now my Dexcom won’t stay paired with my phone, so every 5 minutes, the phone asks to confirm Bluetooth connection with my dexcom transmitter (ID: DexcomGY).

Anybody know a workaround to automatically accept the Bluetooth connection every time? This every 5 minutes thing is killing me!

Hope everybody’s staying safe out there,

-M

[SOLVED: see below]

3 Likes

@Pastadude , have you tried rebooting, and have you tried deleting all of your other Bluetooth-connected devices from your phone Bluetooth settings?

Hi @Pastadude Are you using xDrip+? If you are make sure to turn off all the settings in xDrip+ in Less Common Settings>Bluetooth settings that reconnect Bluetooth at each connection. I would bet it’s some new Samsung nifty security feature to question every connection request. They’re so helpful.

Alright, REAAAAL hit or miss here, but just like last time, the solution seemed to be a buckshot approach. I’ve noticed some people saying the latest Android update bricks XDrip+ on Samsung phones, so I figured I’d write out what worked for me. I’M USING A SAMSUNG GALAXY S9, A DEXCOM G6, AND THE LATEST NIGHTLY XDRIP+ BUILD, 11/26/2020.

Just a quick fyi: deleting and re-adding bluetooth connections, turning bluetooth on and off, and restarting the phone didn’t have any affect, so I’d recommend against churning your wheels on those if you’re having issues too. I tried a few weird things and found the solution to be:

IN SAMSUNG: Make sure the Dexcom pairs (which means sitting in your bluetooth, waiting at least 5 minutes for the Dexcom transmitter to show up, and then smashing the pop-up until it finally connects - note that it can connect, but not STAY connected)

IN SAMSUNG: Download the Samsung smart things app, and add your dexcom transmitter ID to your “directly connected device” list. No idea why, but this seemed to help the stability.

IN SAMSUNG: Go to your settings -> connections -> more connection settings -> and turn nearby device scanning “ON”

IN SAMSUNG: Go to settings -> lock screen -> smart lock -> trusted devices -> add trusted device and add your dexcom sensor. It took a few tries to get it added.

IN XDRIP+: go to settings -> g5/g6 debug settings -> and select “use the ob1 collector”, “native algorithm”, “minimize scanning”, “allow ob1 unbonding”, “allow ob1 initiate bonding”, and “authenticate g5 before each read”. Note that I’m not certain all of these settings are needed, they’re just what I’m using that works on the latest Samsung android update (as of 12/6/2020).

IN XDRIP+: go to settings -> less common settings -> bluetooth settings and enable “turn bluetooth on”, “bluetooth watchdog”, “g5 bluetooth watchdog”, “trust auto-connect”, “use background scans”, and “allow blucon unbonding”. Again, these might not all be 100% necessary, but it’s working for me.

I futzed with all of this for more than a few hours last night while every 5 minutes my phone would ping me asking to confirm the bluetooth connection to my dexcom… I was getting ready to shut the phone off completely to stop the insanity before I tumbled on what I’m considering a fix.

If anybody has any more direct solutions, or ideas why it’s a problem at all, I’d be happy to hear them, but in the meantime I’m considering this solved… and hope that if anyone else is having the same issues, they can use this for help!

Thanks to @Michel and @docslotnick for the assistance - hope you guys are doing well, stay safe during these crazy times!

3 Likes

Well, what the hey, sometimes that is the only thing that works :frowning: Thanks so much for posting what worked for you!

FYI, I will edit your thread title to help people searching for this problem, and I will mark it solved in your body text (it will show as an edit)

And you too! Don’t be a stranger, we are looking forward to your next posts!

1 Like

@Pastadude FYI, according to JamOrHam in an announcement on github yesterday says the Nov. 27, 2020 nightly update solves the repeating request to pair problem on Samsung phones that were recently updated.

BTW, your creativity and tenacity in working up these fixes is greatly admired!

2 Likes