Samsung Galaxy S9+, MiaoMiao and xDrip

Hi all,

Has anyone using a S9+ (or S9) installed the October security/update patch from Samsung? I’m having a real problem with xDrip and my MiaoMiao maintaining connection, and I’m trying to see if this update is the problem.

Everything was working fine until yesterday morning when I started getting random disconnects/signals missed during the day. No big deal I thought - I’ll just stick a paper clip in the reset hole when I get home and then charge it up ready to go on my new sensor when I replace it in the morning.

But, even with the new Libre sensor I am having the same issues and I can’t work out what is wrong. Just to reiterate, the problems only started yesterday and absolutely no changes had taken place in the xDrip settings/setup on my phone. Nor had xDrip been updated to a newer version or anything like that.

I seem to be losing connection roughly every 12 minutes, and in order to get it back I need to restart the collector and/or do a Bluetooth scan for the MiaoMiao Bluetooth signal again. The weird thing is that in the system status screen in xDrip it still says that my MiaoMiao is connected even though the home page says the signal was missed X minutes ago.

I have tried uninstalling and reinstalling xDrip, clearing the cache from the Bluetooth app and xDrip, clearing the S9’s memory and the device maintenance screens too. I’ve “forgotton” the MiaoMiao but nothing seems to be working beyond the initial 10+ minutes when it is connected and getting signal before breaking again.

The only other thing that has changed on my phone that I can see could’ve caused the problem is the October update patch.

So, has anyone else updated and not had problems, or done the update and had similar problems? Any fixes that have worked for you?


1 Like

@MisterMints First, welcome to FUD.

I really don’t know a lot about the Libre side of xDrip+, but there was someone on the xDrip+ Gitter group asking the same question yesterday. So there must be something Samsung did with the S9+/S9 update that mucked things up.

Sorry I can’t give you any solutions but maybe you can talk to that user on the Gitter group.

1 Like

Hi docslotnick

Thank you! At least that confirms it’s not me, something I’ve done or probably not something wrong with the MiaoMiao.

Would you happen to have a link to that forum post?


1 Like

@MisterMints You can find that gitter thread here:

You’ll have to scroll to find the posts because Gitter, well, actually sucks. And if you want to post you’ll have to sign up.

The good news is that I’m sure a fix is only days away. Be sure to update with nightlies.

1 Like

I do hope so! At the moment the whole system is pretty useless to me! I’ve logged it as an issue on the GitHub pages for xDrip and posted on the Gitter chat page too, so fingers crossed someone who knows what they are doing better than me can put a fix in soon.