FUDiabetes

Getting around a confused calibration 2 error?

Hey everyone, been a while! I’m glad to see the samsung workaround is still helping people out :slight_smile:

I’ve come across a new issue (a few times now), and for the life of me, I can’t figure out what it really means, or how to fix it… I’ve managed to trigger the "confused calibration 2’ error.

This isn’t the first time it’s happened, but I’m never sure what the heck triggered it, or how to fix it! I switched to a brand new transmitter today, with a brand new G6 sensor, on the latest nightly of xdrip, using my samsung.

I stopped the last sensor (connection was dropping like crazy) through xdrip, removed the sensor, input the new transmitter code, attached the new sensor, popped the new transmitter in, and then started the new sensor in xdrip.

The weirdness started quickly - “session start failed: clock not synchronized or other error”.

Okay, cool, the countdown is still running, but now it reads sensor status as stopped? Meh, I’ll ignore that…

Then 2 hours later it asks for calibration, after doing so, I get ‘calibration rejected: sensor stopped’.

Well great, let’s actually stop the sensor and then restart it. No “clock not synchronized” error, so far so good, right?

Xdrip asks for calibration, but rejects both, saying “calibration rejected: not ready to calibrate” after waiting a minute or twenty, xdrip tells me my sugar is 59

Lies and deceit! I don’t believe it, I check my sugar and I’m at 129. I go to override calibration to add 129 as the data point, and I get “calibration rejected: rejected”.

Alright, now I’m just confused, I know xdrip is wrong, but it doesn’t seem to want to listen. I try deleting all calibrations for the sensor, which just triggered an endless loop of ‘encountered backfill data we don’t recognize’.

Needless to say, I definitely don’t have any readings, nor any idea how to fix it. Knowing I’m on hour… 6? of a brand new sensor and transmitter, I don’t want to waste it, but I’m also clueless as to how to repair it. I think my last attempt of the night will be to completely stop the sensor, delete the transmitter and see if I can reset it all… because “confused calibration 2” really isn’t doing it for me (especially after telling it to forget all calibrations!!!)

Anybody have any ideas as to what could have triggered all this chaos, how to fix it, and how to avoid it in the future? Any help is greatly appreciated!

2 Likes

Hi @Pastadude Try running in native mode if you’re not. And run a Dexcom receiver simultaneously if you have one. These steps will let you know if the problem is xDrip+ or Dexcom.

But actually, it sounds like the transmitter is screwy.

2 Likes

As soon as I switched from the OB1 to native, I got the message “unusual calibration state - waiting for more data”… but of course, there’s no way to add calibrations through xdrip right now.

Ugh.

Where the heck did I put that old dexcom receiver…?

1 Like

@Pastadude You also might try installing a version of the app from maybe a week ago, if you happen to update nightly. I once had a weird problem resolve after downgrading.

1 Like

Alright! Problem solved. I’m always for the buckshot approach - if it doesn’t work, I’ll learn!

I downgraded to an earlier version (last week), wiped the sensor calibrations, told xdrip to forget device, restarted sensor, and added calibrations using the Dexcom receiver (which was tucked in a drawer in a desk that’s pretty much unused these days) - and success! Xdrip is back up and running happy, and the original receiver is back in its drawer of obsolescence.

Thanks so much for the suggestions Doc, I hope both the 'tech and the 'betes are treating you well!

-M

1 Like

Way to go @Pastadude!
Just remember, native mode takes the readings (and calibrations) from the transmitter.

1 Like