Can't calibrate xDrip+ anymore

Sorry for all the posts – I’m still getting used to xDrip and working through issues with it.

Today I felt that the readings were off so I calibrated it with BG readings from my Freestyle Lite (the readings were indeed about 25 off), but got this message on xDrip+: “Sensor raw data sanity failure”, and nothing changed with the reading on xDrip. I tried it multiple times and also did the “override calibration” thing, which gave me the same result. I had to do the day before yesterday as well when the readings were off, and it worked fine.

Suggestions on what to do? This kind of thing makes me nervous about the reliability of it, especially since I’ve only been using it for a few days so far. Also, if I need to keep calibrating it then there’s no point to use it, for me – does the recurring need for calibration go away when you start with a brand new sensor? This time I started with one that was already 5 days into use.

1 Like

@Headlands This happens when the calibration slope is more than twice out of expected range.

Calibrating at this range would destroy the algorithm because it is just too far off.

How old is your transmitter? Some people have had success resolving this problem with a transmitter change.

First, though, try this. Go to “Stop Sensor”. In the dialogue choose to"Don’t stop, just reset all calibrations". Then restart your current sensor. This will allow you to build a new slope and intercept. If this doesn’t help, then you know the transmitter and sensor are not sending sensible data for calibration, and need to be changed.

Don’t be discouraged. This happens very rarely and is actually designed to prevent you from getting erroneous readings.


OK cool, will try later today. Thank you again.

Hi Doc, I’m having a related problem that you may know how to handle. My sensor was running fine, but time came for it to auto restart. When this has happened before, it did the auto restart, then required a calibration before it would give me any data. After calibration it resumed giving me data.

This time it did the auto restart while I was driving, so I had to wait until I could calibrate. By that time (about an hour after auto restart), it would not allow calibration, with the calibrate option reading “cannot calibrate right now” instead. No data has come in since the auto restart. I tried restarting collector from system status page, but that doesn’t help. Also tried restarting my phone, also without effect. Any idea how to force a calibration when it says “cannot calibrate right now”?

@jag1 That’s a new one on me. But you might try to stop the sensor, and actually stop it. Then restart it. If you still have the sensor code I’d be interested in seeing if that worked or was refused. You may have to go through the 2 hour warm-up, but may avoid it by saying you placed the sensor more than 2 hours ago in the dialogue.

Let me know how it works.

1 Like

I did the sensor stop, then start. Asked for code which I had, and it accepted. Says “g5 transmitter is still warming up, please wait”. Is that the msg printed while waiting for two hours? But errors in event log so may not wake up “NO BG? COULDNT FIND SLOPE”.

I guess that msg is what it logs during the two hour startup, because it did restart after a two hour delay. BTW, I did enter the real start time for the sensor (days earlier) but it gave an error in the log - “cannot rewind sensor start time beyond (5 minutes before current time)” so that option didn’t prevent the 2 hour warmup for me. Anyway back running again, I’ll see if I can get it running well even without the previous calibrations. Thanks.

@jag1 Sorry for the late reply, I fell asleep early last night.

Glad you got it running! I know on most updates now JamOrHam is fixing a lot of dialogues that still say G5. I guess he hasn’t gotten to that one.

But it does pay to update regularly. If you’re not on the alpha channel it would be a good idea to join.

Also, you may prevent further problems by running the native algorithm, which should give you identical results as the Dexcom receiver.


Please don’t apologize, I appreciate any help whenever you can give it.

Strangely it asked me this morning if I wanted an update for the first time, so I accepted it. Don’t know if that means I’m on the alpha channel or not?

I am already running native, but haven’t turned the Dexcom receiver on since I started my first sensor because my watch arrived from eBay and I’ve been running xdrip ever since. I assume you don’t want the D receiver to pair with a sensor once it has been restarted after its first 10 days is that incorrect? How does the receiver know when the 10 days are up?

Also, auto restart is great, except it can restart at a bad time, and based on my experience may require a calibration soon after auto restart and failing to get one requires full restart. Was that a one off, or have you ever had any issues after failing to calibrate on an auto restart?

1 Like

@jag1 The Dexcom receiver won’t interfere if it has the wrong transmitter code. Just change on number or letter, and plug it in somewhere out of the way. If it’s powered down unplugged, if you want to use it later it will give you a fatal error code.

You can make sure you’re on the alpha channel by setting it in less common settings>>xDrip+ update settings. With the G6 it’s a good idea to be on alpha because there’s something fixed every day.

The sensor time switch is in the receiver in the G5, but I don’t know about G6. Also about the restart I really don’t know if it’s a one off. I just started my first G6 sensor a couple days ago so I’ll let you know.

Anyway, I’m glad you got it working!


I checked and auto update was enabled so the G6 updates must have quieted down a lot since this is my first update since first install at Christmas time.

To be honest, I don’t see a need for the receiver unless I lose my phone so I plan to leave it powered down in the box. Unless I didn’t understand you - you don’t mean the receiver will break if it is left powered down, do you? That just sounds too screwy - receiver is DME so supposed to last for some time isn’t it?

Only thing I have done only with the receiver and not phone is starting a new sensor. But I guess I kind of did do that when I stopped my sensor and restarted with the same code - only this time I would give it the code of the new sensor.

1 Like

@jag1 I’ve seen 2 receivers fail after being used and powered down. I was advised by Dexcom I’m Aster the second one to make sure it was stored plugged in.

I’m sorry. I should have said you should be on the nightly channel. You’ll update a lot, but there is a lot changing. The update you got at Christmas is ancient now.


OK, I appreciate the advice but I’m not willing to leave it plugged in for the small chance I may need to use it three months from now. If it fails and they need to replace it I’ll just leave the next one in the box. That’s got to be a design flaw they will fix before long.

Sorry I didn’t understand, now I get what you were saying about updates. I set mine to beta release, not alpha release. That’s why I’ve only had one update (today) after three weeks. For now that seems reasonable since I’m not developing so no need to be on the bleeding edge, though I’ll probably switch to alpha at some point.

@jag1 I understand your trepidation to not update regularly. But xDrip+ is not like Amy app I’ve ever used. The nightly builds are solid, and if something breaks, it’s fixed within a couple of hours.

The constant updating of the G6 function is pretty critical. Improvements are made nightly.

The nightly channel may seem like a nuisance, but it’s well worth it.