FUDiabetes

xDrip+ --- Unable to calibrate (Dexcom G6 1.6.5.25)

Running xDrip+ 2020.06.11 (same with 2020.03.25; upgrading to latest nightly today did not fix the issue) with Dexcom G6 with 80 tx Firmware 1.6.5.25 (rebatteried); before with 8G Firefly calibrations still worked! After changing back to the 80 tx I cannot calibrate any more. See screenshots. Calibrations are registered in Event Log but the message “Calibration Accepted” never shows up! Somehow xDrip/G6 ignores my calibrations… :frowning: Tested with both methods
A) “Initial” or “Add calibration” menu
B) Syringe icon with Advanced Calibration/Automatic Calibration and Automatic Mode ON

G6 running with following options: OB1, Native Algo, Restart Sensor, Preemptive Restarts, G6 Support, Allow OB1 unbonding, Allow OB1 initiate bonding ==> ON and all other G5/G6 Debug Settings OFF . Currently on day 11 of sensor life, preemptive restart on day 9 worked fine but now I need to calibrate +10 mg/dL without success. Tried to calibrate twice yesterday and five times today! Calibrations are showing in “Calibration Data Table” as well as in trend but they are not working. Have also tried “Stop Sensor/Reset Calibrations” in between, no success. See below. Can anybody help me? THANKS!!

(Have also posted this on github NightscoutFoundation/xDrip/Issues)



1 Like

I have done calibrations when using no code at start. And entered via receiver, not directly into xDrip, and they do show on event log in xDrip.

Next time I will check if calibration entry via xDrip works same as yours.

Wondering why you entered calibration, if you used code, and xDrip and meter BG were so close.
I only calibrate if far off.

2 Likes

I don’t have a receiver - only xDrip+ on smartphone. Running in native mode with code, worked all the time. Now after using one Firefly transmitter (8G) I’m back using my old rebatteried 80 tx and cannot calibrate any more. Problem still not solved.

2 Likes