G6 Signal Loss issue

I am hoping someone else has experienced this same issue and has found a solution: My 13 yr old son has been using the Dexcom G6 and Omnipod 5 for over a year now. Within the last month or so he has been getting “signal loss” errors on the G6 app on his smartphone. This then causes me to have “no data” on the Follow app on my phone. Most of the time if he realizes the signal loss, if he clicks on and opens up the app fully on his phone, it comes back within a few minutes. However, it has occurred while sleeping and during school hours and has lost signal for hours at a time. When this starting happening almost on a daily basis, I called tech support and they sent out a new transmitter. However, this same issue is still happening with the new transmitter. This morning the signal loss began around 1am, and did not correct itself until around 7am when he woke up and clicked to re-open the app. When it did reconnect, the “dots” of the readings filled in but not completely – no readings from 1am until 4am. Tech support says it can be that there is something interfering with the Bluetooth, but nothing has changed on our end. All of his other “stuff” (like wireless earbuds, video games, etc.) is exactly the same as it has always been. I feel it is important to note that when the Dexcom app reports signal loss, luckily the Omnipod controller has no issue and continues to read BG levels uninterrupted. So this appears to be a weak signal between the CGM transmitter and the app on his phone. I am hesitant to have him uninstall and reinstall the app as we can’t remember what issues we may run into by doing that. We don’t want to change transmitters again because this sensor still has 6 days left, If anyone has any ideas as to why this might be occurring or how to remedy it, we would love the info!


I am sorry you are dealing with this. I am not a pumper, so cannot help with the Omnipod issue. But if you do decide to change transmitters, please know that you can pop out the transmitter while it’s on your son’s body and definitely restart the existing G6 sensor with the new transmitter. I know what a pain it can be to change sensors. Happy to post more on this if you go that route-- sending you good connectivity wishes! Jessica


@ABCD I don’t know what the problem is, sounds almost like the symptoms of a compression low, but have never heard of this before. I would anticipate one of two things: 1) a setting has been changed regarding the app on the phone or 2) a new piece of software has been introduced on the phone that is interfering with proper operation. I assume you’ve checked all settings on the phone, but have you checked for other apps being added to the phone/phones involved?

1 Like

@TomH We went through and checked all of the settings to make sure nothing changed – everything was set as it should be. No new apps have been added to the phone. I am wondering if we just have a bad transmitter (but again, it has no problem connecting to the Omnipod), or if there is something with the Dexcom app – still am hesitant to uninstall and re-install – has anyone had to do this? Does it take a long time or cause interruptions in the sensor session?


I don’t use omnipod, but I do have dexcom going to phone (as well as tslim) and have had problems with gaps in readings when I have them in my pocket and, fit being a bit different in different clothes, the phone and tslim land so that there is bone between them and the dexcom. Most commonly, with me, while sitting, and a looser-than-usual pocket has landed on the underside of my leg, or sleeping and under back. How is he carrying the phone, has that changed? Could his clothes, the way he fits into the clothes, or way of sitting or lying down have changed?

Yeah, we’ve been experiencing similar weirdness with my teenage son also. He recently started managing everything through the G6 and Omnipod apps on his smartphone, with us getting readings on the Follow app. It has generally worked great, but there are strange periods where he’s not getting a reading on the G6 app. Oddly, he’ll continue to get a reading on the Omnipod app. So it’s like the CGM is still working fine, but it’s more of a connectivity or Bluetooth issue. We just put in a new transmitter, so we’ll see if that helps. But we may also uninstall and re-install the G6 app, in case it’s needs an update.

1 Like

@Tim418 Please let me know if a new transmitter or reinstalling the app seems to solve the problem. We have been “waiting and hoping” that it’s some weird fluke in the system that will work it’s way out…the number of signal loss messages on the G6 app have decreased, yet we have changed nothing, so I’m remaining hopeful!

1 Like

When I have had this issue in the past (btw, did you mention which phone you have?), it was because I had another transmitter listed in the BT app. So the BT app keeps searching for a dex transmitter. Go to your BT app and see if the old transmitters are listed, and if so then delete them.

@Mikey417 Thanks for the tip…I already had him delete all other transmitter numbers. It’s still happening, so I’m really at a loss as to what changed and why it has no problem with the Omnipod receiver but loses signal to the Dexcom app on his Smartphone (Samsung Galaxy S20fe).

I have the S21 phone, and had the S20e. It may be the Dex app. I use this app, which is a derivative of the German app that seems to work better on Samsung phones: https://docs.google.com/forms/d/e/1FAIpQLScD76G0Y-BlL4tZljaFkjlwuqhT83QlFM5v6ZEfO7gCU98iJQ/viewform?pli=1&pli=1Build your own app

I have similar experience to @Dxin1955 with my Dexcom G6 sensor on the back of my arm. If I sit with arms tight to the body my BlueJay watch–even on the same arm–loses the signal. My Tandem T1 pump carried on my belt below the sensor usually does not. But if the pump is on the other side it will. You might think about where your son’s G6 sensor and phone are while he is sleeping.

Have you tried re-booting the phone? That could give the app a kick to restart.

I had this problem when I owned a cheap Samsung trac phone. I ended up using the receiver for the most part.

As soon as I switched to a new iPhone 13 problem solved.

Interesting, I never thought it could be his actual phone- it’s less than 2 years old.

Generally these symptoms are caused by a 'phone update changing the battery optimization handling. Android aggressively stops apps that are using the battery and the G6 app necessarily does that because, well, it wakes up every 5 minutes and uses the battery!

The fix depends on the precise 'phone and the Android version. Samsungs are particularly prone because they’re competing with Apple on battery life so they use modified versions of Android that are very aggressive on the battery.

There will be several settings that need to be changed in practice. The first is to ensure that “battery optimization” is switched off but in later versions of Android (I’m using 13) it’s possible to be more selective; there are per-app settings.

It’s a job for your son; once he understands the problem he will be able to work out the fixes. You may need to give assistance because lots of the places where the information is (e.g. Reddit) are not appropriate for younger people. FaceBook has groups for G6 users that may help but the real information is to be found in groups that support alternatives like xDrip+; the problem isn’t specific to the Dexcom app.

Ah ha. Yes, JBowler’s suggestion lit up a memory in my greying brain. It is battery optimization… I also use xdrip+ (to get readings on my Galaxy watch), and I get a notice to check optimization and turn it off. So I second his suggestion.


@jbowler Battery optimization has been set to “off.” When this first began happening, we checked all of the settings that the Dexcom troubleshooting website recommends. If you can think of anything else, let us know!

I’ve had the same problem lately. It’s happened 3 times in the last month. ‘Signal loss’ for hours. Twice it was preceded by plummeting numbers and the third time I was out of range ar first but then once I got back to my phone, the message changed. Also, when I did start to get a reading, it was just a number- no arrows and no graph on the bottom of the screen. I closed and then reopened the app which helped with that. I don’t have an Omnipod. During these periods, I’ve been using my trusty BG meter to monitor my levels which works for me. I’m still in my honeymoon period and not taking insulin.
I just thought maybe my transmitter was quitting early but now I’m not so sure…

I have Tandem pump and xdrip on phone with G6.

Sometimes pump or phone loses dexcom reading. So I take reading that is showing on one. and enter on other that it is missing on as a calibration. The number I enter immediately appears.