FUDiabetes

Dexcom won't let me log in?

For some reason I can’t seem to log into my dexcom site itself and share doesn’t seem to be working either.

I follow the steps to reset it and that does nothing. Today I called support for the 3rd time and got the same pat answer - change it again and wait 30 min. I told him to escalate it and he said he would, but that takes 24-48 hours. I’m really becoming frustrated. Anyone have any ideas?

All I want to do is to be able to see my reports when I want to and have my wife see my numbers via share when she wants to and I can’t do either.

1 Like

Do you use Heroku/Nightscout?

If so, you may be experiencing the issue I had not too long ago. Scroll to the bottom for the fix.

3 Likes

Exact same situation. What’s weird is Heroku seems to get data just fine. It just won’t let log into my main account so I can see my clarity reports and for some reason the share to my wife’s phone.

So your solution was to uninstall/reinstall the Dexcom app itself? Makes absolutely no sense but I guess it is worth a try.

1 Like

No. My solution as indicated in the last post was to just remove the two Heroku entries for bridge username and pwd then save it. Once you log in to dexcom/clarity You can add that info back into Heroku.

Procedure :
Delete the actual bridge variables in Heroku, save, reset Dexcom pwd, log into dexcom, change Dexcom password, add back the Heroku bridge variables with the correct info, save, done.

3 Likes

It’s not Heroku getting info. It’s Heroku making repeated calls to that bridge info to communicate with Nightscout and those calls happen in such fast succession that your account is locked out by Heroku as soon as you reset your password and before you can even attempt to log in.

The reason Heroku if locking the Dexcom account is because the info being passed into the login attempt is wrong (you probably changed your Dexcom pwd (as I did) and forgot to change the pwd in the bridge_pwd field so Heroku is passing tue wrong credentials into Dexcom and locking your acct.

2 Likes

That worked! Thanks guys! You’re a lifesaver!

3 Likes

Glad that worked for you! It took me a lot of sleuthing to figure that one out. Glad my solution was able to help someone else.

4 Likes