FUDiabetes

iOS Dexcom App -> Nightscout = no values [solved]

Hi there,

i’ve been trying for two weeks to read my BG values from dexcomshare, for example with Nightscout.
Basis is an iPhone XR (iOS 13.5) with Dexcom G6. Readout via the Dexcom App, Follower Share works and data is transferred cleanly (via Follower App or e.g. Sugarmate).
I have tested two different Nightscout instances, one is at 10be (and was already in use), the other one I have just set up at Heroku.
All Dexcom Bridge data is cleanly entered, including the server location (EU, germany).
Not a single value is transferred, I don’t have an error message either…

What have I tried already?

  • Dexcom App newly installed
  • iPhone factory reset
  • Dexcom password changed
  • different followers / no followers
  • various Dexcom servers

I’m out of ideas.
Have any of you had similar experiences or maybe an idea for me?

1 Like

looking for two weeks now…
and 30 mins after I post my problem, I found the answer:
github dot com/nightscout/cgm-remote-monitor/issues/5608

Seems that dexcom suddenly has a problem with dots and anything other than a-z in usernames.
I will create a new account now because the existing username cannot be changed.
Hopes this helps anybody with the same problems :smiley:

5 Likes

Thank you for the information! That’s good to know.

Also, welcome to FUD!

Thank you that is very helpful information. Hope you are able to stick around a while.