FUDiabetes

Dexcom G6 with xDrip+ on Samsung A8 -- OB1 collector does not work :-(

#1

Im using the G6 with xDrip+ nightly on Samsung A8 but I cannot get any readings when turning on the “OB1 collector”. It works when turning this OFF but then I need to calibrate my sensor which I want to avoid.

Symptoms when “OB1 collector” is ON: “Signal Missed” on main page and System Status showing “Sensor Status: Stopped” while is still shows “Got data xx:xx” every 5 minutes! So it obviously receives data from the transmitter but it does not show in xDrip+! Why? Any hints?? Thanks a lot!

1 Like

#2

Hi @emp00 First, welcome to FUD. Make sure you go to our introduce yourself thread and introduce yourself!

Now, about your problem. Go to settings>less common settings>other misc options and make sure “Samsung Workarounds” is checked.

With the G6 you should also be using “native mode”, in G5/G6 Debug. And while you’re there make sure “I am Using G6” is checked.

Try these and let me know if it now works.

2 Likes

#3

Hi @docslotnick, thank you very much for the reply.

However, I checked all options you mentioned “Samsung Workarounds”, “Native Mode” and “I am Using G6” ==> all are switched ON. Whenever I switch on “Use the OB1 Collector” this error appears right away: “Calibration rejected: Sensor stopped”. The other symptoms described in my intial post still apply. :frowning:

I still can only get xDrip+ to receive bg when switching “OB1 Collector” OFF. Why? What else can I do?

Thanks again!!

0 Likes

#4

@emp00 In Less Common Settings, go to Advanced calibration>Use treatment glucose values and select to always ask first. Then when you enter a Bg value in the treatment panel it will ask if you want to calibrate. For some reason this seems a bit more forgiving on the calibration slope.

1 Like

#5

@docslotnick Do you mean with this setting the “OB1 Collector” should be working? Seems rather that this only enables a prompt asking to optionally using entered Bg values for the calibration. However, I wanted to avoid calibration completely since the G6 is supposed to not require this. Maybe as a workaround, can I manually set the calibration slope to 1.00 and intercept to 0.00 ?? Then xDrip+ would display the raw G6 values which is what I want, right? Still I would be highly interested getting this “OB1 Collector” working which should avoid these workarounds… I don’t understand why this does not fly.

0 Likes

#6

@emp00, sorry I can’t help you, I don’t have the required info—but I still want to say welcome to the forum!

1 Like