FUDiabetes

Dexcom G6 and Xdrip+ / Samsung Galaxy S10+

Hey there! Just upgraded to an S10e from an S6 (!!!) and am getting lots of missed signals with xDrip+. I’ve tried everything mentioned here and still many missed signals.

Did you ever find a solution?

Hey! I did indeed come up with a solution - I posted it on a different thread, I’m sorry I never followed up here… aaaaaaand I’m sorry it’s SO long. People have complained that maybe there’s shorter solutions that worked for them, but in my experience this was the fix that actually WORKED, whereas others… well, they didn’t. It’s an outright pain in the butt, it’s very slow to enact, and it’s very specific… but when I tried shortcuts or alternates, I just never got as comprehensive of a result, nor was I able to really maintain connection. Again, I apologize for the length, but if you go through the steps, hopefully it’ll work for you too! To quote me:

THE ISSUE: If your Samsung device (Galaxy S9, S9+, S10, etc) just went through a forced Android update, then your xDrip+ started having connection issues with your Dexcom (as soon as the screen went dark, overnight, etc), then this solution is for you!

STEP 1: Delete xDrip+. I know this sounds simple, but it’s not. Go in to Settings - Apps -xDrip+. Then click “Force stop.” Then tap “Storage.” While in storage, hit clear cache, and clear data. You need to clear BOTH. Then go back to “xDrip+”, and hit “Uninstall.” Then navigate to Samsung - My Files - Downloads, scroll down, and delete EVERY “xDrip-plus-blahblahblahblah.apk” file. In my case there were about 6, you might have more or less.

STEP 2: Delete EVERY instance of a Dexcom transmitter on your bluetooth list. Go in to Settings - Connections - Bluetooth. Then click the gear icon next to anything that starts with “DexcomXX” (where XX are the last 2 digits of your transmitter), and click “Unpair”. You need to do this for EVERY Dexcom device. (And to be honest it might say “forget”, or “delete” - I don’t remember the exact wording on some of mine.)

STEP 3: Turn your phone off. I don’t know if a restart will fix it, I’m only listing what I did, so I’d recommend turning your phone all the way OFF. Once it’s off, power it back on.

STEP 4: Download the latest nightly xDrip+ from Github. I won’t post a link, but hopefully you know where to find it. Make sure that it’s the right date though, as some instances claim to be the latest but are actually months old!

ONCE IT’S INSTALLED DON’T OPEN IT!

STEP 5: Fix your phone settings. Go straight to Settings- Device Care - Battery- Power mode and choose “High performance”. Then go back to Settings - Apps - xDrip+ and click “Mobile data.” Once there, make sure that “Allow background data usage” is turned ON. Currently I don’t have “Allow app while Data saver on” enabled.

Then go back to Settings - Apps - xDrip+, click “Battery,” and make sure “Optimize battery usage” says “Not optimized”. You might need to navigate through some of the menus to make sure it isn’t being optimized (I think you click the top drop-down and change it from “Apps not optimized” to “All”, scroll all the way down to "xDrip+, and make sure that it is turned OFF). Once you’ve done this, back on the “Battery” section, the “Allow background activity” should be greyed out, and you shouldn’t be able to do anything with it.

Then go back to Settings - Apps - xDrip+ and go to “Permissions.” I had success turning on permissions for Camera, Contacts, Location, Phone, SMS, and Storage. I have no idea which of these it actually needs, but again, I’m relating what worked for me.

Then go back to Settings - Apps - xDrip+ and scroll down to “Advanced.” On “Change system settings,” make sure it is allowed, and on “Install unknown apps” make sure it is allowed.

Step 6: Configure xDrip+. You can finally open xDrip+, and you should be greeted with the standard “Terms and Conditions” pages. When you get to settings, choose your receiver type, and you’ll get to a branch where you choose “CONFIGURE SETTINGS” instead of “Start Sensor.” Again, this is what worked for me, but I configured settings BEFORE I started the sensor.

In xDrip+, in the Settings menu, go to “G5/G6 Debug Settings.” Make sure that all of the following options ARE CHECKED: “Use the OB1 Collector”, “Native Algorithm”, “Restart Sensor”, “Preemptive restarts”, “Go on without calibrations”, “G6 Support”, “Allow OB1 unbonding”, “Allow OB1 initiate bonding”, “Authenticate G5 before each read”. For me, all of the rest are unchecked, and again, it’s working as-is, so I’d highly suggest these options.

Go back to “Settings”, then scroll down to “Less common settings”. In this menu, make sure “Aggressive service restarts” and “Display Bridge Battery” are enabled. Again, this is what’s worked for me.

Then go to “Bluetooth Settings”, and make sure that all of the followed are enabled: “Turn Bluetooth on”, “Bluetooth Watchdog”, “G5 Bluetooth Watchdog”, “Trust Auto-Connect”, and “Allow blucon unbonding”. The rest should be unchecked.

Go back to “Less common settings”, and scroll down to “Other misc options”. One last time, make sure all of the following options are enabled: “Run Collector in foreground”, “Battery Optimization prompt”, and “Samsung workarounds”.

From here you can go back to the xDrip+ homescreen and start your sensor. I still had a sensor session running (I think I started it about 13 days ago), and xDrip+ picked it up as soon as I input my transmitter ID.

Now I hate to say this, but: I’m not tech support. I don’t work on xDrip+. I’m not a programmer, and I don’t know what the hell I’m doing. But I do know that, like many of you, I was getting frustrated at this Samsung/xDrip+ issue, and these were the steps that helped me. There’s no guarantee that they’ll help you - it’s just what worked for me, SO FAR. Again, it’s been running smoothly for about 6 hours now, which is better than it has been for the last 2 weeks, so I figured I would share. If you come up with a better/faster/different way of making this work, that’s awesome - but in my searches I didn’t find a comprehensive guide on how to make it work again, so I figured I would put one together - hence this post. I really hope it’ll help you guys, as I know it can be super frustrating, but fingers crossed that we’ve now got a step by step solution for how to get this problem licked!

-Matt
Your Friendly Neighborhood Type 1 Diabetic

1 Like

Thank you so much Matt. I’ll try this later today – I am so hoping it works because if it doesn’t then I have to go back to the unbelievably crappy Dexcom app, and it will be no more xDrip+ for me. :frowning:

Man, I would pay a small monthly fee to have xDrip+ working. It’s uncanny to me how bad the Dexcom app is (and the receiver as well).

1 Like

So…this has been working perfectly so far with a new sensor I just put in! Its been about four hours and it’s been staying 100% connected. I know it’s only four hours but xDrip+ was losing connection multiple times per hour before with my S10E, so I’m hopeful. It takes a bit of work but no more than a few minutes, no biggie.

Hopefully xDrip+ will get working without a workaround like this, but thanks to you it looks like it might work until then.

1 Like

That’s awesome, and I’m so glad to hear! I’m on day 24 and I experienced my first temporary dropout of about 20 minutes this morning. Fingers crossed it works for you!!!

1 Like

Hi @bpollina - What model of Huwawei watch are you using as the collector?

Its’ the Huwawei Watch 2 that was on sale awhile back. From what I hear, it can be patched to work as a collector, but I’m rarely away from my phone, so I didn’t bother. What I do now is use heroko to display my BS on a tab on my PC at work. If you don’t judge, here’s my link as an example: http://bradsxdrip.herokuapp.com/ . Works great. When I’m away from my desk, I look at my watch or my phone. I absolutely LOVE XDRIP+ and would be lost without it! It even resets the timer on the G6 automatically for me so I can get past 10 days of use. (although I rarely get much much over 10, typically 12 or 14 days).

1 Like

Hey Pastadude,

Thanks for thinking to come here and post your solution. Thank goodness Google picked it up quickly.

I’ve not have luck with my Galaxy S10E following your guide, but there is one glaring exception. I actually don’t have a “High Performance” mode option on the battery settings for the xDrip+ app. I’m wondering if Samsung completely killed this off recently?

I have:

  • Optimized
  • Medium power saving
  • Maximum power saving

And then a toggle

  • Adaptive power saving (which I have off)
1 Like

An Update: Setting the “Adaptive power saving” to On, seemed to do the trick… at least for now. I’ll give it a night and see what happens. :slight_smile:

1 Like

Update, sorry if this is off topic/old thread, but Pastadude’s setup with the 9/10 daily + app got it to work on my Note 10 +. This is so far the first setup of any kind including the official dexcom app that I have been able to get to work successfully.