FUDiabetes

xDrip+ alarms temporarily push Samsung S10e volume to max level, no matter what S10e volume is set at

xdrip
#1

As the title says.

I’ll be at the gym or listening to music in my car and when the xDrip+ alarm sounds the phone volume gets pushed to maximum, which is near deafening sometimes. I want to know when I’m low or high but not at the cost of my music career. :smiley:

Is there a way to prevent this? Thank you!

xDrip+ missed reading alert
#2

Hopefully someone has an idea soon. I am assuming you have gone into Xdrip+ and checked if there are separate volume settings?

#3

@Headlands There are no separate volume levels to set, but you have options for workarounds.

First, you can make an alarm for gym time that only vibrates. Actually, the Samsung vibration is pretty loud for a vibration.

Second, you can have the alarm be any .wav file you want. Record a quiet one and see if that works.

Also, you may be noticing increasing volume level on the alarm. This is a check box in alarm settings.

Bottom line is, you have so much granular control over alarms in xDrip+ that you should find something that works.

Edit: I reread your post and see that phone volume is pushed up when the alarm sounds. This would be an easy fix using Tasker. Are you familiar with Tasker?

1 Like
#4

I regret to mention here at FUDiabetes’ Forum that the Dexcom G5 Transmitter running on the IPhone version of its Dexcom app does nearly the same thing.
I sometimes fall asleep listening to internet radio (streams from a live baseball game, Austin City Limits or WXPN’s World Café etc. ). Sometimes I fall asleep before I decide to activate a sleep timer to shut of that app after x_minutes. But my iPhone’s volume setting would have been set at some just audible volume level.
HOWEVER, if /when my BG reaches one of my “urgent” non-quenchable thresholds then it overrides my iOS settings and not only ‘screams’ its (welcomed!!) warning, but even after I’ve acknowledged the Dexcom app alarm & started to treat the high or low, the DEXCOM APP forgets to release/reset my iPhone’s plume setting, so now my browser page or Music.app’s Radio page returns to its stream – but now at the extremely high volume that Dexcom.app had instructed it to use for a glucose alarm!

Arghh! I complained about this poorly coded app ‘feature’/glitch/oversight to Dexcom, but as of about mid-February it had not been fixed/hashed/updated … so I had to quit using my more nicely featured iPhone app, and had to use only the Dexcom+FDA-required “receiver” instead.

I hadn’t realized such a programming mistake had been made in Google_Android on a Samsung line of smartphones as well!
Please update your phone-resident apps, Dexcom & Samsung!!

1 Like
#5

Hi @Headlands,

Did you try any volume control app? Few here.

I used “Volume Control - Volume Lock” before with an S8+ cover that kept increasing the volume. It worked fine. Loads of configurable options.

Ed

1 Like
#6

I have this problem with xDrip+ version 14fecb8-2019.01.10 on Android, but I only have it with the “missed reading” alert.

While the per-alert options don’t allow for separate volumes, only different system/custom sounds, there is overall alert volume control in “Alerts and Notifications/Glucose Alerts Settings/Alert Volume Profile”. I have this set to “Ascending Volume” but it allows for silent, vibrate only, medium and high as well. I assume this means that xDrip+ manages to override the Android “media” volume setting and there is no “use current volume” option!

Nevertheless the missed reading alert seems to completely ignore all the “Glucose Alerts Settings”; it isn’t cancelled by volume button presses, it can’t be snoozed and it is only silenced by down-swiping from the top of the screen. Apparently the programmers regard the latter as “snoozing” the alarm, but the snooze time is set by a menu twenty bazillion levels deep unlike the regular alarm snooze level where the snooze time can be set from the menu option to snooze the alert. This is still one level of menu deeper than I want but I have managed to learn to access it quickly.

John Bowler