FUDiabetes

Sony Smart Watch 3 and iPhone in Tandem (simultaneous connection)

cgm
dexcom
smartwatch

#21

@Tim07NOV18. Back to basics.

  1. Does your watch have a connection to your phone with Android Wear?

  2. Did you enable the watch in xDrip+? (settings>>smart watch integration)

  3. Are you getting readings on the phone but not in the watch?

  4. Is Bluetooth,location, Wi-Fi, and Always On enabled on watch? It won’t work if these are not enabled.

Let me know


#22

hi @docslotnick,

In answer to 1.
Yep, i downloaded Wear OS and notifications, music control, etc. all show up on the watch. I trialled it with the official dexcom app. Once the dexcom app was installed the G5 watch face appeared on the watch. I have since removed the dexcom app to prevent it interfering with xdrip+.

In answer to 2.
I’ve enabled android wear integration. Played around with enable wear and force wear collection. Tried resync of apps in the Wear OS application. Tried tapping ‘resent glucose to watch’ (nothing appears to happen). Tried tapping ‘open settings on wear’ (nothing appears to happen).

I’ve seen some people mention that xDrip prefs appears somewhere on the watch, I haven’t been able to locate it and I’ve dug through every setting i can. Even tried tapping the build number 7 times to enter developer mode on the watch and still find nothing.

In answer to 3.
Yes I am getting readings on the phone but not on the watch. The xDrip+ watch face doesn’t show up on the watch at any point unfortunately.

In answer to 4.
Bluetooth does appear to be on and working on both the phone and watch.
Under xDrip+ application and Android Wear application in settings I have all the permissions allowed including location.
Always-on screen on the watch is enabled.
I changed the wifi setting from automatic to always on, it won’t shut itself off to conserve battery power anymore. The time out for that though was several hours.

Again just to reiterate, I REALLY appreciate all your patience and assistance with this!


#23

sorry and lastly under
-SYSTEM STATUS
-Watch Service State: not running.


#24

@Tim07NOV18 Do this:

On phone in xDrip+, go to settings>> smart watch features>>Android wear integration>>Android wear integration slider to “on”, enable wear collection checked, force wear collection checked,only use wear checked, sync wear logs checked, show treatments checked. All other settings in this section uncheck.

Wait about 10 minutes and check your watch, set the xDrip+ watchface, and see if you have readings. If not, check system status on phone and G5/G6 status tab should show phone state not running and watch service state: got data xx:xx, and watch got glucose x minutes ago.

If you don’t get a watchface, or you don’t have the watch app called xDrip prefs, and you don’t have a time in the status on the phone, your problem is the Android Wear to watch connection. Try the steps above and if you still don’t have the watch working we’ll look at Android Wear next.


#25

Can you upload to tidepool from xdrip when using android?


#26

I tried all the settings you mentioned, no matter what i try there is just never an xdrip+ watch face or application. Ive been trying all week playing around with the smart watch setting features in the app and nothing can make the xdrip+ prefs app or watch face appear on the sony smart watch 3.

from what you’re saying the problem must be with android wear. which is odd because if i download the offical dexcom g5 mobile app their watch face appears almost instantly. so android wear functionality with other applications does appear to be working


#27

@jim26 Yes! Tidepool upload is the newest feature of xDrip+, which is all done on an Android phone!


#28

@Tim07NOV18 Did you inadvertently check or uncheck something in the Android Wear app? There has to be some weird reason why all the other apps and not xDrip+ show up on the watch.

Perhaps you can reboot the watch and see if xDrip+ appears. Or better yet, disconnect the watch from Android Wear (the option is in the wear three dot menu) and then reconnect it to the phone.


#29

I’ve had a look and if i have im not sure what i’ve done wrong? I went through the permissions on the watch face and enabled every single permission that i can.

I did try that as well. I deleted the xdrip+ app. unpaired the watch. then repaired the watch without xdrip+ installed. then installed xdrip+ with the watch already paired to the phone hoping it would rekindle the connection but unfortunately it didn’t


#30

it just seems weird that all other functions of the watch to appear to be working. the only other issue i can imagine is that from what ive read my watch build is different to yours. i believe your build number under the watch settings is SWR50 however mine incorporates a December 1 2016 google security patch apparently so my build is M1D64T however i don’t know how to revert a build backwards?


#31

@Tim07NOV18 In Android Wear , did you try to resync all apps? It’s in advanced settings in the wear app.


#32

just seems so weird how easily other people appear to get this to function and yet ive tried everything and can’t even get the app/watch face to appear let alone get readings, let alone have it work as a stand alone collector. completely baffled haha


#33

yeh ive tried that several times now, left it over night last night thinking maybe the app just takes a long time to transfer but woke up this morning and it still isn’t there. i read to not press resync to often as it takes a while to transfer to avoid completely killing the battery so i ensured i gave it a couple hour window between toggles of the resync button


#34

hmm. When I look in Settings-Data Sync-Cloud Upload, I don’t see that as an option. Am I missing something?


#35

@Tim07NOV18 That may be a problem. Unfortunately I don’t know how to reflash a watch, but I’m sure you can Google it. I’m sure there must be original SWR50 software somewhere on the internet.

If the resync doesn’t do it, that may be your only option. Sorry.


#36

@jim26 Yes, you have to install the latest nightly update. It’s officially a beta version but don’t worry, it works perfectly.

https://github.com/NightscoutFoundation/xDrip/releases


#37

Cool. That worked. Time to play😆

A little frustrating that you need to download the Tidepool Uploader to view your data in Tidepool. So I won’t be abe able to use my chromebook.

Thanks Doc!


#38

Wait…It has to be something else. The build on my watch is M1D64T with a December 1, 2016 security patch. So it’s not the watch firmware. It has to be something else.

Can I suggest something radical? Hard reset your phone, then start over again. One step at a time. Know the results of a particular setting before changing it.

I’m sure this is a case of a mis-setting somewhere, because it isn’t normal that only xDrip+ doesn’t show up on the phone.

Also, I remember when I transferred from a Note4 to a Note8 phone xDrip+ was the last app to load from wear, and it took almost an hour for it to show up. But it eventually got there.


#39

@jim26 Of course there’s a caveat. It uploads to int-app.tidepool.org not to your existing data on tidepool.org

This is just an interim measure that will be “fixed” soon.


#40

yeh i recall you mentioning it takes a significant amount of time to transfer which is why i left it over night, unfortunately even with 8hrs to spare it didn’t transfer. Im just baffled as to why the xdrip+ app works on the phone, readings and all. Just can’t transfer the app and its data/readings to the watch…yet the dexcom g5 mobile app can?