Omnipod 5 PDM trouble connecting to glooko

Has anyone had trouble getting their Omnipod 5 PDM connecting to glooko? I should explain, the back story is, my first PDM malfunctioned. Omnipod customer service overnighted me a new one. I got it all set up and registered with Podder Central. I have been having a problem getting the new PDM connected to glooko. I contacted Omnipod 5 customer support. They directed me to glooko support. I contacted glooko. They sent an email to Omnipod 5 customer support. Omnipod 5 costumer support emailed me and told me I have to connect the PDM with glooko. As I said my son in law and I tried everything the PDM will not connect. I do plan to keep calling Omnipod 5 customer support to get this resolved or I will drop Omnipod 5. Can anyone who had a similar if not the same problem help me? My last resort is to contact my son who is a coder and cyber security specialist to see if he can get it connected this weekend. I do hope this post makes sense as I am very frustrated at this point.

This may be a stupid question, but can you log into glooko with the computer you set up your account on?

Did you have to enter new id for the replacement pdm?

yes I used my laptop for the new PDM. This has been an ongoing problem for a few weeks. Last week the Omnipod 5 rep who signed me up tried to fix the problem. I thought it solved. I logged onto glooko and the data stops at August 13th. That’s when the new PDM was overnighted to me. I’m going to keep working with Omnipod 5 customer service. I wondered if anyone else had this problem and how they solved it.

Yes I did that too with the old PDM that malfunctioned. They overnighted me the new PDM. I registered that one with Podder too. I was going back and fourth with Podder Cental and glooko all day. Even the Omnipod 5 rep tried to fix the problem when I was in the Endocrinologist’s office last week. I went in both glooko and Podder the data stops with the old PDM on August 13th. I was trying to get Omnipod customer service to remove the old PDM. My thoughts are maybe glooko is still trying to communicate with the broken PDM. I still think that might be the case. I’m going to keep trying to resolve this. I wish there was a setting on Podder Cental where I can remove the old PDM.

1 Like

No I used the same ID. I did what they told me to do when the new PDM came.