OmniPod 5 Disaster

Been a type 1 diabetic since I was 13, 56 now. Just switched from Tandem TSlim with CIQ to Omnipod 5 (I hate tubed systems).

First week went perfectly. Great blood sugar numbers. Overnight was perfect, I slept like a baby.

Saturday evening around 9 pm, had my Pod expire, went to replace it and got “communication failure” during new Pod activation. After retrying several times I was advised to replace the Pod. Same issues. Went through 3 Pods. Called into the support line and waited on hold for over 3 hours, all the while I am getting no insulin as I have no active Pod. Blood sugar is climbing. So I gave up on them and left a voicemail, the message says they will get back to you within 48 hours! What the hell?

Gave myself some Novolog via syringe to try to keep things under control. Called back at 430AM. After 15 min. wait, someone answered. Was advised to delete the App on my Samsung S20 (approved for both Dexcom G6 and OmniPod 5) and then reinstall. set up again and I am working… until today.

All of the sudden I see the App on the phone telling me I have a communication error with the Pod. I give it 30 mins. Still nothing. Time to get lunch at work, guess what can’t bolus as it can’t see the Pod. So I ditch yet another pod after this one only lasted like 30 hours.

I decide to switch back to the PDM in case the phone or app on the phone is the issue. Pod activiates, but now it can no longer see the CGM transmitter so no Auto mode is available. Check the transmitter and its working fine on the Dexcom app on my phone, transmitter not an issue.

So now I am once again waiting on hold, as we speak for 2 hours and 36 mins.

What am I doing wrong, or is this system just a dud. I was so excited to get on this and now I am feeling let down.

1 Like

Yikes this sounds terrible. No advice, but I’m sorry you’re dealing with this. I am going to follow this thread, as I’m on the Tandem, but hate the tube and want to try the Omnipod 5 if it ever comes available in Canada…

1 Like

This is one of the most likely problems with the change from a bespoke PDM with the Dash to using an app with the O5. It was a good idea to switch back to the (O5) PDM, but:

Eh? I thought there was no problem using the PDM with a G6 transmitter regardless of how the transmitter is activated, @John58 might have input.

The issue with the S20 is almost certainly a Samsung issue. I use Dash pods and activate them from a Samsung S10, I chose the S10 because the O5 supports it but was then unable to get O5. Dash pod activation on the S10 frequently fails because of communication failures. Fortunately if I retry enough times it, so far, as ended up working; normally twice per activation at the two steps where the controller waits for the pod.

Both 'phone manufacturers aggressively disable the bluetooth/wifi radio because it takes so much energy; it increases the battery life of their 'phones enormously. Different versions of both operating systems change the rules for an app to stop the radio being deactivated, to the point of actually preventing an app doing it. Insulet test on specific hardware with specific software, as do Dexcom, so if you “upgrade” your operating system you can seriously downgrade your life. Often you don’t get any choice about upgrades; it takes a lot of work to prevent upgrades and the manufacturers change the exact work required with each upgrade.

So that’s no help, but I don’t think there is any help. In the past specific “magic” settings have been discussed and recommended but the rules change with every new day.

You certainly aren’t doing anything wrong. For people like me, who chose to use other systems, it’s all my fault but the point about the O5, the only point, is that if it doesn’t work it is Insulet’s fault. They have a hard task ahead of them, I wish them well because I may end up having to use their system, or abandoning the closed loop completely.

3 Likes

Just as an update to any concerned, after a wait of 3 hours and 45 mins, got my call answered. Basically support is just as confused as I am to the cause of this. They offered to replace the PDM which they will over night to me in the morning, and to refer this to tier 2.

2 Likes

I thought someone here mentioned that you have to quit the Omnipod app on your phone when changing pods via the PDM, or the PDM won’t connect to the Dexcom (or something like that). Did you do that? There are only like 5 OM5 threads here, so it shouldn’t be hard to find.

1 Like

Yes I did see that on another post, however, to test that when I was on with support, we powered off the phone and attempted to pair the transmitter and it still failed.

Also, when I was trained on the system, this was never mentioned to me as being required. But who knows. It does seem like a lot of the support is done kind of “ad libbed” or by flying by the seat of their pants.

1 Like

i thought the omnipod5 paired with the phone app or the pdm, switching means you need to switch pods…also it sounds like your phone may have received an update to Android 12…maybe check settings, about, software information to check the version… everyone i spoke to at insulet warned me the phone apps only worked with certain android 11 phones, unless the software was fixed since may2022…most users seem to be stuck with the pdm for now unfortunately

1 Like

The Omnipod itself, the pod, connects to the G6 transmitter. So if the PDM or the app can see the pod and not the G6 (which they see via the pod) the pod is not connected to the G6.

What’s happening here is almost certainly nothing to do with anything suggested:

@Deanernet, it sounds like the PDM has managed to lose the Dexcom G6 transmitter ID or maybe it got changed accidentally. Check the ID on the O5 PDM; check it against the ID in the Dexcom app on the 'phone because you know that one is correct. G6 app/SETTINGS[cog wheel top right]/Transmitter entry. The ID is the six numbers/capital letters immediately below “Transmitter” (you may need a magnifying glass to read them).

There is an issue with “ownership” of the transmitter but this only happens if the Dexcom G6 receiver (the big bulky plastic thing) has the transmitter ID. For safety never switch the D6 receiver on. Even if it is switched on it won’t be a problem unless it has been given the same transmitter ID; in that case there is no choice but to switch it off (complete power off) and wait several hours (well, we don’t know the time required yet…) Insulet may have more precise advice if that happened; it may even be necessary to change the transmitter, but the consensus is that this is not required.

Otherwise if the IDs are the same then there is a communication problem between the Omnipod pod itself and the G6 transmitter. This may be a result of a different site with poor line-of-sight between the pod and the transmitter. The more of our bodies it has to go through the less reliable the communication. The pod has to be on the same side of our body as the transmitter so that the two can communicate via reflections off a single external surface, otherwise communication relies on winning at photon pinball.

Communication problems should resolve themselves in Dexcom’s “20 minutes” but it probably helps to be in a smaller room with reflective walls. 20 minutes spent preparing food in a normal size kitchen would probably do it.

Some other things may harm the communication. Wifi shielding tricks (copper cloth etc) are almost certain to cause problems (Wifi and bluetooth are identical radio waves). It may be that if you have problems with the O5 app communication to the pod it’s simply a general communication problem in the environment, but it’s more likely to be just the pod placement in a non-ideal location.

1 Like

I recently started on the OmniPod 5 and fairly early on encountered an “Unable to communicate with your Pod” message in the app (running on a Samsung S20+) . I put the phone right next to the pod and hit CHECK STATUS over and over with no luck. I was just about to change the pod when the voice of the front line tech support rep in my head said “Did you try rebooting your computer?” I restarted the phone and everything was magically working again. My guess is some hiccup in the bluetooth lost the connection and it wasn’t reestablished in the background. But when the phone starts I think it tries to reestablish connections with devices it is paired with.
Anyhow, not claiming it’s a cure-all, but it is definitely worth trying before you assume the problem is with the pod.

3 Likes

Many thanks for the detailed explanation of how this system is “supposed” to work. This is exactly what I was hoping to learn. No one at support mentioned any of this.

I believe it is an issue with the Pod itself because of your explanation.

The Pod and the transmitter and sitting literally right next to each other. .The Serial number for the transmitter is correct and has been verified multiple times, deleted, reentered etc.

Transmitter itself has to be working because it is displaying on the Dexcom App on the phone.

The Dexcom receiver is not being used and was never set up.

It seems to me that the Pod is either not receiving the SN for the transmitter, or simply not able to communicate with it.

It is disappointing to get support members at Omnipod who are not really knowledgeable about the product (in the same way you are to be honest) and are simply reading from sort of call flow and asking questions. I am familiar with that process as I work for a large telecom company and have the same type of call “wizard” that is supposed to guide you through troubleshooting. That’s fine, I get that, but one has to know what is going on behind the scenes to interpret the answer to the questions you are asking.

As they are sending a new PDM and new Pod’s, I will set up everything again once that all arrives and reassess from there.

Thanks to all for the responses.

2 Likes

Be aware that i had this earlier after I started OP5 and a reboot of the phone fixed my issue as well, however, the following week is when I had my disaster. Maybe it doesn’t like the S20? I don’t know.

Maybe it doesn’t like the S20?

Wow–I hope not. I actually bought the S20 because I didn’t want to have to lug around another device and at the time the S20 was the most recent phone on the device compatibility list. Since it was two generations out of production, I had to get a refurbished model–returned two before I got one that worked just as a phone. I’m glad to see that they recently added the S21 to the supported models, but would be nice if they could actually get through the certification of a phone while it is still in production.

I agree 100 percent. As a “tech guy” I have always tried to have the latest phones. I had to downgrade from a Pixel 6 to the Samsung S20 as well. I had to buy a “New Old Stock” one from Ebay. Its a nice phone, but I agree, it would be nice to be able to use newer equipment.

Dude - i have been walking your riad of frustration for the past 24 hours and your post put my pain to rest.

Yesteday was my first day on the Omnipod5. My first day on a pump period…and the pod communication popped up just before my first dinnet.

I am also using a Samsung 20+.

I tried to change the pod today but got same error.

I should have known being a tech guy myself, when in doubt turn it off and turn it back on.

Rebooted my Samsung S20+ and, bingo, bravo, praise the Type 1 Gods, the damn thing worked.

So. Everyonr using a Samsung, listen up!

When in doubt, turn it off and turn it back on again!

2 Likes

It’s a little of a lost game to try to guess what is going wrong, nevertheless the apps use a lot of battery so they may get hard backgrounded as a result. A reboot will “fix” that until next time the 'phone decides it needs to eliminate the battery guzzlers.

The O5 app is particularly challenged; it has to wake up every 5 minutes to get the latest, greatest, glucose values but it also has to be woken up by the pod, so it has to listen all the time (unlike the G6 app). In the app permissions “battery” should be set to “unrestricted”. I assume the app does that, but maybe not; maybe it can’t. It is worth checking. The default is “optimized” which should be fine since we use the app continuously but for apps controlling my insulin I don’t trust Samsung.

Hi, new here. 40s T1 and have a 6yr old T1 who was prescribed O5 and is on G6. Been following this thread and it sounds like there are multiple communication issues; the first is O5 with G6 which then communicates to the PDM if it has a reading from the G6 and the other is if not using the PDM there are other communication issues with the phone (assuming it’s compatible) am I following this correctly?
So my question here is, do we think this is a software issue or hardware? What will Omni have to do to resolve this? Ty!

Just an update. I have had zero issues since switching back to the stand alone controller. I basicly said to myself. I am setting the whole phone app thing aside until it is debugged.

As a matter of fact i received an email from Omnipod today stating that they are aware of communication issues with S20 and S21 phones and are working on a solution.

@jbowler maybe you can help me understand the issues better. Thanks in advance