Miaomiao with glimp - no readings

Recently received miaomiao. Installed Glimp, followed setup procedure. Activated bluetooth, and phone found the M. occasionally it flashes a box with the mac address in it, but no data. periodically I get the alarm "CGM data not received for more than 28800 seconds.
I also tried uninstalling Glimp and loading XDrip+. It also gave me errors but no data.

It would appear the M has a problem. Any experience with Chinese support?


1 Like


I’ve never contacted Miao Miao support, although I have frequented the Facebook group when I’ve had questions.

The first thing: are you in the US, and if so, are you using the 10-day sensors? If you’re using the 14-day US sensors (14 day sensors from outside the US are different) then unfortunately the Miao Miao can’t read data from them because it’s been encrypted


That’s unfortunate. Recently someone on a different forum had issues with Miaomiao and Glimp, but xDrip+ solved the problem

Really!!! Yes - 14-day US sensor. So the Miao Miao is useless!
I’ll be interested is what support has to say. No reply in 8 hours!
That might explain why XDrip+ gave a log entry that is had received 343(?) bytes but checksum was bad!
I would hate to go to the 10-day sensor, but the idea of alarms and no manual entries sure is is quite a plus!

Do you know if the BlueCon works with 14-day sensors?

I don’t think anyone has cracked the 14-day sensors yet, so I believe the answer is no

1 Like

Unfortunately none of the 3rd party gadgets work with the US 14 day sensors now, though people are working on trying to crack the code.

If you can get 10 day sensors I would recommend it, you end up getting a full 14 days out of them when using the Miao Miao