FUDiabetes

Libre 2 xDrip+ - patching the app

I’m not sure if this has been posted about before, but I am trying to get xDrip+ to work directly with a Libre 2 sensor so that no MiaoMiao is needed. I have read that the LibreLink app needs to be patched. I found instructions here: GitHub - TinoKossmann/LibreLink-xDrip-Patch: Patch für LibreLink, um per vom Libre 2 empfangene Bluetooth-Daten an xDrip weitergeben zu können. but I am struggling with the “patching” step. I am using MacOS and the Terminal command line interface to attempt this, but unfortunately my knowledge of command line interfaces is limited to the last time I used MS-DOS 6.22! Does anyone know how to make this work, or have a patched apk they would be willing to share? Please let me know, thank you!

2 Likes

I’m not familiar with Libre 2 but am curious moving forward for additional hardware options. What error does the patch command give? I take it you are in the correct directory, have a fairly recent version of Mac OS, and that the xdrip2.patch file is where it needs to be. Have you tried man patch from the terminal to see what the documentation looks like?

I’m in the right directory, far as I can tell, but it just says it can’t find the file or something when I copy and paste the patch command from that website. I’m not really sure what’s going on, I’m not very familiar with Terminal commands or developer stuff (though good to know cd is how you change dirrctiory, just like in DOS, except the slashes are forward and there are no drive letters).

Same here, I just use it as necessary, in case it wasn’t obvious, I think the …/xdrip2.patch (i typed two periods before the / but it came out as 3) means that the xdrip2.patch file needs to be in the folder above in the folder hierarchy like if you type pwd and are in /vegetables/green/brocoli, then the file would need to be in /vegetables/green

I tried that, it says "unrecognized option ‘–merge’

Sorry for delayed response. Last few days have been very busy. I’m guessing from that error that there’s a mistyping somewhere (or perhaps the instructions are wrong) in the command issue because merge is a key part of what the patch command does, it takes the code and updates it, can you copy and paste the command issued and the response error? Sorry if I’m being slow and pedantic but I am curious about this command line feature and libre 2, looking at the xdrip2.patch file it has minus signs for what it gets rid of and plus signs for what it adds.

I’ll try a more basic version of using the patch command just to see whether it works as expected on my computer.

Also, the command line is very picky with ordering, dashes, and spaces