FUDiabetes

Jelly phone, Xdrip and nightscout


#1

Hi there,
I have two issues if anyone can help.
Set up is dexcom g4 no reciver, Xdrip, wixel and nightscout.
Just purchased a jelly phone, have set up xdrip but it seems to loose connection every few minutes. I can view bg in jelly phone BUT cannot get the connection as follower to nightscout. Working on old phone just not with jelly phone??

Thank you in advance for your help.


#2

@Laura1 Do you mean that the Jelly phone won’t upload to NS? What is your setup? And the phone and receiver just needs a connection every five minutes.


#3

Yes, I have an Xdrip bridge ( wixel)


#4

On the older phone, Xdrip would show bg all of the time, but on the jelly phone it keeps looking the Bluetooth connection, maybe not compatible with the set up I have?? I’m not technically minded, as you can tell!


#5

@Laura1 OK. On the Jelly phone go into Settings>>data sources. Make sure you check xBridge wixel. On the Jelly phone go to settings>>apps>>permissions (or where you can give apps specific permissions). Enable the location permission for xDrip+. This should get you readings on the Jelly.

Next, go to settings>>Cloud Upload and use the NS rest API. Fill in all of you’re NS credentials and don’t forget the extra options. Now you should be able to upload to NS.

Let me know how it goes


#6

Thanks for your help. Xdrip can be viewed on jelly phone. Cannot still see bg on nighscout. What I can’t understand is when Xdrip is on old phone, I can view bg on Xdrip and nightscout, no problem but cannot view when Xdrip is being used with jelly phone ? I’m missing something!


#7

@That is a problem with internet connectivity with your phone. You have to give xDrip+ the proper permissions on the Jelly phone so that internet upload is allowed. I don’t know enough about Jelly phones to tell you where to find this setting, just that a lot of communication and connectivity settings on the Jelly are proprietary.

Good luck! Let me know if you’ve solved the problem.


#8

@Laura1 Found this on a Jelly thread on another forum, maybe it will help:

Not sure if this is just the Jelly Pro, but there is a strange setting under: “Settings” > “Smart Assistant” (heading) > “Network Access Control”. Open this, then:

Under “Mobile Network” or “WLAN” headings, there is a statement:

“All apps will not be able to connect to the Mobile network/WLAN after closing this switch” – This statement is COMPLETE RUBBISH – they need to be switched ON using “Open All” (or as required, of course!)

As an Electronics Engineer, I know that a “Closed” switch is effectively “ON”. So “Closing this switch” should actually turn them ON!