FUDiabetes

Getting started with G6 & xdrip


#21

Yes, that should be fine. Was Android Wear connected?
The communication protocol is the same with G5 and G6. You just have to check “I am using G6” on the phone.
So G5 is ok on the watch.


#22

Yes, I had connected Android Wear. I can’t find “I am using G6” on the phone.

Here are some screenshots of the settings I have on the phone right now.

Wondering if I should just start over. Sigh…


#23

My hubby is questioning having the “force wear” setting checked on both the phone and the watch. He thinks it should just be on the watch.


#24

Ah ha! Found the “using G6” checkbox. It was already checked.


#25

If uncheck everything on the Wear integration screen, I get data my phone. When I check those things, I no longer get data on my phone. The watch continues to display data either way.


#26

No, this isn’t true. The watch stopped getting data when I did this.


#27

Daughter left for rafting trip. I hope the watch is working. She brought the Dex receiver just in case. When she gets home I’m going to just start over.


#28

When you uncheck “force wear” and you get data on your phone and watch, the phone is acting as the collector and the watch is a display device. If your daughter is not within Bluetooth range of your phone ( like when she’s at school) there will be no data. So if you want the watch to be the collector (receiver) you must check force wear.

You are obviously having a problem with the watch. Put the phone down and concentrate on the watch. Make sure on the watch settings you have Bluetooth on, WiFi on, location on. In xDrip preps check enable collector, force collector, refresh on change, low color. You can also show date, steps, have opaque cards, enable alerts, shoe treatments, show status (watch battery %) if you wish. Under “xDrip G5 settings check " Auth G5 \read”. These are the settings I have on my watch.

Also, it’s best to make sure you have the latest nightly release on your phone. In your phone go to:

https://jamorham.github.io/#xdrip-plus

Click on “nightly updates” and download and install the latest one, August 5 I think. All of your settings will be preserved when you upgrade, so don’t worry.

It’s great that you have gotten it to work so far. We just have to get the last little setting.


#29

Ok, that’s what I thought. So at this point the watch is working splendidly. I’m just not seeing data on the phone. I’ll recheck the settings on the watch and let you know how it goes.
Thanks for your patience!


#30

Wait, I thought you meant the phone was working but the watch was not working. Is that correct?


#31

Just noticed something. On your phone go to settings>less common settings>other misc options>check " run collector in foreground".

Android may be intermittently killing the app as part of its normal maintenance.


#32

Here are my settings:

And from System Status:


#33

No, the watch has been working the whole time, but I’m not getting data on the phone unless I uncheck the Force Wear on the phone and make it the collector.

I’ll try that.

Thank you for sharing your settings. Ill go through and compare to mine.


#34

Well, something is happening. I just went through your screen shots and duplicated your settings and I started getting readings on the phone. It asked me to enter 2 calibration numbers, so I just put in what the watch was showing (151). Now both the watch and the phone are showing “LOW” and the Dex receiver is showing 165.


#35

My System Status screen is very different from yours.


#36

First, swipe left and you’ll notice four different system status screens.

Wait for a few minutes and add a calibration from a finger stick. XDrip will come around. It’s sometimes screwy for the first few readings.

Glad you got the watch and the phone working!


#37

Yay!!! It’s working!!!

I will now write this on the board 100 times:

“I will not mess with the xdrip+ settings.”
“I will not mess with the xdrip+ settings.”
“I will not mess with the xdrip+ settings.”
“I will not mess with the xdrip+ settings.”

Thank you so much for continuing to help me.


#38

Fabulous! Don’t be scared to play with settings. There is so much you can find in there you will be amazed. I seem to be finding all sorts of things, even after 1 1/2 years.

And don’t worry about screwing things up. Help is always available!


#39

Well, at least I’ll make a note anything I do try!

At some point I’ll want to learn how to use the share capability. It’s not urgent since she doesn’t have a smart phone. She just has a button/flip phone. All of this has been on my phone and her watch. When she goes out, she has the watch and when she comes back, the data backfills on her receiver (and hopefully now my phone). Eventually we may get her a smartphone or let her borrow mine so we can use follow in certain situations. Hubby is interested in the parakeet, but don’t know if we’ll go that way.


#40

@sahmcolorado You might want to look into the Jelly phone. It’s not that much bigger than the watch and makes a great xDrip+ phone. I really think that’s the best solution for a child at school just to keep in her pocket.