Double calibration xDrip+ on Android Samsung S7 Edge

First post… I can’t figure out how to do the double calibration using xDrip+. I am using a Dexcom G5 sensor. (I also have the Dexcom receiver.) I have a Samsung S7 Edge Android phone. I have a notification on my phone that says, "Sensor should be ready. Please enter two calibrations. I click on the eyedropper icon and enter my BG level and click the check mark. I repeat this and nothing happens. The graph is displayed. There an “X” showing the BG calibration I entered but there are no BG readings. The app is not recognizing I entered the BG calibration. Any ideas on what step(s) I’m missing?

1 Like

Hi @jonathanarms. Welcome to our forum!

When xDrip+ is ready for the double calibration you can go to the drop down menu (hamburger lines on upper left of screen) and one of the choices will be “add double calibration”. Tap that and it will take you to the double calibration entry screen. Put in your calibrations sms you should be good to go.

Let me know if you have any further problems with getting it going. I’ll be glad to help you out

1 Like

Welcome, @jonathanarms!

Were you using the Dexcom app on iOS before?

You may want to introduce yourself on the intro thread, so that people get to know you: Welcome, introduce yourself here!

There is no “add double calibration” option. The options in the menu bar are:

  • Home screen
  • Stop sensor
  • System status
  • Note search
  • Settings

The xDrip version is dc550b1-2017.07.03
Code: 1707032102

Hi Michael,

I am currently using the Dexcom Mobile app on my Samsung S7 along with my Dexcom receiver as a supplement. I’m trying to get off the Dexcom Mobile app because the alarm is really annoying and there is no way to disable or quiet the “urgent low alert”.

1 Like

Perhaps an obvious question but how often are you getting the “Urgent Low Alert” which alarms at 55 ?

Not that often. I’ve had diabetes for over 35 years under good control and without incident. The Dexcom Mobile app alarm is quite nice with one big exception - the alarm. Sometimes the Dexcom is not accurate and my BG isn’t actually low. The sound is like a five alarm fire. And it goes off every five minutes. There is no way to turn it to vibrate or quiet it. It almost makes the app unusable. There are a lot of comments flying around the internet on this topic. I’m not alone. I actually read a suggestion on one of the boards to use the xDrip because it allows greater control over the alarms, among other things.


@jonathanarms Ok. Then you might want to hit “stop sensor”. That will pop up a choice, to either stop the sensor and replace it (which you don’t want to do right now), or to erase all calibrations and start over. Choose to erase all calibrations and you will be taken to the double calibration screen where you can add your two calibrations.

1 Like

You are right, it’s a common issue :frowning: Too bad. I suspect it’s due to the FDA process.

On our Dexcom G5 Mobile app (v 1.7.2 on the iOS), the repeat interval for the Critical Low alert is 30 minutes. There are also a selection of sounds that can be used for the Alarm.

I followed the steps but it still is not letting me calibrate. I erased all of my calibrations. (The calibrations are still displayed on the graph, however.) There is a message displayed saying, “Sensor should be ready. Please enter 2 calibrations to get started.” When I open xDrip+ at the top of the graph in red it says, “Please wait, need 2 readings from transmitter”

@jonathanarms Just be aware that you cannot use the Dexcom app nor the receiver while you are using xDrip+. You must stop the sensor with the Dexcom app and the receiver before trying to start it with xDrip+ or you will never get a reading from xDrip+.

1 Like

Got it. OK, I’ll stop the sensor and delete the Mobile app and try it again.

Did you stop the sensor with the Dexcom app and the receiver?
Also, in the menu under settings you will find the G5 Debug settings. Make sure you check the box to “reauthenticate before each reading”

1 Like

@jonathanarms Oh, and also turn on location in your phone. I think the S7 still has Bluetooth ties to location.

Edit: Also, when you stop the sensor from the receiver, make sure you plug the receiver in so it’s battery doesn’t completely deplete. Otherwise it will not work if you want to use it again.

1 Like

Just stopped the Dexcom receiver and deleted the Mobile app. I will also plug it in if I decide to revert back to the Dexcom receiver. (I’ll plug it in.) It’s too bad that the Dexcom receiver can’t work in conjunction with xDrip. I really like having a backup device. Oh well.


@jonathanarms One of the nice things you can do with xDrip+ is have followers. You can install the app on another device and copy all the settings from your phone, set the other device as the sync follower and your S7 as the sync master, and then all of your readings will stay in sync with the follower.

This is how my wife keeps an eye on me throughout the day. She can see exactly what I see on my end.


Thanks for the info. I’ll let you know if I can get xDrip to work.


It works. You correctly diagnosed the problem - can’t use the receiver the Mobile app. Thanks for your help.


Hurray! Congrats to you, @jonathan, for making it work, and to you, @docslotnick, for the expert technical expertise!

@jonathan, many of us are intrigued by moving to xdrip+ from the Dexcom iOS app. It would be great if you were to keep a thread going describing your thoughts, experiments and results with it (including getting it to work for the first time)!