FUDiabetes

Apple Watch only showing lines for BG reading

So just got my Apple Watch SE today. Setup the Dexcom face and for a minute it showed my BG in the Home Screen. Now it only shows ——— but if I click on it to open the actual app it shows the BG fine. Ideas? Never had an Apple Watch before.

2 Likes

In the Watch App, select your Watch Face (I use the Utility face) and make sure you specify where the Dex app reading will display (not all positions are available). For the Utility face, it displays on the bottom. Hope that helps!

1 Like

Yeah I did that and it shows it for awhile and then it goes to showing ——- instead of the BG. if I switch faces back and forth then it shows up again.

1 Like

Have you tried the DIY Loop watch app? You can add it as a complication on your watch also. I use both and often find one will update the BG while the other lags. I only get the — when the complication has not been updated recently. Opening the app will refresh the BG.

1 Like

Did you recently upgrade to the G6, by any chance? That messed up my Watch display. I ended up turning off Blutooth for a minute then restarting, then turning the phone off for a minute.

1 Like

No I haven’t heard of that, let me check it out. Thanks.

I upgraded to the G6 couple weeks ago before I got the watch then I went back to the G5 to use up my sensors and cause the G6 kept losing connection so it pissed me off. :slight_smile:

Now I have both apps on my phone but only the G5 on my Apple Watch.

Where do i find it? Haven’t found it yet.

I thought you were on DIY Loop? If not, then maybe ignore my comment! Sorry. If you are, then you build it as part of the XCode workspace project along with the Loop app. Then install the watch app via the phone watch app, then add the complication.

Ah sorry no, I’m getting my Tandem soon. I just went back on my old Minimed 511 which is great! Can’t imagine how awesome the Tandem will be compared to my old Minimed.

Convenience and the ability to set a higher basal during the daytime are keys for me. I take Tresiba which is perfect for night time (I take off my pump) but during day it was never enough. If I increased basal then I’d always go low at night. Now it’s perfect! I went from average of 160 to 116 in two days with much less effort.

I love my new Tech.

2 Likes

Wow, that is fantastic! Good luck with the Tandem, too!!

2 Likes

Any of you run “Spike”?

1 Like

The Apple Watch has a very tiny battery so it’s ruthless about updating things as infrequently as possible. There are a few things you can do to allow it to update more often:

From Dexcom’s FAQ:

Place the Dexcom G6 app in the Dock and enable the background app refresh for best performance.

(“The dock” is a software feature of the watch, not the charger)

My totally uniformed guess is that the frequency of updates might slow down if the watch battery is low so the watch can make sure it’s got enough power for its critical functions, so you might want to try avoiding low battery situations when possible. Also, the more expensive Series 6 watch has a bigger battery so that might be a better choice if my uninformed guess is correct.

On the iPhone, Dexcom was able to get some special permissions to crank the volume of the phone way up when your BG is low. I wish they could get special permission to send data more often to the watch even at the risk of severely shortening battery life.

3 Likes

Thanks Ned! So far it’s been doing ok, I added to the dock so will see if it happens again. I love my SE so far.

2 Likes

Your watch and the Dexcom complication are working fine.

Apple has a hard limit on 3rd party complication updates (refreshes): 50 per day

3 Likes