FUDiabetes

Accu-Chek Mobile wireless adapter

Hi all,

I got one of those new Accu-Chek Mobile wireless adaptors the other day, and it all worked fine for about 48 hours, and now just won’t connect to my phone at all. Nor will it pick it up when trying to search for it in Bluetooth or mySugr (it comes with a free premium mySugr membership so transfer the data over).

I’ve called the helpline, but they can’t offer any help beyond the steps below which I have already tried multiple times.

Can anyone suggest anything else to get this working again?

Thanks

•Press and hold the button on adapter for 3 sec – this will reset the adapter (Adapter will show green light for 2 sec or so and turns off, this rest should not turn on the meter).
•Deactivate Mobile pairing on mySugr app – Menu > connections > Accu-Chek Mobile > deactivate.
•Forget device on Smart phone – Smart phone > settings > Bluetooth > Accu-Chek Mobile > click on blue information circle (information logo) Forget device

•Log out of mySugr app (Menu > Profile & settings > User name > logout)
•Turn off your smart phone
•Turn on the smart phone
•Log in to mySugr app
•Go to menu > connections > select Accu-Chek Mobile

•Turn On the adapter – wait for data transfer on the Mobile meter > then click Connect on the mySugr app
•If the device is found, then mySugr app will ask to enter adapter activation code – enter the activation code – the pairing is successful.
•Then perform a glucose test on Mobile meter > then result should then transfer across to mySugr app.

If this does not work, please clear the Bluetooth Cache (Android only)
•Open your Settings and tap on Apps.
•Tap the 3 dots in the upper right-hand corner and choose Show System Apps
•Find Bluetooth and then tap Clear Cache and Delete Data
•Now, restart your phone.

1 Like

@MisterMints, the wireless adapter works through Bluetooth. The most likely issue (almost 100% odds in my opinion) is a Bluetooth issue, which is very common. How comfortable are you with debugging BT issues? And are you using Android or iOS?

I’m on Android, and a fairly competent user, but not sure how to start debugging BT issues.

I have cleared the cache and data for BT so far, but that hasn’t fixed the issue. What other BT debug steps can I try?

Thanks

1 Like

@MisterMints, here is a possible debugging sequence independent of the app:

  • Open Settings -> Bluetooth and check you can see the device. Is it paired?

∆ Can’t see

  • (a) Turn off meter/wait until off. Turn phone off then restart

  • (b) Check again. If still same problem, wait for meter off, swipe down phone for common settings, turn BT OFF, then ON again, turn meter on.

  • © Check again. If still same problem, question adaptor battery or BT transmitter

∆ Can see device but unpaired

  • (d) Try (a) and (b) again

  • (e) Still no go? try manually pairing the meter from your Settings>Connected Devices>Bluetooth

  • (f) Still no go? Go to System>Apps. Open menu, look for system apps. Find Bluetooth, and clear again both cache and data. If you have more than one Bluetooth system app, do each one.

  • (f) Still no go? Forget as many BT devices on BT settings as possible—if possible only leave 1 or 2. For debugging purposes, it would be best to delete everything and try to pair just the meter. (This may already be blanked)

If, at any time, you succeed in pairing, then go back to the app and see if it now works.

Common issues:

  • Device is not turned on
  • Need a phone reset
  • Need to turn BT on
  • Need hand pairing
  • Too many BT devices
  • Screwed up cache or data
  • Old, obsolete Android version

If none of this works, then possibly your phone is too old, or it is a device problem. Ask for another? Hopefully someone will have more ideas that are more Accu Chek specific.

Hey @Michel

Thanks. I have tried all that, but with no luck. I can at least now see the device in the phone’s BT settings, but it needs to be paired from within the “Connections” page in the mySugr app to link up correctly (much like pairing the MiaoMiao from within the Bluetooth Scan menu in xDrip, rather than the phone’s BT settings page)

Phone isn’t too old, its a Samsung Galaxy S9+ so still a flagship, but it could well be a Accu-Chek device issue.

If only they’d put a simple reset button on the side!

1 Like

You are right, the phone should not be a problem.

So, if you stop and start BT, check that you see the device in the phone BT menu, and try pairing it with mySugr it does not pair, even after the cache is cleared, and no other device in the BT list?

Exactly @Michel

mySugr just sits there looking for a connection, but won’t actually connect. As I say, this worked perfectly until last night, when the connection or pairing was lost and since then it will not reconnect.

@MisterMints, through your debugging steps you have established that the BT stack is not guilty. So we need to look further into the app.

  • Since it is possible that the mySugr app keep track of the state of the BT pairing in parallel to the phone–have you, again, unpaired the device through MySugr? If it is already unpaired thru BT and you can’t see in on the app, it means the app is not keeping track of pairing itself (that is good, not bad).

  • the next step would be to uninstall and reinstall mySugr. But—some apps misbehave and lose internal data when you do that. So there is a little risk.

And—forgot to ask, you did reset the device multiple times, between each debug attempt, right?

@Michel

I have held the button on the device for at least 3 seconds between every retry to reset it, but no joy

I can’t unpair the device through mySugr, because it isn’t listed as being a connected device there. It was, but since this problem started, it has disappeared. There is the option to connect though, which would suggest mySugr has cleared the Accu Chek from its memory/paired devices list.

I have also tried the uninstall/reinstall mySugr trick, but again, no luck there.

1 Like

Either that, or it relies on the phone to keep status info, which would be best from a software architecture point of view. Either way, it is good.

Well, @MisterMints—I think the only options left are device problem or app problem:

  • you established that the BT stack is sound
  • you can see the device on your phone, so the device BT works

There are two other debug checks you could do, not to solve the problem, but to rule something else out.

  • Can you pair another type of BT device, use it, then unpair it? If it works, it will definitely rule out the phone.

  • Do you have another Android phone to play with? If so, you could install mySugr on it with your account info and duplicate the sequence. If it fails as well, then the device may be the problem.

I would be inclined to suspect an app bug, though.

@Michel

SOLVED!

Turns out it is due to a crummy implementation of Bluetooth in the latest version of the mySugr app. I’ve downloaded the previous version from a trusted APK hosting site, and now it works flawlessly.

Roche are aware of this, and are flagging it with mySugr to update the app ASAP. Turns out it was v3.55.1 that was released on 28th Jan that caused issues.

2 Likes

@MisterMints, hearty congrats! It is great that you solved it—but, even more, this was not an easy bug to get through: nice sleuthing job!!!

And, btw, welcome to the forum: I hope to see many more of your posts!

1 Like

Let me mention another thing that can interfere with bluetooth pairing. I learned it twice in the past two days and still am annoyed that I didn’t think of it sooner.

TL;DR: there may be some app that you don’t even know is running, that is getting in the way of the bluetooth pairing process. Suspect any installed app that ever knew the bluetooth ID (transmitter ID) that you are trying to access.

First story. My Dex G5 transmitter wouldn’t start a new session on an old sensor because of the suicide timer. So I tried to run the reset app that had worked for me before on this transmitter. Reset tried for a half hour and couldn’t find the transmitter to reset it. I changed the transmitter ID in the Dex app and told it to start a new session, just to flush out any possible lingering attachment. I did the same in the Dexcom receiver. I told the iPhone bluetooth system in settings to forget the old transmitter. I rebooted the phone without restarting any apps except reset. I even rebuilt the reset app in case somehow the iOS upgrades had introduced an incompatibility. No joy. So I changed to a different transmitter, started that one, and the new transmitter was not found. Tried all those mitigations again, and transmitter not found. Then I got the idea to go into the LOOP app, which I had not started, and tell it to forget that I have a CGM. Now the new transmitter was found. Just for chuckles I then tried the reset app on the old transmitter that was sitting in its box. It found the old transmitter it and reset it.

Second story. The very next day the old sensor failed (excessive jitter and dropouts.) So I put in a new sensor and decided to switch back to the restarted old transmitter to use it up. Long story short, the Dex app couldn’t find it, over and over, or more precisely, after a long time it gave the triple beep that means it’s time to say yes to a pairing request, but on unlocking the phone there was no pairing request waiting for me to say yes. I finally thought to tell LOOP to forget that I have a CGM, and then the Dex app was able to get me the pairing request and start working.

First conclusion: it seems to me that a background process for LOOP must be started at boot time even if the LOOP app hasn’t been launched, and it somehow blocks any other app’s attempt to pair with the cgm transmitter. Until you tell LOOP to forget that you ever had a CGM.

Second conclusion: it can take me a remarkably long time to solve a problem. Even if I already solved the same problem the day before.

1 Like