Wear os

I can’t get wear os app to load. I have used it many times before, successfully. Is there another app that can be used to run xdrip and connect to smartwatch. Is anyone else having trouble with loading the wear os app? TIA.

1 Like

If you are referring to the xDrip+ wear app, sometimes the wear app takes a very long time to install to the watch. I’ve heard from some that it was taking several hours! You could use the debugger, adb, to directly install the xDrip+ wear apk onto your watch, and this would take only seconds. HWR, it would entail building the xDrip+ wear apk, installing adb onto your desktop, connecting your watch to you desktop, etc. Maybe more effort than you want to spend.

Refer to this for additional troubleshooting information. Also, this at the same link.


Thank you for reply. I found the answer in someone else’s question, that you answered for them. I got wear os sorted but still couldn’t get it to work. I read your reply to someone with same problem. You told them to use 20.11.26 version of xdrip, it worked for them. I have been trying for weeks to sort this out. I tried what you suggested and IT WORKS. I am absolutely delighted. Thank you, all the way from sunny England.


You are welcome! Glad it worked for you in sunny England!!! :slight_smile:

1 Like