Omnipod Looping

Yes, check what @ClaudnDaye posted above. And, also check the Loop settings in the iPhone Settings-Notifications-Loop, should look like this:

2 Likes

May need to get Apple involved to help troubleshoot.

1 Like

One more suggestion: let Phone be locked and idle for some time (say 15 min) before trying to get a “failed bolus notification” next time. There may be some delay between the time you lock the phone and the time when iOS starts sending notifications to the watch.

2 Likes

Yep, I just verified. They are all the same as yours. Check, check, check, check…

Okay, I will give that a try next. But it will be a little while, because there are times when my phone is busy and the 15 minutes of not touching it can sometimes make the work people mad!
:open_mouth:

But I will try that next!

I just tried this. Same result.

I let my phone sit locked for 20 minutes, and then put the RileyLink out of range and did a bolus from the watch. The phone showed the failed delivery message, but the watch did not.

1 Like

Hmm, I am running out of ideas, which means it’s probably time to try rebooting the phone and the watch, possibly reinstall Loop, … I’ve not seen that issue come up among Loop users. btw, which iPhone/iOS and Watch/WatchOS are you running? Also, have you ever seen any notifications on your watch coming from Loop (such as notifications that Loop has not completed in last 20 minutes, 40 minutes, or such), or from any other non-Apple application?

1 Like

After it failed a few times, I have starting doing restarts for all the subsequent test scenarios, just to rule that out. Basically for all attempts today I have restarted.

I have not seen any messages like that. I can put my RL outside for a while so that I get a “loop hasn’t completed” message.

Actually I have nothing else installed on the watch, except for Loop and the native iPhone apps. I am trying to keep the watch as clean as possible, with nothing on it except Loop!

I did see txt messages and phone calls on the watch. But the only app installed is Loop.

I can install Dexcom on it and see what happens with it.
:man_shrugging:

The iPhone is 5s (yes, I know it is old, but it is smaller than the crazy-big new ones). The iOS is up-to-date, it is 12.4.

The watch is version 5.3 (16U589) and it is model A1858. I did an update before installing Loop, so it should also be up-to-date.

You could just turn the RL switch off. Or, you could just swipe the Loop app out. You should then see a warning notification on the watch in about 20 minutes. If not, that would confirm that something is wrong with the notification system between your phone and your watch.

An update…

I installed the Dexcom app on my watch. My watch correctly notified me of a low BG warning from Dexcom…

I did this tonight when running. I left my RL behind. The watch DID notify me of the fact that Loop had not completed. But it did NOT notify me of a failed bolus attempt.

The phone did notify me immediately of both the failed Loop completion and the failed bolus. But not the watch.

1 Like

Alright, so watch notifications are working fine, except the failed bolus watch notifications. I am unable to reproduce the problem, and I do not have any further ideas, sorry. Maybe open a Loop issue.

Of course, you’ll need to carry the iPhone + RL with you on your runs now.

Check out these posts on phone cases:
https://www.facebook.com/search/top/?q=rileylink%20phone%20case

And this on a wireless charging case (for $89):

2 Likes

Help with Autotune. I know different people have different opinions on the effectiveness and accuracy of the Autotune program. I used to use it to check my own determinations (mostly based on recs here and from the Loop world), but never adjusted based solely on it’s suggestions. My question: How do you use the Nightscout data with the extra security settings enabled with Autotune? Ever sense turning on the extra security settings recommended, Autotune hasn’t functioned. (You can see I haven’t used it for some time.) I’m sure its something straightforward that I’m missing; tried to look it up without success; alternately, I can turn off the security, use it, then add them back. Thanks!

With web autotone, correct? The answer is that you don’t; webautotune won’t accept a NightScout URL with a token. However it fails early on, so I temporarily enabled anonymous login with read-only access (this has to be done in the Heroku app IRC) then removed it when webautotune had downloaded the data.

The OpenAPS documentation of autotune describes ways of running it directly but to get that to work it seems to be necessary to have a complete OpenAPS on a suitable computer. I briefly looked at this while trying to get the web version to work and from my point of view it just wasn’t worth the effort.

It’s a pity that AndroidAPS doesn’t include autotune; that would allow it to be run without using NightScout for an intermediate data dump.

1 Like

Thanks @jbowler ! Guess I’ll just forego it’s use. Too much effort for what I might get out of it… My numbers seem to have settled in pretty well, just need to prebolus better/more often to counter after meal rises.

1 Like

I actually think it is the single most valuable part of the OpenAPS stuff, so I’ll try to document how to get it to work with minimum, and only temporary, loss of security. I always get the name wrong; it is “autotuneweb”.

It is necessary to use NightScout and it is necessary to have all the relevant data - carbs, basal, boluses and BG levels, recorded in NightScout. Using a CGM, including things where the readings have to be manually downloaded like the Abbott Libre, is probably pretty much essential to get enough data.

The first step is to “open” NightScout. Unfortunately this means going to the Heroku app control, not NightScout. To make sure this is done correctly open your NightScout app in a browser but do NOT log in; do not give NightScout your “API secret or token”. If you can get a view of your data without it then you don’t have the security stuff set up, you can just use autotuneweb without changing anything.

Otherwise you need to log in to Heroku itself, and this will mean doing 2FA but you should have that set up already. Basically you are going to the website https://dashboard.heroku.com/apps and that will take you automatically to salesforce.com and, eventually, you should be logged in.

In the following screen shots I’ve covered most of the name of my app with a white rectangle, this is because the app name is part of my security, I’ll explain more below:

NightScout is the first listed app; I put a yellow highlighter on the app then whited most of it out. Click on that line; the app name or the icon to the left of it:

Now you need to go to “Settings”; the tab on the right below the app name (whited out in my screenshot) and click on “Reveal Config Vars”; after doing that you will see something like this, but without the big Warning, that is there because I also changed the app name deliberately to show an example of how I changed the the name to something random for security:

At this point it is necessary to scroll down to find the “Config Var” that you need to change, it’s called AUTH_DEFAULT_ROLES and it is right below the API_SECRET (so I scrolled it to the top of the pane to avoid having to white out my API_SECRET as well). Click on the “pencil” icon to the right (NOT the “x” icon all the way to the right) and you will see something like this (except that I’ve started editting the value here):

The “Edit config variable” pop-up window will initially say “denied”, change this to “readable”. That value is one of the NightScout system default values; if you’ve changed NightScout to remove or modify it then these instructions won’t work, but if you did that you don’t need these instructions :smile:

After this simply click the “Save Changes” button, wait a few seconds, and go back to the NightScout browser window you opened right at the start. Refresh it; the request for your secrets should be replaced by the normal NightScout browser display. If not something I don’t understand is happening.

Now you can go to autotuneweb, follow the instructions and enter the URI of that window; the NightScout window which is now showing your data. I suggest doing 30 days if you have that much data. autotuneweb will display a window showing that it is processing the data; if not then I don’t think you have an authentication problem and autotuneweb should be displaying something helpful.

After a while it stops processing and sends you a nicely formatted email with the results; they’re pretty easy to understand. You might need to run it again with “UAM as basal” turned on; I’ve been very carefully recording my carbs so I did that after the first run suggested minor but random basal changes.

Changing AUTH_DEFAULT_ROLES is pretty much instantaneous; you can see it happening on the NightScout page (the first one opened above), as soon as you change the ROLE back to “denied” the page starts demanding your secrets. This is good however it means you shouldn’t change back to “denied” until you get the email; I tested it, I got an error from autotuneweb and the log said this (at the end):

Warning: API_SECRET is not set when calling oref0-autotune.sh
(this is only a problem if you have locked down read-only access to your NS).
Could not run oref0-autotune-prep ns-treatments.2022-07-07.json profile.json ns-entries.2022-07-07.json

4 Likes