Omnipod customer service is the worst!

I have been using the Omnipod 5 for several weeks. Customer service claims it is available 24/7, but every time I call I am either on hold for over an hour (and then am hung up on), or, if I leave a message, I do not get a call back for days. My Omnipod representative has been great, but she is not able to resolve my current issue, and even she can’t get in touch with customer support! It is something to seriously consider when choosing between Tandem and Omnipod, especially if this is your first time on a pump and you want support.

My issue is that my pod can’t find the Dexcom transmitter. My Dexcom app works fine on my phone so it’s not the transmitter. I changed the pod multiple times. I deleted the transmitter serial number and put it back in. My representative recommended putting it in manual mode and keeping it in manual mode until we hear back from customer service. The problem is that it keeps beeping me but it doesn’t tell me why I’m getting alerts.

If anyone has had a similar problem, please let me know and how you fixed it.

2 Likes

@Welcome to FUD @dianalewis. Great first post. First, we don’t use Omnipod so I am not the best resource for that. But we have a thriving group that is using Omnipod here so I expect you will get an answer very shortly.

On the customer service front, there really isn’t much good news. Dexcom, Tandem and Omnipod have all gone (going) through issues where their customer service is awesome, then periods where it totally sucks. Dexcom is currently in the sucky phase as well.

3 Likes

Maybe help here? Suggests old podd may still be paired

Resolved connection to PDM issue by moving the disconnected but still functional pod across the house- it was interfering with the new pod signal.

4 Likes

Thanks, Chris. The situation is outrageous. I am once again on hold with customer service for hours. I filed a complaint with the Better Business Bureau, but not sure that will help. Thanks for your post!

2 Likes

Thanks. I killed the old pods. I even tried connecting the new pod in different locations. I have had this issue multiple times since I started on the 5, but it has always resolved itself. Until now. I think I am going to contact the FDA and the Massachusetts Attorney General. This is outrageous.

2 Likes

I hesitate to even say this because you’re a renowned and experienced old hand, but you don’t have the Dex transmitter paired to the Dex receiver, right? Because the Dex transmitter only has two channels, and if the receiver has one and the phone has the other, there’s no possibility to also connect to the Omnipod-5.

I heard there can be a different issue in the absence of a Dex receiver, although I don’t fully understand it so I probably have the details wrong. Anyway, the issue is something along the lines of this: if the Dex phone app is the first to pair to the Dex transmitter, it might bind to the primary channel (for command-issuing DME like the receiver) rather than the secondary channel (for read-only apps on the phone, like the Dex phone app), so the pump might be locked out of the channel it needs.

2 Likes

Oooo thats super interesting. I am not a 5 user, but have noticed related behavior. I primarily use my phone for the dex, but occasionally pair my Bluejay watch as a receiver. I cannot push a calibration from the phone when they’re both paired but only the Bluejay. When its just the phone the dex calibrates fine. Interesting that one is set to read only, that isn’t clear from the documents I’ve seen.

1 Like

Sorry, that’s not a fact, it’s just my faulty recollection of a rumor from I don’t know where. I could have it entirely wrong, but was hoping to spark dianalewis with an idea of something else to try to see if it might help.

It’s about the type of device, medical or not, not channels, as per FDA.

1 Like

@dianalewis I’m using Dash, so not much help with O5. While BBB may work, I’d recommend filing a complaint with the FDA (Report a Problem to the FDA | FDA). I can appreciate the “being on hold” and “hung up on” issues, I think we’ve all experienced them. I understand the O5 has a separate support team form Eros/Dash, so you may want to ensure you’re talking to the right support folks at Insulet.
Just saw @bkh post that you’re an old hand at the game, I didn’t know, so apologies if you’ve already gone that route. I’ve had luck with going thru state AGs previously on a couple of issues with corporations, you may want to address both your own state’s AG and theirs.