FUDiabetes

Nightwatch help: watch upload problem

Hey I am having trouble getting nightwatch to upload to my watch from my phone. I followed my t1d on it for a month -6 weeks then it just stopped working. I have uninstalled , reinstalled, made sure the data is able to run in the background made sure to give it app permissions etc. I’m using a galaxy s10 plus and a galaxy watch. I can see dexcom notifications just not the actual number on my watchface. Please help this mama out. My t1d is going to Mexoco with dad and I’m a nervous wreck.

1 Like

Welcome, @Sroach5!

I am a Nightwatch user as well, but don’t use a watch display, only the phone. Hopefully someone else can help?

Will you be able to make Nightwatch work for you if you can’t get the info to the watch? I love the app but I have found that some functionality does not work with all hardware or OS versions.

Its doesnt even load on my phone/app. It was working and then one day just boom not working and I didnt change anything. It’s so frustrating.

So the problem is not only on your watchface but also on your phone app?

Yes its phone and watch app. I’m not sure how to make it work.

What version of Android are you running?

Rev 1.0 is the latest update I have.

Hmmm. It would likely be a. Version of Oreo 8.0 or Pie 9.0?

For instance, my version of Nightwatch runs in a Motorola X4 with Android Pie 9.0. Under Settings/System/System Updates I can see that my latest version is Android version 9 with a long update code number.

@Sroach5 did your watch unceremoniously stop working about 4 days ago? Mine (Huawei Watch 2) did out of the blue and it seems to possibly be an update issue that was pushed out to wear watches. I am currently trying to back up the update to see if things correct themselves or no.

1 Like

How would I find that? I’m not tech savvy at all.

1 Like

@Sroach5 information on updating your watch can be found at this link

@Michel l is trying to find out what version of Android you are running on your phone. To determine this, find the settings gear (usually accessible in the pull down menu at the top of the phone screen.; Scroll down until you see something that looks like “About Phone”. Usually the Android version listed there. Look for something like Version 6.6, or 8.0, or 9.0, etc.

1 Like


This is the info it gives me

1 Like

Perfect! Version 9.0. @Sroach5 Are you running XDrip also, or no?

1 Like

No how do I do that? Is there an app for.it? Do I have. a follow app?

@Sroach5. I’m just trying to determine where the data for your watch is from. Typically on a Nightwatch it’s from 1 of 3.sources:

  • Dexcom Share Servers (Acts as a follow app for Android)
  • xDrip
  • NightScout Site.

Determining the data source helps to find.the.solution. My watch is controlled as a follower through XDrip. It sounds like your setup is different.

1 Like

Ok so we have it running from night scout and dex. NS website is working and I can see #'s on it.

1 Like

No I dont have xdrip but I can download it if someone has a doc that has the steps!

You don’t need xDrip to run Nightwatch. It is one option for the data source though :slight_smile:

Are you feeding the data to Nightwatch from Dexcom share servers or from NS servers? I am not clear on that. The app needs to be set up to get the data from one of these sources.

I have tried running it through both separately and together on night watch and I’m still not getting it to come through nightwatch but both are working independently without nightwatch.

1 Like

So the next things to check are:

• How does Nightwatch get the data? Through a BT connection with your phone, or directly through a 3g/4g connection
• If BT, is there a connection with the watch? (mine sometimes fails and I toggle the BT off for 30 seconds and re-enable the BT - then everyone is happy again.

• are you accessing the correct NS page/are you logged into the Dexcom servers with your acct name/pword on the watch

• If you are logged into the Dexcom servers, is Dexcom having an issue (verify by logging in through web based portal on computer)

• buffering… please stand by…buffering…