FUDiabetes

LOOP: reinstall musings

I bit the bullet and ordered an iPhone SE 2020 which should arrive tomorrow.

I’m going to do a complete from scratch install of Loop using the windows Virtual machine on my PC to set up the latest build of LOOP.

Would anyone be interested in me recording my steps on Camtasia ? Would be a bit of work, but if people could learn from it, I would be inclined to do it, but only if people want it.

3 Likes

That would be fantastic. I think there are a lot of people, me included that would like to see a setup in action. Unfortunately we can’t host video here, but we can link to it of course.

Generally, I find it quite interesting to watch how diabetics use technology in their daily lives and how well these things work in practice, but an instruction video about installing loop won’t be relevant for me, I’m afraid.

5/17/2020 WARNING! This is RATHER LONG! But here goes:

I posted on many boards to see if there was any interest in me doing a Camtasia video but didn’t get enough interest, so I scrapped that idea. Good thing I did! I had nothing but continuous PROBLEMS! So here goes:

Once the phone was charged, I made sure it had the latest IOS update and activated it on the Visible phone network that uses Verizon as a backbone.

I then downloaded the Dexcom G6 software.

Loop wise, I followed http://www.loopdocs.com to a T.

  1. Following https://macosvmware.tech.blog/ , I installed the base Mac OS 10.15 using Vmware.

  2. My BIOS wasn’t configured for virtual machines, so I had to tweak that.

  3. Once the virtual machine was running, I tried to update to the latest OS, but I didn’t have enough space on the virtual machine.

  4. I googled and expanded my virtual machine from 40 to 80 GB. The update then took.

  5. I checked Xcode to make sure it was the latest version and attempted to build. Failed. Come to find out there is a newer version of Xcode needed, but the app store only shows it through the developer site.

  6. Once I found that version, again I didn’t have enough hard drive space in the virtual machine, so this time I just expanded it big to 200 GB and tried again. That time it worked.

  7. Once that was installed, I continued to follow the directions and got it compiled.

If I had to guess, I’d say all of the above, with mistakes and errors, took a good 20-30 hours over two days.

There were several times I wanted to give up, because, while I am a techie at heart, I’m horrible at anything Apple. But perseverance paid off in the end, and I now have the latest build of LOOP and good functioning virtual machine so that when it comes time to update it again, it should be much simpler.

If anyone has any questions, feel free to reply here or PM me.

3 Likes

Glad you got things working. Sounds like my implementations.