FUDiabetes

Looping help

I am trying to build my loop app for Omnipod. At the recent TCOYD conference, Katie DiSimone said to go ahead and use the Loop-dev branch. However, the build won’t accept the Omnipod. Here is the error message I am getting. Can anybody help?? Thanks!!!

PS I tried the branch for Omnipod specifically but got 2 messages about Swift 5 and a deprecated file. No clue!!

func getPumpManagerTypeByIdentifier(_ identifier: String) -> PumpManagerUI.Type? {
for bundle in pluginBundles {
if let name = bundle.object(forInfoDictionaryKey: LoopPluginBundleKey.pumpManagerIdentifier.rawValue) as? String, name == identifier {
do {
try bundle.loadAndReturnError()

                if let principalClass = bundle.principalClass as? NSObject.Type {

                    if let plugin = principalClass.init() as? LoopUIPlugin {
                        return plugin.pumpManagerType
                    } else {
                        fatalError("PrincipalClass does not conform to LoopUIPlugin")
                    }

                } else {
                    fatalError("PrincipalClass not found")
                }
            } catch let error {
                print(error)
            }
        }
    }
    return nil
}

Which branch is that? I have used JoJo. And I think some people here have used JoJo-Beeps, maybe @ClaudnDaye and @Trying.

1 Like

@CatLady The dev branch does support OmniPod, as does Jojo-beeps.

Did you do a fresh pull from from the dev branch, and perhaps a clean build?

1 Like

The branch has no problems with the Omnipod at all. You can use it with the new Dev branch. I used it briefly, then reverted back to Jo-Jo beeps.

You may need to do a full clean build as @Trying indicated.

2 Likes

The looped group is really good about helping out as long as you do your due diligence so if you are going to post your problems, make sure you first do research on the looped group/loopdocs site, search forums for the same issue, indicate what steps you have taken, take screenshots to post on your thread, and state the problem. The more the community knows, the less they need to eliminate form the help offered.

Or you can ask the questions and seek help in Zulip.

3 Likes

Thanks, everybody. This has been so frustrating! I created a Zulip account and made a screenshot but am walking away from it for now ‘cos I gotta settle my mind before teaching a restorative yoga class this evening. :pray:

After your Yoga class can you capture a full screen shot of Xcode, right before you hit the Build/ Play button, and post it?

I’m around if you need help (I’ll send you a PM with my cell #). Like Harold said, the Looped Facebook page has a large village of folks who really want to and know how to trouble shoot this kind of thing. The keys is to post screen shots that show the exact thing you need help with and provide the details of the trouble shooting you have already done and what happened.

I had a weird error the first time I tried to build it and I finally just deleted all previous loop related downloads from my download folder, downloaded Xcode and the loop branch again and then was able to successfully build it.

You got this.

Lisa

4 Likes

That is my plan for Sunday…

2 Likes

I also had some errors the first few times. I had to restart it and retry and eventually it worked.

Wish I could offer some help here. But like Lisa said, try to download and start again. After it works the first time, it’s easy after that!

2 Likes

I didn’t realize so many of us are (will soon be!) looping! Awesome!

Katie D via Zulip told me that there is a new version of XCode just released so a lot of work is being done to update the branches right now. That’s why I had so much trouble. I’d actually started the process a couple of weeks ago but was a bit under the weather so I postponed my build.

5 Likes

Finally looping!!! :smiley_cat::clinking_glasses::pray:

Had to use the Omnipod specific build ‘cos the loop dev branch would not let me proceed with the choose pump step. (Contacted the folks on Zulip but not able to help.) But it is up and running in open mode.

6 Likes

Awesome! Congrats!

1 Like

Just FYI, the new v2.0 master version of loop has been released. It has support for overrides, omnipods, and more. It’s no longer necessary to run the development branch or jojo branch to get these features.

https://github.com/LoopKit/Loop/archive/master.zip

3 Likes