Loop is working WITHOUT Dex app being open

Does anyone know how to get Loop in this state? I like it, but I am not sure how to make it happen consistently!

Usually (I think) you need the Dexcom app running to get closed Loop to work.

I only do closed Loop when I am asleep. The problem with having the Dex app running on your phone is that when it alarms, you have to unlock the phone to acknowledge the alarm. (It’s much easier to just use the Dex receiver, because you can hit the 2 buttons to acknowledge the alarm. Easier than unlocking your phone.)

Every once-in-a-while, I can get my Loop to be in this state. And I really like it and wish I could always do this.

Does anyone know how I can make this happen all the time?

Dex alarms are turned off:

Loop still works, and BG number is still showing in the Loop app:

1 Like

Not sure about that but I turned off all Dexcom notifications and alerts and only get a phonecall from Sugarmate during the nights which I can push a single button to hang up without needing to unlock phone. Maybe something you can investigate?

1 Like

So does closed Loop always work for you with Dex notifications turned off?

That’s what’s confusing me. Usually the only way I can do closed Loop is by turning the Dex on.

Yes, notifications from Dexcom have no influence on loops operability. As long as the sensor and transmitter work and are providing data, loop works fine with or without notifications on.

1 Like

It is odd for me though, sometimes when I have closed the Dexcom app, Loop no longer “sees” the Dex number. It just disappears in the Loop app.

Just to be sure I understand…you ARE talking about the “notifications” as in…bells and alerts that sound annoyingly all through the day and night? If that’s what you’re talking about, yeah…they have nothing to do with Loop operability so I’m confused why your Loop would stop working and/or your CGM #'s stop showing in Loop and preventing loop from working. Never heard of that before.

1 Like

What I generally do in the morning is close the Dexcom app and turn off notifications. In the past year, Dexcom made this annoying change where it would still alert you even though the app was closed on your phone. So annoying!

So now what I do in the morning is close the Dex app and turn off the Dex notifications, so the Dex app on my phone remains silent all day.

Usually when I do that, the CGM number no longer appears in the Loop app. I just assumed that was normal behavior.

You are saying I do not need Dex running on my phone at all, right? I mean, yes it is installed, but it does not need to be running.

That’s just different from what I normally see.

1 Like

No I never CLOSE the Dexcom app, I just turn off notifications and I don’t get the annoying alerts. That’s probably why your loop stops working…If the app is closed, it can’t feed the numbers into loop. I don’t know why just turning off notifications without closing the app isn’t sufficient? I know there are some annoying quirks with multiple sound settings, etc, but if you turn off notifications in the app AND in the phones general settings area for that specific app, the notifications should stop, and you shouldn’t have to close the app at all thereby allowing loop to continue working.

Settings —> Notifications —> Find Dexcom and open that up —> turn OFF the “Allow notification” radio button.


The change Dexcom made to their app no longer allows me to open the app if notifications are turned off. It’s some liability thing I guess.

If I try to open the app when notifications are turned off, it says you have to allow notifications before you can use the app.



But currently on my phone, the Dexcom app is closed, notifications are turned off, and Loop is still working!

It’s been like this for two days now, which has been great!


I’ve never seen that message before. Very odd. Hopefully it stays working for you!


Firstly, I think the Dex App does vary depending on iOS version and Country.
My “Canadian” version on iOS 16.x does not have the alerts options you have…
I also noted I can create additional notification profiles, but I don’t have the Critical categorization you have. (Rather, I’m unable to truly turn off the Urgent Low, Transmitter-failure and Sensor-Failure alert).

have you by any chance enabled the notification Scheduling feature in iOS 15x +?


We couldn’t have those alerts and alarms going off at all hours during the day while he’s in class at school so if we couldn’t disable then I’m not sure what we’d do.


@ClaudnDaye, that’s so crazy that you are able to disable them. The only Dex alarm my phone has is critical low, but I can’t disable that one anymore and still use the app.

What’s even crazier is that today my phone did not have Dex running but my wife was still getting my BG on share. How is that possible?!?

1 Like

I am not 100% sure yet that this trick is the way to do it, but this seemed to work when I am trying to get Loop to run without needing the Dex app open.

I make sure the Dexcom app is closed, and I make sure the notifications are turned off. Then I go into Loop and delete the CGM and add it back, putting in the transmitter ID.

I did that last night and Loop worked all night, making basal adjustments, and it could see my CGM number, but my phone never made a sound - no Dex alarms! (I am using my receiver at night instead of the phone.)

Curious if this works for anyone else using loop. :thinking:

One other note. This seems to work as long as I keep the phone with me so it can continue to get the CGM signal. As soon as I distance myself from the phone for several minutes and it can no longer get the CGM signal, the Dexcom value disappears from Loop and does not come back until I delete the CGM and add it back. Once I delete it and add it back, the number is there in Loop again. And stays there for as long as the phone is with me.

Oh my gosh, this is confusing! But I think I figured it out.

Anyone else want to try this and see if it works for them?

1 Like

I sometimes have my Dexcom app closed on my phone, and loop will still get BGs. I haven’t had to delete/add the CGM in loop for this to happen. I think loop listens in on the BGs being transmitted so even without Dex app open, BGs will still continue to transmit.


I am loving this undocumented (and probably unintended) “feature”! As long as I can keep doing this, I will keep Dexcom closed on my phone!

If you want to try these repro steps to see if this is a consistent way for you to make it happen, here they are:

  1. Close your Dexcom app and turn off all notifications for Dexcom.

  2. In Loop, delete the CGM in settings, and add it back (still keeping Dexcom closed). This is an easy thing to do. a) you just delete it, and b) add it back (all you need to do is and enter your transmitter ID number). Just 2 steps, super simple!

  3. Wait a few minutes for Loop to connect to your transmitter. This usually only takes a few minutes to happen.

  4. You should now see your BG numbers in Loop, and they should stay there until you separate yourself from the phone for 5+ minutes.

  5. Anytime you want to get BG back into Loop without the Dex app running, just delete the CGM in Loop and add the transmitter number back. (Step 2 above).
    I think the only time you need to do this is when you are separated from your phone and it can’t get the BG signal for 5+ minutes.

It’s pretty easy to do this. And it’s great that you can see the number in Loop and not have any noise from Dex alarms, like when you are in a quiet place. And Loop still can run and make basal adjustments!

If you have the Loop widget thing on your phone, you can even see your BG number on Loop without unlocking your phone.


Thanks, @Eric, for the details. Yes, I do use the widget on my phone. And I try not to separate myself from my phone and rileylink because, even without your method, Dexcom usually takes its time to reconnect if I do! Maybe your method will solve the slowness with Dexcom app, too, on reconnecting!!! Thanks for this tip!!


@Trying, let me know! Always helpful to get it confirmed by others!

So far it’s been very consistent for me. Just took a while to figure it out.


@Eric et al, I’ve been following this discussion with interest. One question for @Eric: how do you have Loop getting the Dex info, directly or via Dexcom Share? That might explain how it functions without the app running. I believe you can do either, but that may be a Nightscout thing. My experience has been if Dexcom app isn’t active, Loop fails to get CGM data, similar to what I understand @ClaudnDaye said above. I haven’t tried the steps you outline for CGM activation, so you may have found a work around.

Also, I’ve been able to reduce alarms to solely the “Urgent Low Soon” alert from anything, but like others can’t get “no” alerts. While I curse the alerts at times (I don’t have the school issue Liam deals with, retired and don’t care what others think), I prefer them to going low or high beyond set limits. I just wish we could set our own alert sounds, innocuous to others but alerting to me; seems the doorbell is the least obnoxious, but it throws others off if I’m in a group setting and requires explanation.

1 Like