FUDiabetes

Dexcom G6 bug: you must swap a new sensor in MORE than 7 minutes

dexcom

#1

I just wanted to add that Eric had an unusual occurrence tonight. And I think that weshould probably start a new thread about it if anyone has also heard this. This evening he swapped out his sensor really quickly - he was in the restroom at a restaurant late to a meeting. His sensor died and he needed to start a new session. After the two hour warm-up period finished, the receiver/iPhone app said that he had no sensor attached. Here he explains:

“This sensor failed because I swapped it too quickly. You have to click stop, wait a minimum of 7 minutes; then click start. It’s a bug they just discovered and are working to fix.

If it is switched too rapidly it thinks it is still a continuation of the prior session. So instead of a 2-hour warm up period it throws a “your session is about to expire” and then it dies.”

This is the third sensor in a little more than week I think. One was a massive bleeder (which seems to be a thing for others) and he pulled it because it was midnight and he didn’t want to have to wait another two hours if it didn’t work. The next one just fell off. This recent one had the glitch. Additionally with his current transmitter, the app says it should be good for another 10 days, but it is 1 day past its stated expiry date (some other kind of bug).

Anyone else have this glitch show up?


Repeated Dexcom G6 failures
#2

Interesting! I haven’t had that particular issue. I did have one last week that prompted a calibration after the warmup (again). It didn’t accept the calibration and asked for another. It did this 3 times before I gave up on it. The next two were crazy bleeders. It wasn’t a good Dexcom day! I’ll keep an eye out for that glitch… and will continue waiting a bit before starting a new one.


#3

This happened to me on my last sensor for the first time. I believe it relates to the transmitter only communicating with the receiver/phone every 5 minutes and the receiver/phone only being able to communicate the current state of the sensor, so if you are super speedy with your site change, you could conceivably stop and have another sensor already going when the transmitter checks back in with the receiver/phone and I think it glitches out on that scenario. For it to happen, it takes a pretty perfect storm though; I think you have to coincidentally stop the sensor immediately after its last receiver communication and then be totally wrapped up with the new sensor start before it checks back in with the receiver.


#4

Nice sleuthing!


#5

Hi-Yes I too struggled with having to change out my sensor due to malfunctions or bleeding sites. What I learned is to wait before taking another sensor off. Hit End Sensor and then new sensor and start up without a code, wait 5 minutes and end sensor again and start up with the actual code. That way I don’t have to waste a brand new sensor. As for the bleeding-I’m still working on it. I have tried ice before hand and it can help but really it is a hit a miss (no pun intended).


#6

I’m wondering how this particular glitch might affect restarting a sensor? I’ve been successful restarting my last two, not paying attention at the time to timing.

Today I tried to restart. I disconnected from Bluetooth, stopped sensor, and tried waiting the 7 minutes. Unfortunately, the wait was long enough that the “forgotten” Bluetooth connection tried to reconnect. I declined it’s request to reconnect, but the screen then switched to the “can’t find transmitter” message rather than the “new sensor” message. So I was stuck.

I reconnected Bluetooth just to see what would happen, assuming all was lost, and surprisingly the old session came back to life, after having stopped the sensor maybe 10-15 minutes prior. I didn’t realize it would do this?

So I tried again, disconnected Bluetooth, stopped sensor, and started new again almost immediately - no 7 minute wait this time. It’s in its 2 hour warmup now but I’m having real doubts it’ll work given how messy the process was.


#7

Miracle of miracles… it worked!

Correction - nope. It turns out it started the old session back up, as it still says the session expires today. I tried again and once the bluetooth tries to connect, the “new sensor” button is gone. I’ll just switch this out one when i get home tonight and try again in 10 days :frowning:


#8

Wow-that sounds so frustrating! You lost me along the way but I am really a novice and can’t offer any suggestions but good wishes.


#9

Thanks for the well wishes! Do you use the G6? Have you had a good experience with it? I’ve been very happy with it, save for a few frustrations with starting up new sensors (and my probably self-inflicted trouble re-starting one yesterday!)


#10

Hi-Yes I feel your pain regarding self inflicted errors! I am using the g6 as of this past fall. Prior to that I was a true MiniMed girl for almost 30 years. The g6 is night and day compared to mm. I am SO happy. I completely know what you mean about the frustration of loss connection and the the incredible joy when the screen starts working. I am waiting for a new transmitter to attempt to pair the g6 with my t-slim. The first go around wasn;t successful. That will be my next help post I am sure! Enjoy your week-end.