FUDiabetes

Any way to detect Omnipod needle not retracting?

Just removed onmipod (pod) from my daughter and found the needle not retracted. I imagine is was significantly more painful than the normal pump cannula.

Anyone else have this problem recently?

Is there any way to know this - seems like there should be an alarm or at least warning

From reading google search results seems it was a problem in 2014-2016

Ed

1 Like

Am yet to experience this although sure that the others have…sorry to hear about that

2 Likes

@EdD
The trick is to look at the little colored patch on the pod. It shows that the needle retracted. If you don’t see the yellow dot in the right place, it did not retract properly.

The dot is part of the needle insertion component. So wherever that dot is, that’s where the needle is too.

4 Likes

Thanks @Eric but I’m not sure I follow…

these are the last 2 pods - one worked fine the other has the needle still out (inside the cannula)

I wonder did it break so the mechanism thinks it retracted?

or am I missing the difference?

Ed

1 Like

Did you remove the pod and still see the needle stuck out?

Yes the cannula is rigid after removing the POD which has been used for 3 days. Looking very closely I can see a very small amount of silver (needle tip) and the end of the cannula even now.

Its not a huge issue - I would just like to check it if possible.
I’ll probably email omnipod the photos and let them know.

Ed

3 Likes

Yes, when you remove it, if the needle is still sticking out and is rigid, you should report that and send it to them for analysis.

2 Likes

It’s probably easiest to understand with some pictures, I only have correctly working Omnipod (Dash) pods, so I don’t have a failed example, but I think this might be sufficient. Firstly the top, basically a duplicate of the posts above:

that’s a bit out-of-focus because I couldn’t persuade my camera to focus on the top of the top, rather it is focused on the writing underneath. Also I had dremel’ed if off to produce the following photos, firstly the top flipped, so you can see what the yellow dot is:

Kinda mysterious, but I hope clearly fixed in place; the picture is with the top rotated in X, so top-to-bottom (the yellow dot was at the top in the first picture, now it is at the bottom, but the same place left-right). The mystery is explained by the picture of the internals, which has the same orientation as the first shot:

The yellow dot is connected to those two weird pokey things inbetween and below the two nylon cogs. They are springs which make, I believe, electrical contact. The dot itself is, I believe, a clicker; like those annoying things we all had in the '70s (1970s, not 1870s, please, bear with me) that we used to annoy people by clicking inappropriately. This, however, is in a Dash pod.

The really important thing is the PINK (my favorite colour) thing immediately below the clicker contacts. This is connected to the catheter, I think that is clear (the white dust is the result of using a Dremel cutoff tool to melt the top off). The theory is that the PINK thing should only be in that place if the catheter has been inserted.

What happens if the needle does not retract? That is a damned good question; the needle is the wire loop connected to the white nylon to the left of the pink thing. The white nylon bit is connected to the complex gear to the immediate left of itself.

Inadvisable poking with a letter opener (I wear glasses, so the bits of plastic that flew off didn’t injure me) produced the following picture:

What I did there was to break the brassish lever arm off the nylon attachment then push the nylon back to the pink bit. This re-inserted the needle, into the canula (catheter, whatever):

(Ha, I’ve worked out how to use my camera again, along with working out what the damned thing in my skin is called!) Here is the result when I pull the nylon bit back to the original position, retracting the needle:

My conclusion is that there is absolutely no way to tell from external examination whether or not the needle has retracted, which is obviously a serious problem for people looking after those unable to communicate exactly.

8 Likes

Awesome post @jbowler! I loved it and thanks for posting! I had always thought about taking a pod apart to see what three innards looked like… Now my fix had been quinched. :laughing:

1 Like

@jbowler thank you very much for posting and taking the time to put that all together (and take the POD apart). it is definitely difficult if not impossible to detect with a visual inspection.

I am going to research the software logging/messaging side - maybe there is something there that would be useful

Ed

2 Likes

@EdD: I’ve just worked out something that might help.

Do you see the brass lever arm assembly at the left, attached to the needle retractor in the first picture and forcibly detached in the second? There is a very powerful spring that drives the lower piece of the lever arm:

I re-attached the arm to the white nylon slider and forced it back into the needle-extended position:

With a bit of wire it is possible to hold it in almost that position and re-attach the top, I believe this fakes the condition where the needle does not retract or only partially retracts:

It is just about possible to see the brass lever arm through the opaque white cover. It is actually slightly clearer with the naked eye, but here’s a picture of the correct position, taken using another Dash pod:

The washer is for camera focus, see the vague yellowish outline below it. The following is a picture of the needle extended arrangement:

The yellow bit isn’t there; it’s towards the (orange) clamp.

Anyway, I tried several ways of making it clearer. Shining a bright LED flashlight at various angles did not help - too much reflection. I didn’t try using a hood to direct all the light into the pod, that might help, but the basic problem is the opacity of the white pod cover. I tried spraying silicone grease on the top to clear up the rough surface but that only helped a little. I guess thicker grease might be better.

The only way I could make it clear was by post-processing the original camera images. Here’s the result of PhotoShop’s raw camera import with +100 contrast, +100 clarity and +100 dehaze. It’s the dehaze processing that makes the real difference:

Needle retracted external view of lever arm, photoshopped

That’s the needle retracted; the second part of the brass lever arm is clearly visible. Here is the same processing with the needle still (partially) extended:

Needle extended, external view of lever arm, photoshopped

It’s not as clear but I think it is clearly different from the retracted image.

It should be possible to do this in-camera if a suitable filter is available. I got a sufficiently clear view of the interior with “Grainy Film I” on my (Olympus) camera and simple monochrome helped a lot too; I didn’t need to take a picture, looking at it on the LCD screen was sufficient, indeed it was a lot less clear on the photo (it helps using smaller images because it eliminates the roughness of the outer shell of the pod.)

I also tried with an iPhone using the “mono” filter; the result was “ok”. It probably helped that I tried it in a room with bright but flat lighting. I’m pretty sure if the iPhone switched on the LED it wouldn’t work.

5 Likes

some great analysis and idea’s in there - I really appreciate your effort.
I am going to try to open the bad POD and a good pod this week and try to see what seems to have gone wrong

Ed

2 Likes

The ways I’ve heard of fixing the failure to retract the needle simply involve manual force; tapping the pod or hitting it with something while the pod is still in-place. I suspect that removing the top might cause the retraction mechanism to suddenly work, possibly with some danger of bits flying out of the disassembled pod quite fast (that spring is pretty strong).

2 Likes

I thought it was the yellow dot, but after reading their site, Insulet describes the red dot as showing proper deployment. But they don’t go so far as to say it shows retraction.